|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- Fp-scrubber daemon
fpsd is a user-level daemon that periodically runs non-intrusive tests to validate proper functioning of FPU (Floating Point Unit) hardware in the system. A fault management action is initiated by means of fmd(1M), in case an error is detected by the test.
fpsd is not supported on all Sun systems. On a system on which it is not supported, fpsd is automatically disabled.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The fpsd service is managed by the service management facility, smf(5), under the service identifier:
You can use svccfg(1M) to change the default fpsd behavior:
Property Name Type Description ------------- ---- ----------- config/exclude_cpus astring comma delimited list of CPU IDs to be excluded from proactive testing.
Disabling the service can increase system's vulnerability to silent data corruption, if a fault were to develop in an FPU within the system.