|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- add (create) a new group definition on the system
/usr/sbin/groupadd [-g gid [-o]] [-S repository] [-U user1[,user2..] ] group
The groupadd command creates a new group definition on the system by adding the appropriate entry to the group database in the files and ldap repositories.
An administrator must be granted the User Management rights profile or have solaris.group.manage authorization to be able to add a group. Once the group is successfully added, the administrator is granted the authorization to modify and delete the group. The format of the authorization is solaris.group.assign/groupname, and can be managed by means of usermod(1M).
The following options are supported:
Assigns the group id gid for the new group. This group id must be a non-negative decimal integer below MAXUID as defined in /usr/include/sys/param.h. The group ID defaults to the next available (unique) number above the highest number currently assigned. For example, if groups 100, 105, and 200 are assigned as groups, the next default group number is 201. (Group IDs from 0-99 are reserved by SunOS for future applications.)
Allows the gid to be duplicated (non-unique). An administrator must have solaris.group.assign authorization to use this option.
The valid repositories are files and ldap. The repository specifies which name service will be updated. When repository is not specified, the files repository is used. When the repository is files, the user name and other items can be present in other name service repositories and can be assigned to a group in the files repository. When the repository is ldap, all the assignable attributes must be present in the ldap repository.
Adds a list of users user1, user2 to the group.
The following operands are supported:
A string consisting of characters from the set of lower case alphabetic characters and numeric characters. A warning message is written if the string exceeds MAXGLEN-1, which is usually eight characters. The group field must contain at least one character; it accepts lower case or numeric characters or a combination of both, and must not contain a colon (:) or NEWLINE.
The following exit values are returned:
Invalid command syntax. A usage message for the groupadd command is displayed.
An invalid argument was provided to an option.
The gid is not unique (when -o option is not used).
The group is not unique.
The group database cannot be updated.
See attributes(5) for descriptions of the following attributes:
groupadd adds a group definition to the system. If a network name service is being used to supplement the local /etc/group file with additional entries, groupadd verifies the uniqueness of a specified group name and group ID against the external name service and uses the entries in the files repository.