|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- Service Tag Listener
The in.stlisten daemon allows a mechanism for discovering the location of the Service Tag. By default, the in.stlisten daemon listens for discovery probes (using a minimal built-in protocol) on TCP port 6481.
The daemon is under control of the service management facility, smf(5), under its inetd framework. It only runs upon demand and exits when no longer in use.
See attributes(5) for descriptions of the following attributes:
In open networks where the participants may not always be trusted, it is recommended that you deploy this daemon with the passphrase-encryption option. In smf(5) environments, the following command can be used to set the passphrase:
< prepare a text file "passfile" containing the passphrase > # chown svctag:daemon passfile # chmod 600 passfile svccfg -s svc:/network/stlisten \ setprop servicetag/passphrase=passfile
where passfile is the path of a file containing the intended passphrase.
This passphrase can be subsequently cleared as follows:
svccfg -s svc:/network/stlisten \ setprop servicetag/passphrase=""