|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- mount hsfs file systems
mount -F hsfs [generic_options] [-o FSType-specific_options] [-O ] special | mount_point
mount -F hsfs [generic_options] [-o FSType-specific_options] [-O] special mount_point
mount attaches an ISO 9660 filesystem (the High Sierra file system, hsfs, is a draft predecessor to ISO 9660, so the name reflects the filesystem's history) to the file system hierarchy at the mount_point, which is the pathname of a directory. If mount_point has any contents prior to the mount operation, these are hidden until the file system is unmounted.
If mount is invoked with special or mount_point as the only arguments, mount will search /etc/vfstab to fill in the missing arguments, including the FSType-specific_options; see mount(1M) for more details.
A file system conforming to ISO 9660 can contain extensions that allow it to overcome limitations of the original ISO 9660:1988 (version 1) standard. The following types of extensions are supported by hsfs:
This is the preferred type of extension as it allows file attributes, name length, and types equivalent to those on other UNIX-style filesystems. Example of supported features are device special files, POSIX permissions, symbolic links, and filenames of up to 255 bytes in length. Rock Ridge extensions also remove the ISO9660:1988 restriction on maximum nesting depth for directories (eight levels). hsfs automatically detects the presence of Rock Ridge extensions and uses them, unless mount options are specified to disable the use of Rock Ridge or to use a different extension.
The first version of ISO9660, released in 1988, supported only uppercase ASCII filenames of no more than 31 characters in length. ISO9660 version 2, released in 1999, provides an extension that allows filenames of at least 207 bytes that can use UTF-8 characters and removes the limitation on the nesting depth for directories. Unlike Rock Ridge, it does not provide support for UNIX-style file types and file attributes. hsfs automatically detects this extension and will use it for filename lookup if no Rock Ridge extensions are found on the media.
The Joliet extension was devised by Microsoft to allow Unicode (UCS-2) long filenames with CDROM-based media. It allows filename lengths of up to 110 Unicode characters and does not support UNIX-style file types and attributes. hsfs falls back to using Joliet if such an extension is present and neither Rock Ridge nor ISO9660 version 2 extensions are found.
If filenames are longer than the 64 UCS-2 characters officially allowed by Microsoft (that is, 110 Unicode characters), they can translate to up to 330 UTF-8 octets. Filenames that translate to more than 255 UTF-8 octets will be truncated.
See mount(1M) for the list of supported options.
Specify hsfs file system specific options. If invalid options are specified, a warning message is printed and the invalid options are ignored. The following options are available:
If global is specified and supported on the file system, and the system in question is part of a cluster, the file system will be globally visible on all nodes of the cluster. If noglobal is specified, the mount will not be globally visible. The default behavior is noglobal.
Mount the file system read-only. This option is required.
Enable (rr) or disable (nrr) the use of Rock Ridge. rr is the default and need not be specified. If you use nrr and Rock Ridge extensions are present in the file system, ignore them and search for other available extensions or fall back to plain ISO9660.
Enable or disable the use of ISO9660 version 2 extensions. If vers2 is specified and ISO9660 version 2 extensions are available, hsfs will use ISO9660 version 2 even if the file system contains the preferred Rock Ridge extensions as well. If novers2 is specified, it will fall back to using either Joliet extensions or plain ISO9660 even if ISO9660 version 2 extensions are available.
Enable or disable the use of Joliet extensions. If joliet is specified and Joliet extensions are available, hsfs will use them even if the file system contains the preferred Rock Ridge and/or ISO9660 version 2 extensions. If nojoliet is specified, it will fall back to using plain ISO9660.
File names on High Sierra file systems consist of a proper name and an extension separated by a '.' (dot) character. By default, the separating dot is always considered part of the file's name for all file access operations, even if there is no extension present. Specifying notraildot makes it optional to specify the trailing dot to access a file whose name lacks an extension.
Exceptions: This option is effective only on file systems for which Rock Ridge, ISO9660 version 2 or Joliet extensions are not active, either because they are not present on the CD-ROM, or they have been deliberately disabled via the nrr, novers2 and nojoliet option. If either extension is active, hsfs quietly ignores this option.
File names on High Sierra/ISO9660 CD–ROMs with no extensions present should be uppercase characters only. By default, hsfs maps file names read from a non-Rock Ridge disk to all lowercase characters. nomaplcase turns off this mapping. The exceptions for notraildot discussed above apply to nomaplcase.
Overlay mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a preexisting mount point without setting this flag, the mount will fail, producing the error: device busy.
Example 1 Mounting and Unmounting a DVD Image Directly
The following commands mount and unmount a DVD image.
# mount -F hsfs /images/solaris.iso /mnt/solaris-image # umount /mnt/solaris-image
table of mounted file systems
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than on top of the symbolic link itself.