|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- rebuild the data base for the mail aliases file
newaliases rebuilds the random access data base for the mail aliases file /etc/mail/aliases.
newaliases accepts all the flags that sendmail(1M) accepts. However, most of these flags have no effect, except for the -C option and three of the Processing Options that can be set from a configuration file with the -o option:
Use alternate configuration file.
Specify possible alias files.
Set the default log level to n. Defaults to 9.
Validate the RHS of aliases when rebuilding the aliases(4) database.
newaliases runs in verbose mode (-v option) automatically.
Example 1 Running the newaliases Command
The following command runs newaliases on an alias file different from the /etc/mail/aliases default in sendmail(1M):
example% newaliases -oA/path/to/alternate/alias/file
newaliases returns an exit status describing what it did. The codes are defined in /usr/include/sysexits.h.
Successful completion on all addresses.
User name not recognized.
Catchall. Necessary resources were not available.
Syntax error in address.
Internal software error, including bad arguments.
Temporary operating system error, such as “cannot fork”.
Host name not recognized.
Message could not be sent immediately, but was queued.
Symbolic link to /etc/mail/aliases
ndbm files maintained by newaliases
Berkeley DataBase file maintained by newaliases
See attributes(5) for descriptions of the following attributes: