|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- network status monitor
statd is an intermediate version of the status monitor. It interacts with lockd(1M) to provide the crash and recovery functions for the locking services on NFS. statd keeps track of the clients with processes which hold locks on a server. When the server reboots after a crash, statd sends a message to the statd on each client indicating that the server has rebooted. The client statd processes then inform the lockd on the client that the server has rebooted. The client lockd then attempts to reclaim the lock(s) from the server.
statd on the client host also informs the statd on the server(s) holding locks for the client when the client has rebooted. In this case, the statd on the server informs its lockd that all locks held by the rebooting client should be released, allowing other processes to lock those files.
lists hosts and network addresses to be contacted after a reboot
lists hosts and network addresses that could not be contacted after last reboot
includes a number which changes during a reboot
contains the rpcgen source code for the interface services provided by the statd daemon.
See attributes(5) for descriptions of the following attributes:
The crash of a server is only detected upon its recovery.
The statd service is managed by the service management facility, smf(5), under the service identifier: