|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Information Library|
- network auto-magic configuration management
Network configuration can be managed automatically, according to default policy rules defined by the system, or to user-defined policy rules. This management is performed by the nwamd daemon.
The NWAM facility is provided by the network/physical:default SMF service. NWAM configuration management is enabled if the netcfg/active_ncp property is set to the name of an NWAM NCP. Alternatively, traditional network configuration is performed if the netcfg/active_ncp property is set to DefaultFixed.
The default configuration policy, implemented in the Automatic NCP, is to have all physically connected Ethernet links active; if no Ethernet links are available, a single wireless link is made active. DHCP is used to obtain IP addresses for all active links. This default policy can be changed by creating alternate Network Configuration Profiles (NCPs). The nwam-manager GUI tool or the nwamd(1M) command can be used to create and modify NCPs.
If you used an earlier version of the NWAM service, which created an /etc/nwam/llp configuration file, configuration present in that file is automatically incorporated into the User NCP upon upgrade to the current version of the NWAM service.
The automatic behavior provided by the NWAM facility requires that management of the network configuration be handed over to the NWAM service. Any manual changes to the network configuration might be lost if conditions change such that a new profile is activated, or if the NWAM service is restarted. If persistent changes are desired, the recommended approach is to create an External Network Modifier (ENM), which can be activated and deactivated as needed by the NWAM service.
The following list takes the form:
Enables debug logging using daemon.debug.
Indicates whether open WLANs should be connected automatically, in the absence of a better (more preferred) choice.
The number of seconds to wait for an NCU (or link/interface NCU pair, as appropriate) to come up before trying the next available NCU. The bringup activity is not cancelled, and might eventually succeed, at which time the more preferred NCU is activated and the alternate might be disabled, depending on the specified configuration conditions.
The number of seconds between periodic condition checks for conditionally activated objects. Minimum value is 30 seconds.
The number of seconds between periodic wireless scans.
A signal strength threshold; if the currently connected AP drops below this signal level, and equivalent APs (of the same ESSID) are available at higher signal strength, the existing connection is dropped in favor of a connection to an AP with stronger signal.
If true, both ESSID and BSSID must be matched in order to connect to a previously connected WLAN. If false, only an ESSID match is required.
The currently active NCP. This property should not be set by the user; it is used internally by the NWAM service for persistence across restarts. The appropriate user interface to change the currently active NCP is by means of the nwam-manager GUI or the netadm command's enable subcommand.
Enabling the reserved NCP name DefaultFixed disables the NWAM automatic configuration management and enables traditional, fixed network configuration.
See attributes(5) for descriptions of the following attributes:
See also nwam-manager(1M), available in the JDS/GNOME man page collection.
The networking service is managed by the service management facility, smf(5), under the service identifier: