|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Device name file system
The dev filesystem manages the name spaces of devices under the Solaris operating environment. The global zone's instance of the dev filesystem is mounted during boot on /dev.
A subdirectory under /dev can have unique operational semantics. Most of the common device names under /dev are created automatically by devfsadm(1M). Others, such as /dev/pts, are dynamic and reflect the operational state of the system. You can manually generate device names for newly attached hardware by invoking devfsadm(1M) or implicitly, by indirectly causing a lookup or readdir operation in the filesystem to occur. For example, you can discover a disk that was attached when the system was powered down (and generate a name for that device) by invoking format(1M)).
The /dev/zvol/dsk and /dev/zvol/rdsk directories are generated based on the ZFS dataset hierarchy. Each ZFS file system is represented in /dev/zvol/dsk and /dev/zvol/rdsk as a directory. Each ZFS volume and each snapshot of a ZFS volume is represented as a block device in /dev/zvol/dsk and as a character device in /dev/zvol/rdsk. Within the global zone, symbolic links to device nodes within /devices are used instead of device nodes. See devfs(7FS)
Within non-global zones, the names that appear under /dev/zvol represent the aliased dataset names. See zonecfg(1M).
Within non-global zones, devices that are added by way of device resources can have the same name as those that appear in the aliased dataset namespace. See zonecfg(1M). If such conflicts occur, the device file corresponding to the device resource is seen and any corresponding /dev/zvol entries for datasets that are delegated to the zone is not seen. For example, if the device /dev/zvol/rdsk/rpool/vol1 is added as a device resource and the within the non-global zone the volume rpool/vol1 is created, the file /dev/zvol/rdsk/rpool/vol1 is the device allocated from the global zone, not the one that appears within the non-global zone's aliased dataset namespace.
Mount point for the /dev filesystem in the global zone.
The global /dev instance cannot be unmounted.