|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Devices file system
The devfs filesystem manages a name space of all devices under the Solaris operating environment and is mounted during boot on the /devices name space.
The /devices name space is dynamic and reflects the current state of accessible devices under the Solaris operating environment. The names of all attached device instances are present under /devices.
The content under /devices is under the exclusive control of the devfs filesystem and cannot be changed.
The system may be configured to include a device in one of two ways:
The device may be attached through a number of system calls and programs, including open(2), stat(2) and ls(1). During device attach, the device driver typically creates minor nodes corresponding to the device via ddi_create_minor_node(9F). If the attach is successful, one or more minor nodes referring to the device are created under /devices.
Mount point for devfs file system
The /devices name space cannot be unmounted.
All content at or below the /devices name space is an implementation artifact and subject to incompatible change or removal without notification.