|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Differentiated Services Code Point Marker
The dscpmk marker is an action module that is executed as a result of classifying or metering packets. It sets a codepoint in the IP header as defined in RFC-2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers.
The dscpmk module exports the following statistics available through kstat:
module: dscpmk instance: <action id> name: dscpmk stats class <action name> crtime snaptime npackets <number of packets> epackets <number of packets in error> ipackets <number of packets not processed> dscp_unchanged <number of packets with DSCP unchanged> dscp_changed <number of packets with DSCP changed> Also, for each DSCP the following is exported: module: dscpmk instance: <action id> name: dscpmk_dscp0x<DSCP> value class: <action name> dscp <DSCP value> npackets <number of packets for this DSCP>
See attributes(5) for descriptions of the following attributes:
RFC 2474, Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers K. Nichols, S. Blake, F. Baker, D. Black, The Internet Society, 1998.