|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11 Information Library|
- reset a SCSI bus
#include <sys/scsi/scsi.h> int prefix tran_bus_reset(dev_info_t *hba_dip, int level);
The dev_info_t pointer associated with the SCSI HBA.
The level of reset required.
The tran_bus_reset() vector in the scsi_hba_tran(9S) structure should be initialized during the HBA driver's attach(9E). It is an HBA entry point to be called when a user initiates a bus reset through device control interfaces.
tran_bus_reset() must reset the SCSI bus without resetting targets.
level will be one of the following:
Reset the SCSI bus only, not the targets.
Implementation is hardware specific. If it is not possible to reset the SCSI bus without changing the state and operating mode of the targets, the HBA driver should not initialize this vector or return failure.
tran_bus_reset() should return:
See attributes(5) for a description of the following attributes: