|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11 Information Library|
- quiesce and unquiesce a SCSI bus
#include <sys/scsi/scsi.h> int prefixtran_quiesce(dev_info_t *hba_dip);
int prefixtran_unquiesce(dev_info_t *hba_dip);
The dev_info_t pointer associated with the SCSI HBA.
The tran_quiesce() and tran_unquiesce() vectors in the scsi_hba_tran(9S) structure should be initialized during the HBA driver's attach(9E). They are HBA entry points to be called when a user initiates quiesce and unquiesce operations through device control interfaces.
tran_quiesce() should wait for all outstanding commands to complete and blocks (or queues) any I/O requests issued. tran_unquiesce() should allow I/O activities to resume on the SCSI bus.
Implementation is hardware specific.
tran_quiesce() and tran_unquiesce() should return:
An error occurred.
See attributes(5) for a description of the following attributes: