|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- parse Configuration tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_CONFIG(client_handle_t ch, tuple_t *tu, cistpl_config_t *cc);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_config_t structure which contains the parsed CISTPL_CONFIG tuple information upon return from this function.
This function parses the Configuration tuple, CISTPL_CONFIG, into a form usable by PC Card drivers. The CISTPL_CONFIG tuple is used to describe the general characteristics of 16-bit PC Cards containing I/O devices or using custom interfaces. It may also describe PC Cards, including Memory Only cards, which exceed nominal power supply specifications, or which need descriptions of their power requirements or other information.
The structure members of cistpl_config_t are:
uint32_t present; /* register present flags */ uint32_t nr; /* number of config registers found */ uint32_t hr; /* highest config register index found */ uint32_t regs[CISTPL_CONFIG_MAX_CONFIG_REGS]; /* reg offsets */ uint32_t base; /* base offset of config registers */ uint32_t last; /* last config index */
The fields are defined as follows:
This field indicates which configuration registers are present on the PC Card.
Configuration Option Register present
Configuration Status Register present
Pin Replacement Register present
Copy Register present
Extended Status Register present
IO Base 0 Register present
IO Base 1 Register present
IO Base2 Register present
IO Base3 Register present
IO Limit Register present
This field specifies the number of configuration registers that are present on the PC Card.
This field specifies the highest configuration register number that is present on the PC Card.
This array contains the offset from the start of Attribute Memory space for each configuration register that is present on the PC Card. If a configuration register is not present on the PC Card, the value in the corresponding entry in the regs array is undefined.
This field contains the offset from the start of Attribute Memory space to the base of the PC Card configuration register space.
This field contains the value of the last valid configuration index for this PC Card.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA
PC Card drivers should not attempt to use configurations beyond the “last” member in the cistpl_config_t structure.