|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- allocate and free non-sequentially accessed memory
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_iopb_alloc(dev_info_t *dip, ddi_dma_lim_t *limits, uint_t length, caddr_t *iopbp);
void ddi_iopb_free(caddr_t iopb);
A pointer to the device's dev_info structure.
The length in bytes of the desired allocation.
A pointer to a caddr_t. On a successful return, *iopbp points to the allocated storage.
The iopb returned from a successful call to ddi_iopb_alloc().
The ddi_iopb_alloc() function allocates memory for DMA transfers and should be used if the device accesses memory in a non-sequential fashion, or if synchronization steps using ddi_dma_sync(9F) should be as lightweight as possible, due to frequent use on small objects. This type of access is commonly known as consistent access. The allocation will obey the alignment and padding constraints as specified in the limits argument and other limits imposed by the system.
Note that you still must use DMA resource allocation functions (see ddi_dma_setup(9F)) to establish DMA resources for the memory allocated using ddi_iopb_alloc().
In order to make the view of a memory object shared between a CPU and a DMA device consistent, explicit synchronization steps using ddi_dma_sync(9F) or ddi_dma_free(9F) are still required. The DMA resources will be allocated so that these synchronization steps are as efficient as possible.
The ddi_iopb_free() function frees up memory allocated by ddi_iopb_alloc().
The ddi_iopb_alloc() function returns:
Memory successfully allocated.
These functions can be called from user, interrupt, or kernel context.
See attributes(5) for a description of the following attributes:
This function uses scarce system resources. Use it selectively.