|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- remove a kstat from the system
#include <sys/types.h> #include <sys/kstat.h> void kstat_delete(kstat_t *ksp);
Solaris DDI specific (Solaris DDI)
Pointer to a currently installed kstat(9S) structure.
kstat_delete() removes ksp from the kstat chain and frees all associated system resources.
kstat_delete() can be called from any context.
When calling kstat_delete(), the driver must not be holding that kstat's ks_lock. Otherwise, it may deadlock with a kstat reader.