|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- Copy message contents into a buffer and free message
#include <sys/stream.h> #include <sys/strsun.h> void mcopymsg(mblk_t *mp, void *buf);
Solaris DDI specific (Solaris DDI).
Message to be copied.
Buffer in which to copy.
The mcopymsg() function copies the contents of the specified message into the specified buffer. If the message consists of more than a single message block, the contents of each message block are placed consecutively into the buffer. After copying the message contents to buf, mcopymsg() frees the message mp.
The provided buffer must be large enough to accommodate the message. If the buffer is not large enough, the results are unspecified. The msgsize(9F) function can be used to calculate the total size of the message beforehand.
This function can be called from user, kernel or interrupt context.
STREAMS Programming Guide