|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- verify layer 3 and layer 4 checksums
#include <sys/neti.h> int net_isvalidchecksum(const net_data_t net, mblk_t *mb);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
the mblk structure holding a packet that is the subject of this query.
The net_isvalidchecksum() function verifies the layer 3 checksum (and, in some case, the layer 4 checksum) in the packet. If possible, fields that are used by hardware checksum'ing are examined rather than manually verifying that the checksums are present for packets received from a network interface.
For both IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6) layer 4 checksums are currently validated.
The net_isvalidchecksum() function returns:
The network protocol does not support this function.
The packet does not contain partial checksums.
The packet does contain partial checksums.
The net_isvalidchecksum() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: