|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- convert size in pages to size in bytes
#include <sys/ddi.h> unsigned long ptob(unsigned long numpages);
Architecture independent level 1 (DDI/DKI).
Size in number of pages to convert to size in bytes.
This function returns the number of bytes that are contained in the specified number of pages. For example, if the page size is 2048, then ptob(2) returns 4096. ptob(0) returns 0.
The return value is always the number of bytes in the specified number of pages. There are no invalid input values, and no checking will be performed for overflow in the case of a page count whose corresponding byte count cannot be represented by an unsigned long. Rather, the higher order bits will be ignored.
The ptob() function can be called from user, interrupt, or kernel context.