|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11 Information Library|
- linkage structure for loadable drivers
Solaris DDI specific (Solaris DDI)
The modldrv structure is used by device drivers to export driver specific information to the kernel.
struct mod_ops *drv_modops; char *drv_linkinfo; struct dev_ops *drv_dev_ops;
Must always be initialized to the address of mod_driverops. This member identifies the module as a loadable driver.
Can be any string up to MODMAXNAMELEN characters (including the terminating NULL character), and is used to describe the module and its version number. This is usually the name of the driver and module version information, but can contain other information as well.
Pointer to the driver's dev_ops(9S) structure.