|Skip Navigation Links|
|Exit Print View|
|Image Packaging System Man Pages Oracle Solaris 11 Information Library|
- GUI for the Image Packaging System
/usr/bin/packagemanager [-hiRu] [--help] [--info-install file] [--update-all] [--image-dir dir]
packagemanager is the graphical user interface for pkg(5), the Image Packaging System software.
The Package Manager enables you to perform the following tasks:
Search, install, and remove packages.
Add, remove, and modify publishers.
Create, remove, and manage boot environments.
If the file operand is specified and its suffix is .p5i, packagemanager launches in Web Install mode, which adds one or more publishers and a number of packages for each publisher.
The following options are supported:
Displays a usage message.
Allows you to specify a .p5i file to run packagemanager in Web Install mode. The file must have the suffix .p5i.
Operate on the image rooted at dir, rather than the image discovered automatically.
Update all installed packages that have updates available.
Note - If the package/pkg, package/pkg/package-manager, or package/pkg/update-manager packages need to be updated, packagemanager first updates these packages and then restarts to carry out any remaining updates.
A Web Install file. This file must have the suffix .p5i. See the Package Manager online help for more information about Web Install.
Example 1 Operate on the Current Image
Invoke packagemanager on the current image.
Example 2 Operate on a Specified Image
Invoke packagemanager in the image stored at /aux0/example_root.
$ packagemanager -R /aux0/example_root
Example 3 Invoke in Web Install Mode
Invoke packagemanager in Web Install mode.
$ packagemanager ~/test.p5i
The following exit values are returned:
An error occurred.
Invalid command line options were specified.
Since pkg(5) images can be located arbitrarily within a larger file system, the token $IMAGE_ROOT is used to distinguish relative paths. For a typical system installation, $IMAGE_ROOT is equivalent to /.
Metadata directory for a full or partial image.
Metadata directory for a user image.
Within the metadata of a particular image, certain files and directories contain information useful during repair and recovery. The token $IMAGE_META is used to refer to the top-level directory that contains the metadata. $IMAGE_META is typically one of the two paths given above.
Location for cached metadata maintained by packagemanager to speed up program startup and switching between publishers.
Other paths within the $IMAGE_META directory hierarchy are Private, and are subject to change.
See attributes(5) for descriptions of the following attributes:
Package Manager online help
packagemanager needs to be invoked with sufficient privilege to operate on an image's files and directories.