JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
Oracle Solaris 11 Installation Man Pages     Oracle Solaris 11 Information Library
search filter icon
search icon

Document Information

Preface

System Administration Commands

aimanifest(1M)

distro_const(1M)

installadm(1M)

js2ai(1M)

File Formats

installadm

- Manages automated installations on a network

Synopsis

/usr/bin/installadm [-h|--help]
installadm help [subcommand]
installadm create-service
    [-n|--service svcname]
    [-t|--aliasof existing_service]
    [-p|--publisher prefix=origin]
    [-a|--arch architecture]
    [-s|--source FMRI_or_ISO]
    [-b|--boot-args boot_property=value,...]
    [-i|--ip-start dhcp_ip_start]
    [-c|--ip-count count_of_ipaddr]
    [-B|--bootfile-server server_ipaddr]
    [-d|--imagepath imagepath]
    [-y|--noprompt]
installadm set-service
    -o|--option prop=value svcname
installadm rename-service svcname newsvcname
installadm enable svcname
installadm disable svcname
installadm delete-service
    [-r|--autoremove] [-y|--noprompt] svcname
installadm list
    [-n|--service svcname]
    [-c|--client] [-m|--manifest] [-p|--profile]
installadm create-manifest -n|--service svcname
    -f|--file manifest_or_script_filename
    [-m|--manifest manifest_name]
    [-c|--criteria criteria=value|list|range... |
    -C|--criteria-file criteriafile]
    [-d|--default]
installadm update-manifest -n|--service svcname
    -f|--file manifest_or_script_filename
    [-m|--manifest manifest_name]
installadm delete-manifest
    -m|--manifest manifest_name
    -n|--service svcname
installadm create-profile -n|--service svcname
    -f|--file profile_filename... 
    [-p|--profile profile_name]
    [-c|--criteria criteria=value|list|range... |
    -C|--criteria-file criteriafile]
installadm delete-profile -p|--profile profile_name...
    -n|--service svcname
installadm export -n|--service svcname
    -m|--manifest manifest_name...
    -p|--profile profile_name...
    [-o|--output pathname]
installadm validate -n|--service svcname
    -P|--profile-file profile_filename... |
    -p|--profile profile_name...
installadm set-criteria
    -m|--manifest manifest_name
    -p|--profile profile_name...
    -n|--service svcname
    -c|--criteria criteria=value|list|range... |
    -C|--criteria-file criteriafile |
    -a|--append-criteria criteria=value|list|range...
installadm create-client
    [-b|--boot-args property=value,...]
    -e|--macaddr macaddr -n|--service svcname
installadm delete-client macaddr

Description

The Automated Installer (AI) is used to automate the installation of the Oracle Solaris OS on one or more SPARC and x86 systems over a network.

The machine topography necessary to employ AI over the network is to have an install server, a DHCP server (this can be the same system as the install server), and the installation clients. On the install server, install services are set up to contain an AI boot image, which is provided to the clients in order for them to boot over the network, input specifications (AI manifests and derived manifests scripts), one of which will be selected for the client, and Service Management Facility (SMF) configuration profiles, zero or more of which will be selected for the client.

The AI boot image content is published as the package install-image/solaris-auto-install, and is installed by the create-service subcommand. The create-service subcommand is also able to accept and unpack an AI ISO file to create the AI boot image.

Install services are created with a default AI manifest, but customized manifests or derived manifests scripts (hereafter called “scripts”) can be added to an install service by using the create-manifest subcommand. See Installing Oracle Solaris 11 Systems for information about how to create manifests and derived manifests scripts. The create-manifest subcommand also allows criteria to be specified, which are used to determine which manifest or script should be selected for an installation client. Criteria already associated with a manifest or script can be modified using the set-criteria subcommand.

Manifests can include information such as a target device, partition information, a list of packages, and other parameters. Scripts contain commands that query a running AI client system and build a custom manifest based on the information it finds. When AI is invoked with a script, AI runs that script as its first task, to generate a manifest.

When the client boots, a search is initiated for a manifest or script that matches the client's machine criteria. When a matching manifest or script is found, the client is installed with the Oracle Solaris release according to the specifications in the matching manifest file, or to the specifications in the manifest file derived from the matching script. Each client can use only one manifest or script.

Each service has one default manifest or script. The default is used when the criteria of no other manifest or script matches the system being installed. Any manifest or script can be designated as the default. Any criteria associated with a default manifest or script become inactive and are not considered during manifest or script selection. If a different manifest or script is later made the default, the criteria of the former default manifest or script become active again. Manifests or scripts with no criteria associated with them can only be used as default manifests or scripts. Manifests or scripts without criteria become inactive when a different manifest or script is designated the default.

System configuration profiles are complementary to manifests and scripts in that they also contain specifications for an installation. In particular, profiles are used to specify configuration information such as user name, user password, time zone, host name, and IP address. Profiles can contain variables to get configuration parameters from the install server environment or from criteria specified in the create-profile subcommand. In this way, a single profile file can set different configuration parameters on different clients. See the “Examples” section.

System configuration profiles are processed by smf(5) and conform to document format service_bundle(4). See sysconfig(1M) and Installing Oracle Solaris 11 Systems for more information about system configuration profiles. Each client can use any number of system configuration profiles. A particular SMF property can be specified no more than once for each client system.

If you want a specific client to use a specific install service, you can associate that client with the service by using the create-client subcommand. You can also use create-client to modify an existing client.

The installadm utility can be used to accomplish the following tasks:

Install Server Configuration Properties

The following three properties of the svc:/system/install/server:default SMF service are used to configure the install server.

all_services/networks

A list of networks in CIDR format (for example, 192.168.56.0/24) to allow or disallow, depending on how the all_services/exclude_networks property is set.

Use this list of networks to specify which clients this install server serves. By default, the AI install server is configured to serve install clients on all networks that the server is connected to if the server is multihomed.

all_services/exclude_networks

A boolean value. If true, exclude networks specified by the all_services/networks property from being served by this install server. If false, include networks specified by the all_services/networks property.

all_services/port

Specifies the port that hosts the AI install services web server. By default, the web server is hosted on port 5555.

If you want to use a different port number from the default, customize the port property before you create any install services.

Options

The installadm command has the following option:

-h, --help

Show the usage help message.

Sub-commands

The installadm command has the subcommands listed below. See also the “Examples” section below.

help [subcommand]

Displays the syntax for the installadm utility.

subcommand

Displays the syntax for only the specified subcommand.

create-service [-n|--service svcname] [-t|--aliasof existing_service] [-p|--publisher prefix=origin] [-a|--arch architecture] [-s|--source FMRI_or_ISO] [-b|--boot-args boot_property=value,...] [-i|--ip-start dhcp_ip_start] [-c|--ip-count count_of_ipaddr] [-B|--bootfile-server server_ipaddr] [-d|--imagepath imagepath] [-y|--noprompt]

This subcommand sets up a network boot image (net image) in the specified imagepath directory, and creates an install service that specifies how a client booted from the net image is installed.

The AI boot image content is published as the package install-image/solaris-auto-install. If the -s option is not specified, that package is installed from the first publisher in the system's publisher preference list that provides an instance of that package. The -s option accepts the pkg specification as a full FMRI or location of an image ISO file. The resulting net image is eventually located in imagepath. The net image enables client installations.

Note the following specifications:

  • When the first install service of a given architecture is created on an install server, an alias of that service, default-i386 or default-sparc, is automatically created. This default service is used for all installations to clients of that architecture that were not added to the install server explicitly with the create-client subcommand. To change the service aliased by the default-arch service, use the set-service subcommand.

    If a default-arch alias is changed to a new install service and a local ISC DHCP configuration is found, this default alias bootfile is set as the default DHCP server-wide bootfile for that architecture.

  • If you want a client to use a different install service than the default for that architecture, you must use the create-client subcommand to create a client-specific configuration.

  • If the -i option and the -c option are used, and a DHCP server is not yet configured, an ISC DHCP server is configured.

    If an ISC DHCP server is already configured, that DHCP server is updated.

    Even when -i and -c arguments are provided and DHCP is configured, no binding exists between the install service being created and the IP range. When -i and -c are passed, the IP range is set up, a new DHCP server is created if needed, and that DHCP server remains up and running for all install services and all clients to use. The network information provided to the DHCP server has no specific bearing on the service being created.

  • If the IP range requested is not on a subnet that the install server has direct connectivity to and the install server is multihomed, the -B option is used to provide the address of the bootfile server (usually an IP address on this system). This should only be necessary when multiple IP addresses are configured on the install server and DHCP relays are employed. In all other configurations, the software can determine this automatically.

-n|--service svcname

Optional: Uses this install service name instead of a system-generated service name. The svcname can consist of alphanumeric characters, underscores (_), and hyphens (-). The first character of svcname cannot be a hyphen.

If the -n option is not specified, a service name is generated automatically.

-t|--aliasof existing_service

Optional: This new service is an alternate name for existing_service.

-a|--arch architecture

Optional: Selects a specific variant architecture. Legal values are i386 or sparc. If not specified, the variant corresponding to the server's architecture is selected.

The -a option only applies when the -s argument is a pkg(5) package.

-p|--publisher prefix=origin

Optional: A pkg(5) publisher, in the form prefix=origin, from which to install the client image.

If the -p option is not specified, then the first publisher in the system's publisher preference list that provides an instance of the package is used.

-s|--source FMRI_or_ISO

Optional: Specifies the data source for the net image. This can be either of:

  • The full FMRI of a pkg(5) package.

  • The path to an AI ISO image.

If -s is not specified, the install-image/solaris-auto-install package used is from either of:

  • The publisher specified with the -p parameter.

  • The first publisher in the system's publisher preference list that provides an instance of that package.

-b|--boot-args boot_property=value,...

Optional: For x86 clients only. Sets a property value in the service-specific menu.lst file in the service image. Use this option to set boot properties that are specific to this service. This option can accept multiple comma-separated boot_property=value pairs.

-i|--ip-start dhcp_ip_start

Optional: Specifies the starting IP address in a range to be added to the local DHCP configuration. The number of IP addresses is provided by the -c option. If a local ISC DHCP configuration does not exist, an ISC DHCP server is started.

-c|--ip-count count_of_ipaddr

Optional: Sets up a total number of IP addresses in the DHCP configuration equal to the value of the count_of_ipaddr. The first IP address is the value of dhcp_ip_start that is provided by the -i option.

-B|--bootfile-server server_ipaddr

Optional: Used to provide the IP address of the boot server from which clients should request bootfiles. Only required if this IP address cannot be determined by other means.

-d|--imagepath imagepath

Optional: Specifies the path at which to create the net image. If not specified, the default location, /export/auto_install/svcname, is used. A confirmation prompt is displayed unless -y is also specified.

-y|--noprompt

Optional: Suppresses any confirmation prompts and proceeds with service creation using the supplied options and any default values (see -d).

set-service -o|--option prop=value svcname
-o|--option prop=value

Specifies the property and value to set.

prop=value can be:

  • aliasof=existing_service

    Makes svcname an alias of existing_service.

  • default-manifest=manifest_name

    Designates a particular manifest or script that is already registered with a given service to be the default manifest or script for that service. Use the following command to show a list of manifests and scripts registered with this service.

    $ installadm list -n svcname -m
svcname

Required: Specifies the name of the install service whose property is being set.

rename-service svcname newsvcname

Renames the install service svcname to newsvcname. The newsvcname can consist of alphanumeric characters, underscores (_), and hyphens (-). The first character of newsvcname cannot be a hyphen.

enable svcname

Enables the svcname install service.

disable svcname

Disables the svcname install service.

delete-service [-r|--autoremove] [-y|--noprompt] svcname

Deletes an install service. Accomplishes the following:

  • Deletes the manifests, profiles, client configuration files, and web server configuration for this install service.

  • Deletes the image used to instantiate the service.

  • If the service is a default alias and a local ISC DHCP configuration exists, the bootfile associated with this service is removed from the ISC DHCP configuration.

-r|--autoremove

If specified, any clients assigned to this service, and any services aliased to this service, are also removed.

-y|--noprompt

Suppresses any confirmation prompts and proceeds with service deletion.

svcname

Required: Specifies the install service name to delete.

list [-n|--service svcname] [-c|--client] [-m|--manifest] [-p|--profile]

Lists all enabled install services on a server.

-n|--service svcname

Optional: Lists information about the specific install service on a local server.

  • If the -c option is specified, lists the client information associated with the install service.

  • If the -m option is specified, lists the manifests and scripts associated with the install service.

  • If the -p option is specified, lists the profiles associated with the install service.

-c|--client

Optional: Lists the clients of the install services on a local server.

-m|--manifest

Optional: Lists the manifests and scripts associated with the install services on a local server.

When -n is not specified, displays an abbreviated listing per service. This includes the default manifest or script, and all non-default manifests and scripts that have criteria associated with them. Criteria are not listed.

When -n is specified, displays all manifests and scripts for the given service, using a more complete listing format that includes criteria for each manifest. Inactive manifests, which have no associated criteria and are not designated as the default, are so marked. Criteria associated with a default manifest are marked as inactive.

-p|--profile

Optional: Lists the profiles associated with the install services on a local server.

When -n is not specified, displays an abbreviated listing per service that includes the profile names.

When -n is specified, displays the profiles for the requested service along with their criteria.

create-manifest -n|--service svcname -f|--file manifest_or_script_filename [-m|--manifest manifest_name] [-c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile] [-d|--default]

Creates a manifest or script for a specific install service, thus making the manifest or script available on the network, independently from creating a service. A non-default manifest or script can be used (can be active) only when criteria are associated with it. Criteria can be entered on the command line (-c) or via a criteria XML file (-C). Any criteria specified along with the -d option are temporarily ignored until the manifest or script is no longer designated as the default.

The name of the manifest is determined in the following order:

  1. The manifest_name specified by the -m option, if present.

  2. The value of the ai_instance name attribute, if present in the manifest.

  3. The base name of the manifest or script file name.

-n|--service svcname

Required: Specifies the name of the install service this manifest or script is to be associated with.

-f|--file manifest_or_script_filename

Required: Specifies the path name of the manifest or script to add.

-m|--manifest manifest_name

Optional: Specifies the AI instance name of the manifest or script. Sets the name attribute of the ai_instance element of the manifest to manifest_name. The manifest or script is referred to by manifest_name in subsequent installadm commands and installadm list output.

-c|--criteria criteria=value|list|range...

Optional: Specifies criteria to be associated with the added manifest or script. See the “Criteria” section below. When publishing a default manifest, criteria are registered but kept inactive until the manifest or script is no longer designated the default. The -c option can be specified multiple times.

-C|--criteria-file criteriafile

Optional: Specifies the path name of a criteria XML file containing criteria to be associated with the added manifest or script. When publishing a default manifest or script, criteria are registered but kept inactive until the manifest or script is no longer designated the default.

-d|--default

Optional: Specifies that this manifest or script is the new default manifest or script for the service. Any criteria specified are ignored until the manifest or script is no longer the default.

update-manifest -n|--service svcname -f|--file manifest_or_script_filename [-m|--manifest manifest_name]

Updates a specific manifest or script that is associated with a specific install service. Any criteria or default status remain with the manifest or script following the update.

The name of the manifest is determined in the following order:

  1. The manifest_name specified by the -m option, if present.

  2. The value of the ai_instance name attribute, if present in the changed manifest and if it matches the ai_instance name value of an existing manifest.

  3. The base name of the manifest or script file name, if it matches the ai_instance name attribute value in an existing manifest, or the name given by installadm list if it matches the name of an existing script.

The replacement manifest or script is given by the manifest_or_script_filename.

-n|--service svcname

Required: Specifies the name of the install service this manifest or script is to be associated with.

-f|--file manifest_or_script_filename

Required: Specifies the path name of the replacement manifest or script.

-m|--manifest manifest_name

Optional: Specifies the AI instance name of the replacement manifest or script.

delete-manifest -m|--manifest manifest_name -n|--service svcname

Deletes a manifest or script that was published with a specific install service. A default manifest or script cannot be deleted.

-m|--manifest manifest_name

Required: Specifies the AI instance name of a manifest or script as output by installadm list with the -n option.

-n|--service svcname

Required: Specifies the name of the install service this manifest is associated with.

create-profile -n|--service svcname -f|--file profile_filename... [-p|--profile profile_name] [-c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile]

Creates profiles for a specific install service. Criteria can optionally be associated with a profile by either entering them on the command line (-c) or via a criteria XML file (-C). Profiles created without criteria are associated with all clients of the service.

The name of the profile is determined in the following order:

  1. The profile_name specified by the -p option, if present.

  2. The base name of the profile file name.

Profile names must be unique for an AI service. If multiple -f options are used to create more than one profile with the same criteria, then the -p option is invalid and the names of the profiles are derived from their file names.

-n|--service svcname

Required: Specifies the name of the install service of the profile being updated.

-f|--file profile_filename...

Required: Specifies the path name of the file with which to add the profile. Multiple profiles can be specified.

-p|--profile profile_name

Optional: Specifies the name of the profile being created. Valid only for single profile creation.

-c|--criteria criteria=value|list|range...

Optional: Specifies criteria to be associated with the profiles. See the “Criteria” section below. Multiple -c options can be specified.

-C|--criteria-file criteriafile

Optional: Specifies the path name of a criteria XML file containing criteria to be associated with the specified profiles.

delete-profile -p|--profile profile_name... -n|--service svcname

Deletes the profile_name profile from the svcname install service.

-p|--profile profile_name...

Required: Specifies the name of the profile to delete. Multiple -p options can be specified.

-n|--service svcname

Required: Specifies the name of the install service of the profile being deleted.

export -n|--service svcname -m|--manifest manifest_name... -p|--profile profile_name... [-o|--output pathname]

Displays (exports) the specified manifest/scripts and/or profiles belonging to a service. At least one manifest/script or profile must be specified. Display goes to stdout unless the -o option redirects to a file or directory.

-n|--service svcname

Required: Specifies the install service associated with the manifest or profile to export.

-m|--manifest manifest_name...

Specifies the AI instance name of a manifest or script to export. Multiple -m options can be specified.

-p|--profile profile_name...

Specifies the name of a profile to export. Multiple -p options can be specified.

-o|--output pathname

Optional: Redirect output. The pathname must be a directory if multiple manifests, scripts and/or profiles are requested. The pathname can be a file if only one manifest, script, or profile is requested.

validate -n|--service svcname -P|--profile-file profile_filename... | -p|--profile profile_name...

Validates specified profiles. The validate subcommand can be used to either validate profiles in the database (-p) or to validate profiles while they are being developed before their entry into the database (-P).

-n|--service svcname

Required: Specifies the service with which the profiles are associated.

-P|--profile-file profile_filename...

Specifies an external profile file to validate.

-p|--profile profile_name...

Specifies the name of the profile to validate.

set-criteria -m|--manifest manifest_name -p|--profile profile_name... -n|--service svcname -c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile | -a|--append-criteria criteria=value|list|range...

Updates criteria of an already published manifest/script, profile, or both. Criteria can be specified via the command line or or via a criteria XML file. Criteria must be specified with one of the mutually exclusive options, -a, -c, or -C.

Valid criteria are described under the create-manifest subcommand.

-m|--manifest manifest_name

Specifies the AI instance name of a manifest or script.

-p|--profile profile_name...

Specifies the name of a profile. Any number of profiles can be specified.

-n|--service svcname

Required: Specifies the name of the install service associated with this manifest/script or profile.

-c|--criteria criteria=value|list|range...

Specifies criteria to replace all existing criteria for the manifest/script or profile. See the “Criteria” section below.

-C|--criteria-file criteriafile

Specifies the path name of a criteria XML file containing criteria to replace all existing criteria for the manifest/script or profile.

-a|--append-criteria criteria=value|list|range...

Specifies criteria to be appended to the existing criteria for the manifest/script or profile. See the “Criteria” section below. If the criteria specified already exists, the value|list|range of that criteria is replaced by the specified value|list|range.

create-client [-b|--boot-args property=value,...] -e|--macaddr macaddr -n|--service svcname

Accomplishes optional setup tasks for a specified client, in order to provide custom client settings that vary from the default settings used by the create-service subcommand. Enables the user to specify a non-default service name and boot arguments for a client. Can also be used to modify an existing client.

If the client is an x86 system and a local ISC DHCP configuration exists, the client is configured in the ISC DHCP configuration.

-b|--boot-args property=value,...

Optional: For x86 clients only. Sets a property value in the client-specific menu.lst file in /etc/netboot. Use this option to set boot properties that are specific to this client. This option can accept multiple property=value pairs.

-e|--macaddr macaddr

Required: Specifies a MAC address for the client.

-n|--service svcname

Required: Specifies the install service for client installation.

delete-client macaddr

Deletes an existing client's specific service information that was previously set up using the create-client subcommand.

If the client is an x86 system and a local ISC DHCP configuration exists, the client is unconfigured in the ISC DHCP configuration.

macaddr

Required: Specifies the MAC address of the client to delete.

Criteria

Manifests, scripts, and profiles can be used to configure AI clients differently according to certain characteristics, or criteria. Only one manifest or script can be associated with a particular client. Any number of profiles can be associated with a particular client.

The criteria values are determined by the AI client during startup.

The following AI client system criteria can be specified for both manifests/scripts and profiles unless otherwise noted.

See the “Examples” section to see how to specify criteria on the command line. For information about creating a criteria file, see Installing Oracle Solaris 11 Systems.

Criteria
Description
arch
Architecture per uname -m.
cpu
CPU class per uname -p.
hostname
Assigned hostname. Can be used only for profiles, not for manifests.
ipv4
IP version 4 network address.
mac
Hexadecimal MAC address with colon (:) separators.
mem
Memory size in MB per prtconf(1M).
network
IP version 4 network number.
platform
Platform name per uname -i.
zonename
Name of a zone per zones(5).

The ipv4, mac, mem, and network specifications can be expressed as ranged values separated by a hyphen (-). To specify no limit to one end of a range, use unbounded.

Any criteria that are not specifiable as a range can be specified as list of values separated by white space.

Examples

Example 1 Set Up a New x86 Install Service From an ISO File

Set up an install server and an x86 install service for the first time. The command includes a starting IP address and total count of IP addresses, in order to configure the DHCP server.

# installadm create-service -n sol-11-i386-svc \
-s /export/isos/sol-11-i386.iso \
-i 172.0.0.10 -c 10 -d /export/images/soli386

The AI ISO image is at /export/isos/sol-11-i386.iso. The command sets up a net image and an install service at /export/images/soli386 that is based on the AI ISO image. This net image enables client installations.

The starting IP address of 172.0.0.10 and ten IP addresses are added to the local ISC DHCP configuration. If a local ISC DHCP configuration does not exist, an ISC DHCP server is started.

Because this is the first i386 service created, the default-i386 service is automatically created and aliased to this service. The default-i386 alias is operational, and a client booted via PXE will boot and install from the default-i386 service.

Example 2 Set Up a New SPARC Install Service From an ISO File

Set up a SPARC install service for the first time.

# installadm create-service -n sol-11-sparc-svc \
-s /export/isos/sol-11-sparc.iso \
-d /export/images/solsparc

The AI ISO image is at /export/isos/sol-11-sparc.iso. The command sets up a net image and an install service at /export/images/solsparc that is based on the AI ISO image. This net image enables client installations.

Because this is the first SPARC service created, the default-sparc service is automatically created and aliased to this service. The default-sparc alias is operational, and a SPARC client will boot and install from the default-sparc service.

Example 3 Set Up an i386 Install Service From a Package Repository

# installadm create-service -y -n mysvc

On an i386 install server, this command sets up an i386 net image and install service named mysvc at the default image location, /export/auto_install/mysvc. The -y option provides confirmation that the default location is acceptable. Since the architecture is not specified, the service created is of the same architecture as the install server. This command assumes that a package repository on the pkg publisher list for the install server contains the install-image/solaris-auto-install package.

To specify the creation of a SPARC service on this server, use the -a option.

To specify the source of the solaris-auto-install package, use the -p option. For example, use the following command to specify the ai-image repository located at http://example.company.com:4281 as the source of the solaris-auto-install package:

# installadm create-service -y -n mysvc \
-p ai-image=http://example.company.com:4281

Example 4 Associate a Client With an Install Service

Use the following sample command to associate a client with a specific install service. The install service must already exist.

# installadm create-client -b "console=ttya" \
-e 0:e0:81:5d:bf:e0 -n my-i386-service

In this example, the command creates a client-specific setup for the system with MAC address 0:e0:81:5d:bf:e0. This client will use the install service previously set up, named my-i386-service, and that service's associated net image. The command sets the boot property console=ttya in the client-specific menu.lst file in /etc/netboot.

Example 5 Add a New Install Service Without Modifying the Default Service

Use the following sample command to add a new service named my-sparc-service, retaining existing services, and leaving the existing default unchanged.

# installadm create-service -n my-sparc-service \
-s /export/isos/mysparc.iso \
-d /export/ai/mysparc-image

Example 6 Add a New Install Service and Update the Default Service

Use the following two sample commands to add a new service named my-sparc-service, retaining existing services, and making the new service the default for SPARC clients.

# installadm create-service -n my-sparc-service \
-s /export/isos/mysparc.iso \
-d /export/ai/mysparc-image
# installadm set-service \
-o aliasof=my-sparc-service default-sparc

Example 7 Add a Custom Default AI Manifest to an Install Service

Use the following sample command to add a new manifest to the service_092910 install service, and make it the service's default manifest. The manifest data is in my_manifest.xml. Future installadm commands will refer to this manifest as my_manifest.

# installadm create-manifest -d -f my_manifest.xml \
-m my_manifest -n service_092910

Example 8 Add a Derived Manifests Script to an Install Service

Use the following sample command to add a derived manifests script named my_script to an existing install service named service_092910. Scripts are added the same way as manifests.

# installadm create-manifest -f my_script.py \
-m my_script -n service_092910

See Installing Oracle Solaris 11 Systems for information about how to create derived manifests scripts.

Example 9 Replace the Default AI Manifest for an Install Service

Use the following sample command to replace the default manifest for an existing install service, service_092910, with a custom manifest that has already been added to the service as my_manifest. The manifest was added to the service by specifying -m my_manifest to the create-manifest subcommand.

# installadm set-service -o default-manifest=my_manifest \
service_092910

Example 10 List Install Services

Use the following sample command to list the install services on a local server.

$ installadm list
Service Name     Alias Of         Status  Arch  Image Path 
------------     --------         ------  ----  ---------- 
default-i386     sol-11-i386-svc  on      x86   /export/images/soli386
default-sparc    sol-11-sparc-svc on      Sparc /export/images/solsparc
sol-11-i386-svc  -                on      x86   /export/images/soli386
sol-11-sparc-svc -                on      Sparc /export/images/solsparc

Example 11 List Clients Associated With an Install Service

Use the following sample command to list the clients of a specific install service on a local server.

$ installadm list -c -n my-x86-service
Service Name   Client Address    Arch  Image Path 
------------   --------------    ----  ---------- 
my-x86-service 01:C2:52:E6:4B:E1 i386  /export/images/myimage

Example 12 List Manifests Associated With an Install Service

Use the following sample command to list the manifests and scripts associated with a specific install service on a local server.

$ installadm list -m -n my-x86-service
Manifest      Status    Criteria 
--------      ------    -------- 
manifest2               arch = i86pc
                        mem  = 4096 MB - unbounded

sparc_setup             arch = sun4v

new_default   Default   (Ignored: mem = 2048 MB - 4095 MB)

orig_default  Inactive  None

This example shows the following output:

Example 13 List Profiles

Use the following sample command to list the profiles on a local server.

$ installadm list -p
Service Name Profile
------------ -------
sparc2       myprofile.xml
             myprofile2.xml
svc0817      profile3
svc0819      profile4.xml
             newprofile
             foo.xml

Example 14 Add a Custom AI Manifest With No Name to an Install Service

Use the following sample command to add the manifest in /export/my_manifest.xml to svc1 with a criterion of MAC address equaling aa:bb:cc:dd:ee:ff.

# installadm create-manifest -f /export/my_manifest.xml \
-n svc1 -c MAC="aa:bb:cc:dd:ee:ff"

In this example, the manifest does not contain a name attribute, so the manifest name is taken from the file name.

$ installadm list -m -n svc1
Manifest       Criteria
--------       --------
my_manifest    mac  = AA:BB:CC:DD:EE:FF

Example 15 Add a Custom AI Manifest With a Custom Name to an Install Service

Use the following sample command to add the manifest in /export/my_manifest.xml to svc1 with the criterion of IPv4 range from 10.0.2.100 and 10.0.2.199.

# installadm create-manifest -f /export/my_manifest.xml \
-n svc1 -m chosen_name \
-c IPV4="10.0.2.100-10.0.2.199"

In this example, the manifest name is taken from the -m option.

$ installadm list -m -n svc1
Manifest       Criteria
--------       --------
chosen_name    ipv4 = 10.0.2.100 - 10.0.2.199

Example 16 Add a Custom AI Manifest With Name Specified In the Manifest

Use the following sample command to add the manifest in /export/manifest3.xml to svc1 with criteria of 2048 MB memory or greater and an architecture of i86pc.

# installadm create-manifest -f /export/manifest3.xml \
-n svc1 -c MEM="2048-unbounded" -c ARCH=i86pc

In this example, the manifest name is taken from the name attribute of the ai_instance element in the manifest, as shown in the following partial manifest:

<auto_install>
    <ai_instance name="my_name" />
</auto_install>
$ installadm list -m -n svc1
Manifest    Criteria
--------    --------
my_name     arch = i86pc
            mem  = 2048 MB - unbounded

Example 17 Add a System Configuration Profile To an Install Service

Use the following sample command to add the profile in /export/profile4.xml to svc1 with criteria of any of the host names myhost1, host3, or host6.

# installadm create-profile -f /export/profile4.xml \
-n svc1 -p profile4 -c hostname="myhost1 host3 host6"
$ installadm list -p -n svc1
Profile          Criteria
-------          --------
profile4         hostname = myhost1 host3 host6

Example 18 Add a System Configuration Profile For All Clients

If you do not specify criteria, then the profile is used by all clients that use the specified install service. In the following example, the created profile is used by all clients that use the svc1 service.

# installadm create-profile -f /export/locale.xml -n svc1
$ installadm list -p -n svc1
Profile          Criteria
-------          --------
profile4         hostname = myhost1 host3 host6
locale

Example 19 Add a System Configuration Profile With Replacement Tags

A profile can use replacement tags, which serve as placeholders for custom client configuration information that comes from either the user's environment (see environ(4)) or from the criteria specified in the -c option in the create-profile subcommand. Using replacement tags, a profile file can be reused for any number of different systems. In the following example, each profile is stored with the hostname value taken from the -c criteria option:

# installadm create-profile -p myhost1_hostname \
-f /export/hostname.xml -n svc1 -c hostname=myhost1
# installadm create-profile -p myhost2_hostname \
-f /export/hostname.xml -n svc1 -c hostname=myhost2
$ installadm list -p -n svc1
Profile               Criteria
-------               --------
myhost1_hostname      hostname = myhost1
myhost2_hostname      hostname = myhost2

The hostname.xml file contains the following line:

<propval name="nodename" value="{{AI_HOSTNAME}}"/>

The create-profile command makes the substitution so that the myhost1_hostname profile contains the following line:

<propval name="nodename" value="myhost1"/>

Using the same hostname.xml input file, the myhost2_hostname profile contains the following line:

<propval name="nodename" value="myhost2"/>

The replacement tag, {{AI_HOSTNAME}}, is replaced with different values for each create-profile invocation because the hostname criteria was used and substituted into the profile. For more information about using replacement tags with profiles, see Installing Oracle Solaris 11 Systems.

Example 20 Add Criteria To an Existing Manifest

Use the following sample command to append the criterion of 4096 MB memory or greater to the criteria of manifest2 of svc1.

# installadm set-criteria -m manifest2 -n svc1 \
-a MEM="4096-unbounded"

Example 21 Replace the Criteria for an Existing Manifest

Use the following sample command to replace the criteria of manifest2 of svc1 with the criteria specified in the file /tmp/criteria.xml.

# installadm set-criteria -m manifest2 -n svc1 \
-C /tmp/criteria.xml

See Installing Oracle Solaris 11 Systems for information about the contents of the criteria XML file.

Example 22 Validate Profile Files Under Development

Use the following sample command to validate the profiles stored in the files myprofdir/myprofile.xml and herprofdir/herprofile.xml during their development.

# installadm validate -P myprofdir/myprofile.xml \
-P herprofdir/herprofile.xml -n svc1

Example 23 Export Profile Contents

Use the following sample command to export the profile myprofile.xml in the service svc1.

$ installadm export -p myprofile -n svc1

Example 24 Replace the Contents of an Existing AI Manifest

Use the following sample command to update the manifest in service svc2 that has the manifest name, or AI instance name, spec with the contents of the manifest in the file /home/admin/new_spec.xml.

# installadm update-manifest -n svc2 \
-f /home/admin/new_spec.xml -m spec

Example 25 Export and Update an Existing AI Manifest

Use the following sample commands to export the data of an existing manifest named spec in service svc2, and then update the manifest with modified content.

$ installadm export -n svc2 -m spec -o /home/admin/spec.xml

Make changes to /home/admin/spec.xml.

# installadm update-manifest -n svc2 \
-f /home/admin/spec.xml -m spec

Exit Status

The following exit values are returned:

0

The command was processed successfully.

>0

An error occurred.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
install/installadm
Interface Stability
Uncommitted

See Also

aimanifest(1M), sysconfig(1M), dhcp(5), dhcpd(8), smf(5), service_bundle(4), ai_manifest(4), environ(5)

Part III, Installing Using an Install Server, in Installing Oracle Solaris 11 Systems

Transitioning From Oracle Solaris 10 JumpStart to Oracle Solaris 11 Automated Installer