Skip Headers
Oracle® Fusion Middleware Developer's Guide for Oracle Service Bus
11g Release 1 (11.1.1.6.3)

Part Number E15866-08
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

18 Format Builder Menus

This chapter provides a user interface reference for the Format Builder menus.

Format Builder provides the following menus:

18.1 File Menu

The following commands are available from the File Menu.

Table 18-1 File Menu Commands

Menu Command Description

New

Creates a new Message Format document.

Open

Opens an existing Message Format document.

Close

Closes the current Message Format document.

Save

Saves the current Message Format document.

Save As

Saves the current Message Format under a different name document.

Properties

Opens the Properties window for the selected file or message format. You can change the MFL encoding or MFL version for the selected item.

Exits

Closes the application.


18.2 Edit Menu

The following commands are available from the Edit Menu.

Note:

Some commands may be unavailable, depending on the actions you have taken.

Table 18-2 Edit Menu Commands

Menu Command Description

Undo

Reverses the previous action. The Undo command in the Edit Menu changes to indicate the action that can be undone. For example, changing the name of a field to Field1 and clicking Apply causes the Edit Menu to read "Undo Apply Field Field1".

Redo

Reverses the effects of an Undo command. The Redo command in the Edit Menu changes to indicate the action that can be redone. For example, changing the name of a field to Field1 and then undoing that action causes the Edit Menu to read "Redo Apply Field Field1".

Cut

Removes the item currently selected in the left-hand pane, and its child objects, from the tree.

This action is not available if the Message Format (root) item is selected.

Copy

Makes a copy of the item currently selected in the left-hand pane for insertion elsewhere in the tree.

Note: This action is not available if the Message Format (root) item is selected.

Paste

Inserts the copied item. An additional menu is displayed when you select Paste. You can choose to paste the item as a child or sibling of the selected item. In addition, you can choose to paste a reference as a sibling of the selected item.

Duplicate

Makes a copy of the item selected in the tree. The duplicate item contains the same values as the original item. The name of the duplicate item is the same as the original item name, but the word "New" is inserted before the original name. For example, duplicating an item called "Field1" results in an item with the name "NewField1".

When you duplicate an item with a numeric value in its name, the new item name contains the next sequential number. For example, duplicating "NewGroup1" results in a group named "NewGroup2".

Delete

Deletes the item selected in the tree, as well as all child objects of that item.

Move Up

Moves the selected item up one position under its parent.

Move Down

Moves the selected item down one position under its parent.

Promote

Promotes the selected item to the next highest level in the tree. For example, Field1 is the child object of Group1. Selecting Field1 and clicking the Promote tool makes it a sibling of Group1.

Demote

Demotes the selected item to the next lower level in the tree. For example, Group1 is the sibling of Field1. Field1 immediately follows Group1 in the tree. Selecting Field1 and clicking the Demote tool makes it a child of Group1.


18.3 Insert Menu

The following commands are available from the Insert Menu.

Table 18-3 Insert Menu Commands

Menu Command Description

Field

Inserts a new field. You can choose whether to insert the field as a child or sibling of the item selected in the tree.

Group

Inserts a new group. You can choose whether to insert the group as a child or sibling of the item selected in the tree.

Comment

Inserts a comment. You can choose whether to insert the comment as a child or sibling of the item selected in the tree.


18.4 View Menu

The following commands are available from the View Menu.

Table 18-4 View Menu Commands

Menu Command Description

Show Palette

Displays the palette window. For more information on the palette, see Chapter 20, "Using the Palette"

Expand All

Expands the entire tree pane to show the child objects of all items in the tree.

Collapse All

Collapses the entire tree pane to show only the root message format.


18.5 Tools Menu

The following commands are available from the Tools Menu.

Table 18-5 Tools Menu Commands

Menu Command Description

Import

Displays a list of the installed importers. Choose the importer from which you want to import a message.

Test

Opens the Format Tester. Refer to Chapter 17, "Format Tester" for more information.

Options

Displays the Format Builder Options dialog. Refer to Chapter 15, "Format Builder Options" for more information.


18.6 Help Menu

The following commands are available from the Help Menu.

Table 18-6 Help Menu Commands

Menu Command Description

Help Topics

Displays the main Help screen.

How Do I

Provides step-by-step instructions for performing the basic tasks in Format Builder.

About

Displays version and copyright information about Format Builder.


18.7 Shortcut Menu

The following commands are available from the Shortcut Menus. You can access the Shortcut Menus by right-clicking an item in the tree.

Note:

Some commands may be unavailable, depending on the item you have selected in the tree.

Table 18-7 Shortcut Menu Commands

Menu Command Description

Cut

Removes the item currently selected in the left-hand pane, and it's child objects, from the tree.

Copy

Makes a copy of the item currently selected in the left-hand pane for insertion elsewhere in the tree.

Paste

Inserts the cut or copied item. An additional menu displays when you select Paste. You can choose to paste the item as a child or sibling of the selected item. In addition, you can choose to paste a reference to the cut or copied item as a sibling of the selected item.

Insert Group

Inserts a new group. You select whether to insert the group as a child or sibling of the selected item.

Insert Field

Inserts a new field. You select whether to insert the field as a child or sibling of the selected item.

Insert Comment

Inserts a comment. You select whether to insert the comment as a child or sibling of the selected item.

Duplicate

Makes a copy of the currently selected item. The duplicate item contains the same values as the original item. The name of the duplicate item is the same as the original item name, with the word "New" inserted before the original name. For example, duplicating a group called "Group1" results in a group with the name "NewGroup1".

When you duplicate an item with a numeric value in its name, the new item name contains the next sequential number. For example, duplicating "NewGroup1" results in a group named "NewGroup2".

Delete

Deletes the selected item.