Skip Headers
Oracle® Fusion Middleware Developer's Guide for Oracle Service Bus
11g Release 1 (11.1.1.6.3)

Part Number E15866-08
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

20 Using the Palette

This chapter provides a user interface reference for the Format Builder palette.

The Format Builder palette allows you to store commonly used message format items and insert them into your message format definitions. These items are stored in an XML document, and you can use the standard Windows drag and drop feature to copy items from the palette into your message format definition.

The palette contains some common date formats, literals, and strings. You can use these items in the message formats you create, as well as adding your own items to the palette.

20.1 Displaying the Palette Window

To turn the palette display on or off, choose View > Show palette. If the palette is not currently displayed, it opens in a separate window next to the Format Builder window. If the palette is currently displayed, its window closes.

20.2 Adding Items to the Palette

To add items to the palette:

  1. From the navigation tree, choose the item you want to add to the palette.

  2. Click and hold the left mouse button and drag the item into the palette window.

  3. When the item is placed in the position you want it (as a sibling of the selected item), release the mouse button. The item is copied from the navigation tree to the palette window.

    Note:

    You cannot add any node that depends on the existence of another node to the palette. For example, you cannot add Field or Group References, and you cannot add items that have a Repeat Field specified.

    Adding comments is possible, but not recommended since comments do not have unique names and therefore are indistinguishable on the palette.

20.3 Adding Palette Items to a Message Format

To copy items from the palette to a message format:

  1. From the palette window, choose the item you want to add to your message format.

  2. Click and hold the left mouse button and drag the item into the left pane of the Format Builder window.

  3. When the item is placed in the position you want it (as the child or sibling of the desired item), release the mouse button. The item is copied from the palette to the message format.

20.4 Using the File Menu

The following commands are available from the palette's File menu.

Table 20-1 File Menu Commands

Menu Command Description

Open

Opens an existing message format.

Save

Saves any message format items you have added to the palette, or any existing items you have modified.

Hide palette

Closes the palette window.


20.5 Using the Shortcut Menu

The following commands are available from the palette's shortcut menu. You can access the shortcut menu by right-clicking within the palette window.

Note:

Some commands may be unavailable, depending on the item you have selected in the tree.

Table 20-2 Shortcut Menu Commands

Menu Command Description

Insert

Inserts a new group in the palette. When you select this command, a window displays asking you to supply the name of the new group.

Rename

Displays a window asking you to supply the new name of the group.

Delete

Deletes the selected item.

Move Up

Moves the selected item up one position under its parent.

Move Down

Moves the selected item down one position under its parent.

Promote

Promotes the selected item to the next highest level in the tree. For example, Field1 is the child object of Group1. Selecting Field1 and clicking the Promote tool makes it a sibling of Group1.

Demote

Demotes the selected item to the next lower level in the tree. For example, Group1 is the sibling of Field1. Field1 immediately follows Group1 in the tree. Selecting Field1 and clicking the Demote tool makes it a child of Group1.