Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 2 (11.1.2)

Part Number E24480-01
Go to Documentation Home
Home
Go to Table of Contents
Contents
Go to Index
Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4.2 Set Properties and Preferences

This section provides procedures for the following tasks that you may perform as you work with property and preference settings:

4.2.1 Displaying the Property Inspector

To display the Property Inspector for an object:

  • In the Object Navigator, do any of the following:

    • Double-click the icon immediately to the left of the object name.

    • Click the object name, then right-click and choose Property Inspector.

    • Click the object name, then choose Tools > Property Inspector.

    • Click the object name, then press F4.

  • In the Report Editor views, do any of the following:

    • Double-click the object.

    • Click the object, then right-click and choose Property Inspector.

    • Click the object, then choose Tools > Property Inspector.

    • Click the object, then press F4.

See also

Section 1.10.1, "About the Property Inspector"

4.2.2 Setting report properties

To set the properties for a report:

  1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.

  2. Set report properties as desired.

4.2.3 Setting report preferences

To specify the preferences for a report:

  1. Choose Edit > Preferences.

  2. To specify preferences for designing reports, set values on the General, Access, and Wizards tabs.

  3. To specify preferences for running reports, set values on the Runtime Values and Runtime Settings tabs.

  4. For a detailed description of settings in the Preferences dialog box, click Help.

4.2.3.1 Using the Auto Save Feature

Oracle Reports 11g Release 2 (11.1.2) provides the Auto Save feature that recovers any unsaved changes during an unexpected event in Reports Builder or system failure.

If Auto Save is enabled, Reports Builder recovers any unsaved data automatically.

To enable the Auto Save feature:

  1. In the Object Navigator, choose Edit > Preferences...

  2. In the General tab, select the Auto Save check box.

  3. Click OK.

4.2.4 Setting preferences for the Object Navigator

To specify options for the Object Navigator display:

  1. In the Object Navigator, choose Tools > Options > Navigator.

  2. In the Object Navigator Options dialog box, change the settings as desired.

  3. Click OK.

See also

Section 1.5.1, "About the Object Navigator"

4.2.5 Setting properties for an ASCII (character-mode) report

To set properties for an ASCII (character-mode) report:

  1. Double-click the properties icon next to the report name to display the Property Inspector.

  2. Under the Character Mode node, set Design In Character Units to Yes.

  3. In the Object Navigator, under the Paper Layout node, double-click the Header Section, Main Section, or Trailer Section properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector.

    Note:

    By default, a report is defined in the Main section.
  4. In the Property Inspector, under the Section node:

    • set the Report Width and Report Height to the appropriate character-mode dimensions for the report. For example, 132 (or 180) width x 66 height for landscape or 102 width x 85 (or 116) height for portrait.

    • set the Orientation property to the desired value.

  5. In the Object Navigator, expand the Data Model node, then the System Parameters node.

  6. Double-click the properties icon next to MODE to display the Property Inspector, and set the following properties:

    • Under the Parameter node, set the Initial Value property to Character.

  7. In the Paper Layout view, choose Tools > Options > Rulers to display the Ruler Settings dialog box:

    • Set Units to Character Cells and Number of Snap Points Per Grid Spacing to 1.

    • Click OK.

  8. Click View in the menu bar and make sure that Snap to Grid is checked.

  9. Choose Edit > Preferences to display the Preferences dialog box:

    • On the Wizards page, set Horizontal Interfield to 1 and Vertical Interfield to 0.

    • Click OK.

  10. Choose Format > Font, and select the font, style, and size that most closely approximates the character-mode font. For example, Courier, Regular, 12 points.

See also

Section 4.5.9, "Creating an ASCII (character-mode) report"

4.2.6 Setting color palette preferences

To set color palette preferences:

  1. Choose Edit > Preferences.

  2. In the Preferences dialog box, on the General tab page, set the Color Mode as desired:

    • Editable. Oracle Reports Builder temporarily replaces your system's color palette with the palette of the active report. Each time a new report is made active, its color palette replaces the system palette. A report can have only one color palette. The active report will then be shown accurately, although the appearance of the inactive reports may suffer. You must choose Editable if you want to modify the color palette or import or export a color palette.

    • Read Only - Shared. (Default) Oracle Reports Builder continues to append each active report's color palette to your system's original palette until there is no room left in the palette for any more colors. That palette becomes the single palette that all open reports share. If you create a report that uses entirely different colors, it may not be shown accurately.

    • Read Only - Private. Each time you make a report active, Oracle Reports Builder appends that report's color palette to your system's original palette until there is no room left in the palette for any more colors. This palette is then used whenever that report is active. The active report is then shown accurately, although the appearance of the inactive reports may suffer.

    Note:

    A report can have only one color palette.
  3. If you change the Color Mode, shut down and restart Oracle Reports Builder to enable the new mode.

See also

Section 2.4.5, "About changing colors and patterns"

Section 4.9.6.6, "Importing or exporting a color palette"

Section 4.9.6.5, "Modifying the color palette"

Section 4.9.6.2, "Changing colors"

Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.

4.2.7 Setting properties of multiple objects

To set the properties of multiple objects:

  1. In the Object Navigator or any Report Editor view, select the objects whose properties you want to set. The objects can be of different types and can even be in different documents.

  2. Choose Tools > Property Inspector.

  3. In the Property Inspector, click the Union button to see all properties of all objects or leave the tool as the Intersection button to see only the properties the objects have in common.

  4. Set the properties as desired.

    Note:

    Any change you make to a property setting is applied to all of the objects in the current selection to which that property applies.

For example, a report includes several fields, each of which displays the date. The Datatype property of each field is DATE, which causes dates to be displayed in the default ORACLE format DD-MON-YY.

To use a different date format throughout the application, you need to set the Format Mask property for each field that displays dates. Rather than setting each field's Format Mask property individually, select all of the items, then set the Format Mask property once to change the format mask for each item selected.

See also

Section 1.10.1.1, "About making multiple selections in the Property Inspector"

4.2.8 Comparing the properties of one object to another

To compare the properties of one object to another:

  1. In the Object Navigators or the editors, double-click the first object so that its properties are displayed in the Property Inspector.

  2. In the Property Inspector, click the Pin button to attach this copy of the Property Inspector to the current object.

  3. In the Object Navigator, double-click the second object, then choose Tools > Property Inspector.

    A second Property Inspector is displayed. If the second window is on top of the first, drag it to move it alongside the first window.