Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 2 (11.1.2)

Part Number E24480-01
Go to Documentation Home
Home
Go to Table of Contents
Contents
Go to Index
Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

31.5 Import a Check Image and Arrange Fields for Printing

The steps in this section will show you how to adjust the margins of your check printing report and align the fields with an image of a check. You can scan any check and use its image to lay out the objects of your check report. In this section, we use the image we have provided to you, called blankcheck.jpg. This image is located in the spellcash example folder.

31.5.1 Rearrange the layout objects

Before you can insert the check image, you must first rearrange the layout objects.

To rearrange the layout objects:

  1. Click the Paper Layout button in the toolbar to display the Paper Layout view.

    The layout currently looks like this:

    Figure 31-10 Paper Layout view of your report

    Description of Figure 31-10 follows
    Description of "Figure 31-10 Paper Layout view of your report"

  2. Click the Edit Margin button in the toolbar.

  3. In the Paper Layout view, click the margin frame (the heavy black line) to select it.

  4. At the top of the frame, click the center black resizing square and drag it up, so that the margin is 0.25 inches (0.5 centimeters).

    Tip:

    When you click the center square, notice that a dotted guideline displays while your mouse button is depressed. You can use these guidelines to help place objects exactly where you want them in the Paper Layout view.

    When you are done, it should look something like this:

    Figure 31-11 Paper Layout view with resized margin

    Description of Figure 31-11 follows
    Description of "Figure 31-11 Paper Layout view with resized margin"

  5. Save your report.

31.5.2 Import the blank check image

In this section, you will import an image of a blank check. You can use any check you like. For this example, we have provided an image called blankcheck.jpg in the spellcash example directory.

To import the blank check image:

  1. While the frame is still selected, choose Insert > Image.

  2. In the Import Image dialog box, make sure that File is selected.

  3. In the text box next to File, type or browse for the location of the image, blankcheck.jpg, then click OK to display the blank check image in the Paper Layout view.

  4. Click the Edit Margin button in the toolbar to return to edit mode. Notice that the image no longer displays.

31.5.3 Set up the check printing fields

The steps in this section will show you how to use the various tools in the Paper Layout view to modify the look and feel of your check report. Here, you will learn how to add and modify layout objects and fields according to how you want them to display on the resulting checks. You will create copies of certain fields that you will then use in Section 31.6, "Create a Check Stub With Payment Information and Order Details" to create the check stub.

To set up the check printing fields:

  1. In the Paper Layout view, click the Order No. boilerplate text.

  2. Click the Select Parent Frame button in the toolbar.

    The repeating frame called R_G_ORDER_ID should now be selected in the Paper Layout view. You can also look in the Object Navigator, under Paper Layout, to make sure R_G_ORDER_ID is selected.

  3. While R_G_ORDER_ID is selected, click and drag the bottom center resize handle to 8.75 inches (22 centimeters), or the bottom of the page.

    Tip:

    When you click and drag a resize handle in the Paper Layout view, guidelines display along the ruler to help you place your objects. In this case, drag the bottom center resize handle down the page until the horizontal guideline reaches 8.75 inches (22 centimeters).
  4. Click the Flex Off button in the toolbar to set Flex mode off.

  5. In the Paper Layout view, click F_ORDER_TOTAL, then press CTRL+C on your keyboard.

  6. Click in the area below your layout objects and press CTRL+V.

    You should see a new field called F_ORDER_TOTAL1. If this field displays on top of the other layout objects, click and drag it down below the other layout objects so that your Paper Layout view now looks something like this:

    Figure 31-12 Partial Paper Layout view with F_ORDER_TOTAL1

    Description of Figure 31-12 follows
    Description of "Figure 31-12 Partial Paper Layout view with F_ORDER_TOTAL1"

  7. Copy the F_ORDER_DATE field and paste it below the other fields, so that your layout now looks like this:

    Figure 31-13 Partial Paper Layout view with F_ORDER_DATE1

    Description of Figure 31-13 follows
    Description of "Figure 31-13 Partial Paper Layout view with F_ORDER_DATE1"

    Note:

    When you copy and paste a field, Reports Builder maintains the size of the field. So, when you copy and paste F_ORDER_DATE, you may not see the full name of the field. While the field is selected, you can click and drag the right border of the field to the right so that you can see the full name of the field, F_ORDER_DATE1.
  8. Copy F_CUSTOMER_NAME and paste the field below the other layout objects, so that your layout looks like this:

    Figure 31-14 Partial Paper Layout view with F_CUSTOMER_NAME1

    Description of Figure 31-14 follows
    Description of "Figure 31-14 Partial Paper Layout view with F_CUSTOMER_NAME1"

  9. Make two copies of F_CHECK_NO by pressing CTRL+C on your keyboard once, then CTRL+V twice.

    Note:

    Since this field is small, it may be difficult to find. You can use the Object Navigator to find and select the field. When you click a field in the Object Navigator, under Paper Layout, the corresponding field is also selected in the Paper Layout view.
  10. Position these two new fields below the other layout objects, so that your layout looks like this:

    Figure 31-15 Partial Paper Layout view with F_CHECK_NO1 and F_CHECK_NO2

    Description of Figure 31-15 follows
    Description of "Figure 31-15 Partial Paper Layout view with F_CHECK_NO1 and F_CHECK_NO2"

    Note:

    We have expanded the size of the two new fields (F_CHECK_NO1 and F_CHECK_NO2) to make them easier to see, but you do not need to resize these fields.
  11. Click the Field tool in the tool palette.

  12. Draw a field below the other layout objects about 5 inches (12.5 centimeters) long, so that your layout now looks like this:

    Figure 31-16 Partial Paper Layout view with F_1 field

    Description of Figure 31-16 follows
    Description of "Figure 31-16 Partial Paper Layout view with F_1 field"

  13. While the new field, F_1, is still selected, click the Fill Color tool in the tool palette, and choose No Fill.

  14. Click the Line Color tool in the tool palette, and choose No Line.

  15. Double-click the field F_1 display the Property Inspector.

  16. Set the Name property to F_SPELLED_AMOUNT.

  17. Under Field, set the Source property to SPELLED_AMOUNT (the formula column you created in Section 31.3.2, "Create a formula column in your data model").

  18. Save your report.

31.5.4 Rearrange the new fields according to the blank check image

The steps in this section will show you how to use the Paper Design view to rearrange the fields you just created. You will use the blank check image we have provided as a guide.

  1. Click the Paper Design button in the toolbar to display your report in the Paper Design view.

    Note:

    When you click the Paper Design button while you are in another view (that is, Paper Layout view or Data Model view), Reports Builder runs your query and your layout. If you receive any error messages when you click the Paper Design button, go back to your original view to verify your changes. You can always compare your report against the sample report we have provided, called spellcash.rdf.

    You will see your layout objects, as well as the blank check image:

    Figure 31-17 Partial Paper Design view of the check report

    Description of Figure 31-17 follows
    Description of "Figure 31-17 Partial Paper Design view of the check report"

    Note:

    You will see that the preview does not quite look like a check report. The steps in this section will show you how to move your fields so that your report looks like a proper check.
  2. In the Paper Design view, position the F_ORDER_TOTAL field in the "Amount" box in the blank check image.

    Note:

    If you closed Reports Builder for any reason and are returning to building this report, make sure you click the Flex Off button in the toolbar so that you can move the fields around in the Paper Design view.
  3. Click the Align Right button in the toolbar, so that this portion of the check looks like the following:

    Figure 31-18 Amount area on blank check

    Description of Figure 31-18 follows
    Description of "Figure 31-18 Amount area on blank check"

  4. Position the F_CHECK_NO field in the "Check No." box on the blank check, and center-align the text.

  5. Position the F_ORDER_DATE field in the "Date" box on the blank check, and center-align the text.

  6. Position the F_CHECK_NO2 field in the upper right-hand corner of the check image, and right-align the text.

  7. Position the F_SPELLED_AMOUNT field next to the "Pay Exactly:" text on the blank check image.

  8. Position the F_CUSTOMER_NAME field next to the "Pay To The Order Of:" text on the blank check image.

    The check should now look like this:

    Figure 31-19 Check image with fields positioned

    Description of Figure 31-19 follows
    Description of "Figure 31-19 Check image with fields positioned"

  9. Save your report.

31.5.5 Modify the look and feel of the check

The steps in this section will show you how to change the font, alignment, and formatting of the data on your check.

To modify the look and feel of the check:

  1. In the Paper Design view, choose Edit > Select All (or press CTRL+A).

  2. Choose Format > Font.

  3. In the Font dialog box, choose Arial font, Regular style, Size 10, then click OK.

  4. In the Paper Design view, click anywhere to deselect all the objects.

    Tip:

    If you have trouble deselecting the objects, go to the Object Navigator and click any item. The objects that were selected in the Object Navigator should display as deselected.
  5. In the Paper Design view, click F_CHECK_NO2 (the check number in the upper right-hand corner of the check) and change the font to Arial, Bold, 12 point.

  6. Click the F_ORDER_TOTAL field (the number in the Amount box on the check).

  7. Click the Currency button in the toolbar, then click the Commas button.

  8. While F_ORDER_TOTAL is still selected, click the Add Decimal Place button in the toolbar twice, so that the amount now displays like this: $46,257.00.

  9. Choose Tools > Property Inspector to display the Property Inspector for F_ORDER_TOTAL.

  10. Under Field, next to the Format Mask property, add to the beginning of the existing format mask "****", then close the Property Inspector.

    The amount should now display like this: ****$46,257.00.

  11. Select the F_CUSTOMER_NAME and F_SPELLED_AMOUNT fields by Shift-clicking them, then change the font to Times New Roman, 12 point.

    Your report should now look something like this:

    Figure 31-20 Formatted Check

    Description of Figure 31-20 follows
    Description of "Figure 31-20 Formatted Check"

    Note:

    You will notice that the other boilerplate text is still overlaying the image. We will rearrange this text later in the chapter.
  12. Save your report.