Oracle® Essbase Studio

Release 11.1.2.1.000 Patch Set (PS): 11.1.2.2.000

Readme

About this Patch. 1

Patch Type. 2

Supported Paths to this Patch. 2

Prerequisites. 2

Supported Platforms. 2

Supported Languages. 2

Defects Fixed in this Patch. 3

Known Issues in this Patch. 4

Applying this Patch. 5

Rolling Back this Patch. 7

Troubleshooting FAQs. 7

Documentation Updates. 8

 

About this Patch

This Readme file describes the defects fixed in this patch set (PS) and the requirements and instructions for applying this PS.

Who should apply this patch: This PS contains defect fixes and changes that are specific to the Oracle Exalytics In-Memory machine. You should install this PS only in the following circumstances:

·         You are installing Essbase on the Exalytics In-Memory Machine, or

·         There is an urgent need for a defect fix that is included in this PS

Customers considering this PS for a platform other than the Exalytics In-Memory Machine should carefully review the list of fixed defects. If there is not a truly urgent need for a defect fix included in this PS, Oracle recommends customers install the upcoming Enterprise Performance Management (EPM) 11.1.2.2.000 release, which will contain an update, instead of this patch set. To check the availability of the EPM 11.1.2.2.000 release prior to installing this PS, visit the Oracle Software Delivery Cloud (https://edelivery.oracle.com).

Oracle highly recommends that you do extensive testing before making this patch available in a general production environment.

Caution: Once applied, you cannot roll back this patch or any other Essbase 11.1.2.2.000 component patch.

Also see the Oracle Essbase Studio New Features.

Patch Type

For Essbase Studio Server, this PS replaces files in the existing installation and does not require a full installation.

For Essbase Studio Console, this PS is an MSI installer and requires a full installation.

This PS includes patches for these components:

·         Essbase Studio Server (Patch ID 11892494)

·         Essbase Studio Console (Patch ID 13587342, part of a Hyperion Installation Technology patch that includes MSI installers for both Essbase Studio Console and Essbase Administration Services Console)

Supported Paths to this Patch

You can apply this patch to the following release:

·         11.1.2.1

·         11.1.2.1.102

Prerequisites

Required Patches

Essbase 11.1.2.1.102 is required to use the new “Redeployment Option in Background for XOLAP Cubes” feature.

Required User Rights

The user applying the patch should be the user who was set up to install and configure EPM System products. Required user privileges or rights:

Windows:
Use the user account that has Local administrator rights and was set up for installation and configuration. This user is an administrator and is the same for all EPM System products. Assign local policies if required by the product. Such assignments typically are: “Act as part of the operating system, Bypass traverse checking, Log on as a batch job, Log on as a service.”

UNIX/Linux:
Use the account that was used to install EPM System products and has Read, Write, and Execute permissions on $MIDDLEWARE_HOME. If you installed other Oracle products, the user who installed EPM System products must be in the same group as the user who installed the other Oracle products.
OPatches are not intended to be applied using a root user.

Supported Platforms

This patch applies to all supported platforms.

Note: The Essbase 11.1.2.2.000 patch applies to all supported platforms, with the exception of Solaris 9 (also known as Solaris 2.9 or 5.9).

Supported Languages

Applies to all supported languages.

Top of Document

Defects Fixed in this Patch

Use the Defects Fixed Finder tool to review the list of defects fixed prior to release 11.1.2.2.000. This tool is available here:

https://support.oracle.com/oip/faces/secure/km/DocumentDisplay.jspx?id=1292603.1

Defect Number

Defects Fixed

• 9196670

When performing catalog import/export, minischemas are not imported or exported along with data source connections.

Note that in this release, minischemas become part of individual data source connections and can be imported and exported along with other metadata elements. See the Oracle Essbase Studio New Features guide for more information.

• 11781604

The canonical host name of Essbase Studio Server is not stored in an Essbase outline; a general host name is stored instead. The stored Essbase Studio server host name is used to connect to Essbase Studio from Analytic Provider Services and Smart View.
Thus, if the canonical machine name where Essbase Studio Server and Analytic Provider Server are hosted contains a period ( . ), the cube linkage for the cube must be manually reset after each redeployment before any drill-through reports can be executed from Smart View.

• 11793745, 11830011

Drill-through reports cannot be displayed in Smart View for Essbase cubes deployed from Essbase Studio if the underlying Essbase model name contains non-ASCII characters.

• 11886510

For deployments from EPM Architect, attribute values associated with a ragged base dimension may not be loaded properly.

• 12385131

Upgrading from 11.1.2 to 11.1.2.1 causes the Essbase Studio catalog database to be out of sync with Essbase Studio Server.

Note: After applying this patch, the catalog version is not synchronized with the current version of Essbase Studio Server. To synchronize the catalog, execute the “reinit” command from the Essbase Studio command line client. See step 6 of the Essbase Studio Server section in “Applying this Patch” for instructions on running reinit.

• 12587204

Migrating the catalog from a pre-11.1.2.x release to an 11.1.2.x release fails when the deployment history in the catalog database is too large.

You can now run a new command, cleanModelHistory, from the Essbase Studio command line client. This command clears deployment history from the Essbase Studio catalog.

See the “Clearing Deployment History” topic in this readme for information on using the cleanModelHistory command.

• 12661093

Errors result from deployments using the MaxL “deploy” statement when there are mixed hierarchies, such as chains containing hand-typed members on the upper levels, and dimension elements as the lower levels.

• 12703695

Essbase Studio Server is not handling redeployment from EPM Architect when the accounts dimension is altered between deployments.

• 12797137

The “Never Consolidate” option (^) is not allowed on models that are enabled for aggregate storage.

• 12810562

Deployment fails when using the MaxL “deploy” statement on Windows 64-bit platforms.

• 12884358

If you are starting from an a pre-11.1.2.x environment and have installed and configured Essbase Studio 11.1.2.x, the models containing varying attributes with forward dependencies are not upgraded correctly.

Forward dependent dimensions are when the dimensions containing varying attributes come before the independent dimension in terms of dimension order in the model.

• 13521216

Essbase Studio does not support the data source column data types nchar and nvarchar.

 

Top of Document

Known Issues in this Patch

The following issues are the noteworthy known issues of this patch.

Defect Number

Known Issues

13356806

Alias sets that are created in folders other than the Root folder (of the Metadata Navigator) do not appear in the Alias tab of the Edit Properties dialog box for the associated dimension element.

Note that the Alias tab is a display-only dialog box; the alias set will still work properly.

13041135

When attempting to delete an alias set, an error occurs if an alias set with the same name exists in a different folder and one of those alias sets is associated with one or more Essbase models.

Also, if you attempt to delete a metadata folder that contains a duplicate-named alias set, the folder contents will not be completely deleted.

Workaround: Whether you are deleting an individual alias set or a metadata folder, give a unique name to any duplicate-named alias set, and then delete the alias set or metadata folder.

13393585

Essbase Studio help is not automatically updated in this release.

You may access the 11.1.2.2.000 help in English only on the Enterprise Performance Management System Documentation area of the Oracle Technology Network Web site (http://www.oracle.com/technology/documentation/epm.html).

14155099, 14462547

Netezza Data Source for Essbase Studio. Unable to connect to a Netezza data source using non-streaming mode in Essbase Studio.

Workaround: In non-streaming mode, the connection to a data source is made by Essbase, not Oracle Essbase Studio. Data source drivers are specified in the Essbase configuration file (essbase.cfg). By default, some data source drivers are disabled by the presence of a semicolon (;) comment indicator at the beginning of the data source entry. In the following example, the Netezza driver is disabled.

BPM_Oracle_DriverDescriptor "DataDirect 6.1 Oracle Wire Protocol"
BPM_DB2_DriverDescriptor "DataDirect 6.1 DB2 Wire Protocol"
BPM_SQLServer_DriverDescriptor "DataDirect 6.1 SQL Server Native Wire Protocol"
;BPM_SQLServer_DriverDescriptor "SQL Server"
;BPM_Netezza_DriverDescriptor "NetezzaSQL"
BPM_Teradata_DriverDescriptor "Teradata"
;BPM_ORACLEBI_DriverDescriptor "Oracle BI Server 11g_OHXXXX"
;BPM_ORACLEBI_DriverDescriptor "Oracle BI Server"
BPM_MySQL_DriverDescriptor "DataDirect 6.1 MySQL Wire Protocol

Edit essbase.cfg to make sure that the data sources you are using are listed and are not disabled by the semicolon comment indicator.

Note: The Netezza ODBC driver must be installed on the machine on which Essbase Server runs.

 

Top of Document

Applying this Patch

The section includes important information about applying this patch for Essbase Studio.

Component

Patch ID

Essbase Studio Server

11892494

Essbase Studio Console

13587342
(MSI installer)


In the 11.1.2.2.000 release, you apply the Essbase Studio Server patch; and you install the Essbase Studio Console using an MSI installer.

This patch does not include updated Essbase Studio help files. You may access the 11.1.2.2.000 help in English only on the Enterprise Performance Management System Documentation area of the Oracle Technology Network Web site (http://www.oracle.com/technology/documentation/epm.html).

Caution: Once applied, you cannot roll back this patch or any other Essbase 11.1.2.2.000 component patch.

Essbase Studio Server

To apply the Essbase Studio Server patch (11892494):

1.    Stop Essbase Studio Server.

2.    Download and unzip the downloaded patch file, <PATCH FILE NAME>.zip, to the <EPM_ORACLE_HOME>/OPatch directory (by default, Oracle/Middleware/EPMSystem11R1/OPatch).

NOTE: <PATCH FILE NAME>.zip is the name that My Oracle Support assigns to this patch. When you download the file, a message indicates the file name.

3.    From a command line, change the directory to <EPM_ORACLE_HOME>/OPatch.

4.    To apply the patch, enter the following command on one line:

Windows:
opatch.bat apply <EPM_ORACLE_HOME>\OPatch\<PATCH DIRECTORY> -oh <EPM_ORACLE_HOME>
-jre <MIDDLEWARE_HOME>\jdk160_21


NOTE: The default for <EPM_ORACLE_HOME> is C:\Oracle\Middleware\EPMSystem11R1. The default for <MIDDLEWARE_HOME> is C:\Oracle\Middleware.

UNIX/Linux:
./opatch apply <EPM_ORACLE_HOME>/OPatch/<PATCH DIRECTORY> -oh <EPM_ORACLE_HOME> -jre <MIDDLEWARE_HOME>/jdk160_21 -invPtrLoc <EPM_ORACLE_HOME>/oraInst.loc

NOTE: The default for <EPM_ORACLE_HOME> is $HOME/Oracle/Middleware/EPMSystem11R1. The default for <MIDDLEWARE_HOME> is $HOME/Oracle/Middleware.

5.    Restart Essbase Studio Server.

6.    Update the Essbase Studio catalog:

You must update the Essbase Studio catalog in order to use it with this patch. This is accomplished by issuing the “reinit” command in the Essbase Studio command line client, as described below.

a.    Go to <MIDDLEWARE_HOME>\user_projects\epmsystem1\bin.

b.    Call start_BPMS_bpms1_CommandLineClient.bat|sh to start the Essbase Studio command line client.
A command window called the CPL Shell is displayed.

c.    At the prompt, enter a valid admin user name and password.
NOTE: You must have Essbase Studio administrator privileges to use the
reinit command.

d.    At the prompt, enter the following command:
reinit

e.    Type exit to close the CPL Shell.

The Essbase Studio catalog is now ready for use.

Next, install the Essbase Studio Console using the MSI installer provided.

Essbase Studio Console

To install the Essbase Studio Console (patch ID 13587342):

1.    Stop Essbase Studio Console.

2.    If the console is already installed, back up the following directory:

<EPM_ORACLE_HOME>\products\Essbase\EssbaseStudio\Console

3.    From My Oracle Support, download the Essbase Studio Console zip file,
<CONSOLE PATCH FILE NAME>.zip, to a temporary directory.

Note: <CONSOLE PATCH FILE NAME>.zip is the name that My Oracle Support assigns to this patch. When you download the file, a message indicates the file name.

4.    Unzip the <CONSOLE PATCH FILE NAME>.zip file to extract the EssbaseStudioConsole.exe file.

5.    Run EssbaseStudioConsole.exe and follow the prompts.

6.    When finished with the console installer, start Essbase Studio Console and connect to Essbase Studio Server.

Top of Document

Rolling Back this Patch

You cannot roll back this or any other Essbase 11.1.2.2.000 component patch.

Top of Document

Troubleshooting FAQs

How can I find out which releases and patches of EPM System products are installed in a deployment?

In EPM System Release 11.x, you can use the lsinventory command to OPatch to find the release and patches that are installed in an Oracle Home. For example, enter the following command on one line:

Windows:

opatch.bat lsinventory -oh <EPM_ORACLE_HOME> -jdk <MIDDLEWARE_HOME>/jdk160_21

NOTE: The default for <EPM_ORACLE_HOME> is C:/Oracle/Middleware/EPMSystem11R1. The default for <MIDDLEWARE_HOME> is C:/Oracle/Middleware.

UNIX/Linux:

./opatch lsinventory -oh <EPM_ORACLE_HOME> -jdk <MIDDLEWARE_HOME>/jdk160_21

NOTE: The default for <EPM_ORACLE_HOME> is $HOME/Oracle/Middleware/EPMSystem11R1. The default for <MIDDLEWARE_HOME> is $HOME/Oracle/Middleware.

Why do I get the following patch conflict error message when running OPatch?

If the patch that you apply conflicts with a previously applied patch, you may receive the following error message when running OPatch:

Patch(es) <PreviousPatch#> conflict with the patch currently being installed (<NewPatch#>).

If you continue, patch(es) <PreviousPatch#> will be rolled back and the new patch (<NewPatch#>) will be installed.

If a merge of the new patch (<NewPatch#>) and the conflicting patch(es) (<PreviousPatch#>) is required, contact Oracle Support Services and request a Merged patch.

This error is returned when one patch attempts to update a previously patched file. When this conflict happens, you can either (1) roll back the previous patch and apply the new patch (this action might be appropriate if the previous patch was not critical) or (2) request a “merged patch” consisting of the new patch and the patch that it conflicts with. To request a merged patch, contact your Oracle Support representative.

Why do I get the OUI-67078 warning message when applying OPatch?

This warning means that the patch being applied is a superset of a patch already on the deployment and the existing patch will be rolled back. The following snippet shows the context of this warning.

The following warnings have occurred during OPatch execution:
1) OUI-67078:Interim patch 12345678 is a superset of the patch(es) [77777777] in OH C:\Hyperion
-----------------------------------------------------------------------------------
OPatch Session completed with warnings.

Top of Document

Documentation Updates

Accessing EPM System Product Documentation

The most recent version of each EPM System product guide is available for download from the Enterprise Performance Management System Documentation area of the Oracle Technology Network Web site (http://www.oracle.com/technology/documentation/epm.html). For faster access to the documentation, you can also use the Enterprise Performance Management Documentation Portal (http://www.oracle.com/us/solutions/ent-performance-bi/technical-information-147174.html) which also links to EPM Supported Platform Matrices, My Oracle Support, and other information resources.

Deployment-related documentation is also available from the Oracle E-Delivery Web site (http://edelivery.oracle.com/EPD/WelcomePage/get_form).

Individual product guides are available for download on the OTN Web site only.

Copying and Pasting Code Snippets from PDFs

When you cut and paste code snippets from a PDF file, some characters can be lost during the paste operation, making the code snippet invalid.

Workaround: Cut and paste from the HTML version of the document.

Documentation Contains Erroneous References to Deploying Essbase Cubes from Oracle BI EE

The Oracle Essbase Studio User’s Guide and Oracle Essbase Studio New Features guide contain references to functionality that is not available.

In the Oracle Essbase Studio User’s Guide, the topics, “Working with the Data Source Connections of an Essbase Cube Deployed by Oracle BI EE” and “Working with the Metadata Elements of an Essbase Cube Deployed by Oracle BI EE” should be disregarded.

In the Oracle Essbase Studio New Features guide, the topic, “Cube Deployment from Oracle BI EE” should be disregarded.

Accessibility Appendix Updates

The following items were not documented in the Accessibility appendix of the Essbase Studio User’s Guide (PDF and HTML help formats):

Shortcut Keys Added to Search Tab

Element Name

Equivalent

Name

Alt+N

Type

Alt+T

Look In

Alt+L

Browse

Alt+B

Search

Alt+S

Clear

Alt+C

 

After clicking Search or pressing Alt+S, if there are search results returned, press Tab to move focus to the Search Result portion of the Search tab, and navigate the search results. If there are no search results, you may not tab to the Search Results portion of the tab and this message appears: No elements found in search.

Refer to Table 7, "Accessing Elements in the Metadata Navigator and Source Navigator," in "Appendix A, Accessibility" in the Oracle Essbase Studio User's Guide, which contains instructions for navigating within a tree structure.

Shortcut Keys Missing from Table 7 of the Accessibility Appendix

Action

Key or Key Combinations

Launch the Text List dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then L

Launch the Alias Sets dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then A

Note: The Alias Set Manager is no longer part of Essbase Studio. This command now launches the Alias Sets dialog box.

 

Shortcut Keys Added to Refresh Data Source Tables Dialog Box

Element Name

Equivalent

Changed Tables

Alt+T

Changed Columns

Alt+C

Dependent Dimension Elements and Joins

Alt+D

Save Dependencies List as File

Alt+F

Refresh

Alt+R

 

Shortcut Keys Added to Delete Tables Dialog Box

Element Name

Equivalent

Table Status (Errors and Warnings)

Alt+T

Select All Tables

Alt+A

Dependent Dimension Elements and Joins

Alt+E

Save Dependencies List as File

Alt+S

Delete

Alt+D

 

Shortcut Key Omitted in Error from Essbase Studio Login Dialog Box

Element Name

Equivalent

Login

Alt+L

 

Shortcut Key Added to Essbase Login Dialog Box

This shortcut key is added to the Essbase Login dialog box which is accessed when creating an Essbase Server connection in the Cube Deployment Wizard.

Element Name

Equivalent

Data Encryption

Alt+E

 

Shortcut Keys Added to Connection Wizard, Define Parameters Page if Oracle RAC is the Data Source Type

Element Name

Keys

Press the Tab key to arrive at the “Add RAC server node” button

Tab

Press the Tab key to arrive at the “Remove RAC server node” button

Tab

 

Shortcut Key Added to Connection Wizard, Create OBIEE Dimension Elements Page

Element Name

Equivalent

Create cube schema and Essbase model

Alt+C

 

Shortcut Keys Added to Connection Wizard, Create OBIEE Cube Schema Page

Element Name

Equivalent

Cube Schema Name

Alt+S

Comment

Alt+C

Available Fact Tables

Use the arrow keys to expand folders and navigate to a column to select as a measure. Then, tab to the “Add selected measures” button, and press Enter. The column is moved to the Measures list.

Alt+F

Measures

Use the arrow keys navigate to a column to remove from the list. Then, tab to the “Remove selected measures” button, and press Enter. The column is removed from the Measures list.

Alt+M

Available Dimension Elements

Use the arrow keys navigate to a column to select as a hierarchy. Then, tab to the “Add selected hierarchies” button, and press Enter. The dimension is moved to the Hierarchies list.

Alt+D

Hierarchies

Use the arrow keys navigate to a hierarchy to remove from the list. Then, tab to the “Remove selected hierarchies” button, and press Enter. The column is removed from the Hierarchies list.

Alt+H

 

Shortcut Keys Added to Minischema Right-click Menu

Element Name

Equivalent

Save Minischema

Shift+F10, then S

Add to Metadata Navigator

Shift+F10, then M

 

Shortcut Key Omitted in Error from Connection Wizard, Select Minischema Page

Element Name

Equivalent

Clear existing schema

Alt+X

 

Shortcut Keys Added to Alias Sets Dialog Box

The Alias Sets dialog box replaces Alias Set Manager in release 11.1.2.2.000.

Element Name

Equivalent

Name

Alt+N

Description

Alt+D

Binding

Alt+B

Bindings popup menu

Alt+B, Shift+F10

The Bindings popup menu has these options:

N—Sort by dimension element name

P—Sort by dimension element path

B—Sort by bindings

A—Sort ascending

D—Sort descending

F—Show full path for dimension elements

Press Tab to move to the following buttons:

·         Create a binding

·         Create bindings by inspection

·         Edit the selected binding

·         Delete the selected bindings

Tab

 

Shortcut Keys Added to Cube Schema Wizard, Choose Measures and Hierarchies Page

Note that the following preview options are not available for measure hierarchies.

Element Name

Equivalent

Preview With Caption Binding

Alt+P+C

Preview With Key Binding

Alt+P+K

 

Shortcut Keys Added to Cube Deployment Wizard, Server Connection Options Page

Note that the following preview options are not available for measure hierarchies.

Element Name

Equivalent

Enable streaming mode for cube deployment

Alt+S

Build outline in background

Alt+K

 

Shortcut Keys Added to New Joins Dialog Box

Element Name

Equivalent

New Joins

Alt+N

Select All Joins

Alt+S

Add

Alt+A

 

Closing the Essbase Studio "View" Tabs

View tabs are the tabs for Metadata Navigator, Search, Data Sources, Minischemas, and Console Messages.

Action

Key or Key Combinations

Close You a view tab

Shift-Tab until focus is on the actual tab title.

·         Shift-Tab twice for Metadata Navigator, Data Sources, and Minischemas tabs

·         Shift-Tab once for Search and Console Messages tabs

Then, Alt+- (hyphen), use down arrow to select Close (or press C)

 

Shortcut Key Removed from the Preferences Dialog Box, General Section

The Browse command and the Alt+B shortcut have been removed.

Issues Related to Essbase Model Resync

Removing Base Chain in Hierarchy Causes Cube Deployment to Fail

(12988552)

In a multichain hierarchy containing a base chain and attribute chains, when removing the base chain, the Essbase model resync operation will succeed, but cube deployment of this model will fail.

Note that the Essbase model resync operation does not validate the model. If the resynced model contains errors, you will not be notified. Therefore, you must validate the model separately by opening it in the Essbase Model Properties dialog box and performing the steps in the "Validating Model Properties" topic in the Essbase Studio User's Guide.

Attribute Settings Deleted When Adding or Removing an Intermediate Level in a Hierarchy

(13005538)

In a multichain hierarchy containing a base chain and an attribute chain, if an intermediate level in an attribute chain is added or deleted and then model resync is performed, the attribute settings are removed from attribute dimension.

Whenever you add or remove levels in an attribute chain, you should perform the model resync, and then review and reset any attribute or varying attribute properties in the affected Essbase models. Also, Oracle recommends that you validate the model before attempting cube deployment.

Importing Minischemas from an Earlier Release

(13097315)

Because of the way minischemas have been implemented in this release, you cannot import minischemas from earlier releases, such as release 11.1.2.1. When you are importing a metadata catalog from a release earlier than 11.1.2.2.000, the minischemas will not be imported.

For more information, see “Exporting and Importing the Essbase Studio Catalog Database” in the Essbase Studio User’s Guide.

Importing Alias Sets from an Earlier Release

You may import alias sets from earlier releases. Any imported alias sets will be displayed at the root of the Metadata Navigator. You may leave them in the root folder or copy them to other folders in the tree.

The following new features are being introduced in the 11.1.2.1.102 release:

·         Deployment in Background Option for XOLAP Cubes

·         Support for Incremental Update of XOLAP Cubes

See the release 11.1.2.1 Oracle Essbase Studio New Features guide for features introduced in Releases 11.1.2 and 11.1.2.1.

Redeployment in Background Option for XOLAP Cubes

(11879223, 11888557)

This feature was introduced in the 11.1.2.1.102 release, but not included in the 11.1.2.2.000 version of the Essbase Studio User’s Guide.

You now have the option of redeploying XOLAP cubes in the background.

If an Essbase model is enabled for XOLAP, you may, when redeploying the cube, select the "Build outline in background" option.

When you select this option, the Essbase cube downtime is reduced. There is a small downtime interval when the cube is stopped and the new outline is available, as opposed to the downtime of previous releases when the cube was unavailable during the entire outline build process.

For example, in Essbase Spreadsheet Add-in, users may continue performing analysis on the cube during most of the cube redeployment process while the outline build is occurring in the background. When the redeployment is finished, if the user tries to perform a retrieve (or any other operation), an error message is displayed asking the user to log in again.

The "Build outline in background" option is selectable only when taking these actions:

·         Redeploying XOLAP cubes

·         Building an outline only

This option is not selectable when taking these actions:

·         Performing an initial XOLAP cube deployment

·         Redeploying non-XOLAP cubes

·         Loading data

Essbase Server Requirement

You must have installed Essbase Release 11.1.2.2.000 or 11.1.2.1.102 in order to use the “Redeployment in Background Option for XOLAP Cubes” feature.

Usage

To use the "Build outline in background" option:

1.    Complete the Essbase Server connection options page of the Cube Deployment Wizard, and then click Next.

See the "Providing Connection Information for Cube Deployment" topic in the Oracle Essbase Studio User's Guide.

2.    In the Cube deployment options page of the wizard, in the Load task type group, select Build outline in background.

Note that when Build outline in background is selected, you may not select from the Load data options group. The following options are also not selectable:

·         Delete all members first

·         Delete and restore database

·         Incremental Load

·         Create and save rule file only

3.    Select any other options you require in the Rejected records settings group and the Scheduling Options group.

See the "Setting Deployment Options" topic in the Oracle Essbase Studio User's Guide.

4.    Click Finish to complete the wizard and begin the deployment.

A dialog box is displayed, providing you with information about the current dimension being deployed. When the deployment is done, a "success" message is displayed.

If the deployment is unsuccessful, a message is displayed providing the name of application and database that was being deployed in the background, and giving the reasons for the unsuccessful deployment. Correct the errors that are indicated in the message, and try the deployment again.

Support for Incremental Update of XOLAP Cubes

(11888677)

This feature was introduced in the 11.1.2.1.102 release, but not included in the 11.1.2.2.000 version of the Essbase Studio User’s Guide.

Essbase Studio now supports incremental update for XOLAP cubes. You may perform an incremental load on an XOLAP cube when any of the following operations, either singly or in combination, are performed in the Essbase model:

·         Members are added to hierarchies

·         Members are deleted from hierarchies

·         Members in hierarchies are re-parented (reorganized)

The Oracle Essbase Studio User's Guide states that incremental builds are not enabled for XOLAP models. You can ignore this statement.

Measures Hierarchy Guidelines

 (12577525)

Measures hierarchies are used by Essbase Studio Server to create the accounts dimension in the Essbase model. Essbase Studio has the following guidelines for measures hierarchies.

Oracle recommends that a measures hierarchy be created from a fact table. The measures hierarchy may also include user-defined members. However, a measures hierarchy can also be created from dimension tables, and it may also include user-defined members.

·         An accounts dimension that is created from a measures hierarchy built from a fact table is referred to as “accounts from fact.”

In a cube schema, when you use a measures hierarchy built from a fact table, the column headers from the fact table become members in the accounts dimension in the subsequent Essbase model.

Using the TBC sample database, an example of a measures hierarchy built from the fact table, SALESFACT, would be:

Profit            (user-defined member)
   SALES        (from SALESFACT)
   COGS         (from SALESFACT)

If a column type in a fact table is text, Essbase Studio treats it as a text measure and automatically builds a text list.

·         An accounts dimension that is created from a hierarchy built from dimension tables, combined with one or more loose measures, is referred to as “accounts not from fact.” (Loose measures are individual measures that are not organized into a hierarchy.)

In this case, a designated column in one of the dimension tables contains rows that represent the column headings for facts. This column is joined to a column in a separate dimension table, which contains the values for those facts. It is from these two dimension tables that the accounts dimension (not from fact) is constructed when the model is created.

Using the TBC sample database, an example of a measures hierarchy built from non-fact tables, MEASURES and SALES, would be:

PARENT         (from MEASURES)
   CHILD        (from MEASURES)

In the MEASURES table, the values in the CHILD column correspond to the values in the MEASURESID column, which is joined to the MEASURESID column in the SALES table, which provides the actual data values from the AMOUNT column of the SALES table.

When you use an “accounts not from fact” measures hierarchy in a cube schema, you drag the hierarchy to the Hierarchies field of the Cube Schema Wizard. You must also drag at least one loose measure to the Measures/Measures Hierarchy field.

Essbase Studio maps the value of the loose measures to the members in the “accounts not from fact” measures hierarchy.

If a column type in a fact table is text, Essbase Studio treats it as a text measure and automatically builds a text list.

In summary, although Oracle recommends that measures hierarchies be created from columns in the fact table, Essbase Studio does not prevent you from creating measure hierarchies from dimension tables or from user-defined members. If the column header type is text, Essbase Studio will build a text list.

Note: Text lists larger than 1024 KB can cause deployments to abort.

Clearing Deployment History

(12681126)

Each time you deploy an Essbase model, deployment history data is collected and stored in the Essbase Studio catalog. When you migrate your catalog from one release to another, Essbase Studio Server makes use of the deployment history data contained in the catalog. If the history in the catalog becomes too large, the migration cannot be completed.

This release introduces a utility to clear the model deployment history files, cleanModelHistory.

Before you use this command, you must identify models that have large deployment history files; for example, models that have been redeployed many times.

Once you have identified the models to work with, run the cleanModelHistory utility from the Essbase Studio command line client as follows

1.    Go to <MIDDLEWARE_HOME>\user_projects\epmsystem1\bin.

2.    Call start_BPMS_bpms1_CommandLineClient.bat|sh to start the Essbase Studio command line client.

A command window called the CPL Shell is displayed.

3.    At the prompt, enter a valid admin user name and password.

NOTE: You must have Essbase Studio administrator privileges to use the Essbase Studio cleanModelHistory utility.

4.    Run the cleanModelHistory command using the following syntax:

call 'util'::'cleanModelHistory'("MODEL_NAME", dataset:\'DATASET_NAME');

"MODEL_NAME" is the name of the model whose history you want to clear.

'DATASET_NAME' is the name of the cube schema that was used to build this model.

For example:

call 'util'::'cleanModelHistory'("ProdMktModel1", dataset:\'ProdMktCS');

This removes all entries in the deployment history of the model except for the current “in-sync” entry for a given cube. All failures and non-current successes are removed.

“Launch Essbase Administration Services Console” Option Removed

(13546135)

The “Launch Essbase Administration Services Console” option has been removed from the Tools menu. You can no longer launch Administration Services Console from Essbase Studio Console.

You may launch Administration Services Console from the Windows Start menu on the machines where it is installed. For more information on launching Administration Services Console, see the Oracle Hyperion Enterprise Performance Management System Installation and Configuration Guide.

Configuring Teradata as a Data Source

To configure Teradata as a data source:

1.    Install Teradata drivers, which you must obtain from Teradata.

·         Essbase Studio uses JDBC drivers. The JDBC Teradata driver must be installed on the computer on which Essbase Studio Server runs.

Essbase Studio uses the JDBC Teradata driver to deploy cubes in streaming mode.

To deploy cubes in non-streaming mode, the ODBC Teradata driver must be installed on the computer on which Essbase Server runs.

·         Essbase uses ODBC drivers. The ODBC Teradata driver must be installed on the computer on which Essbase Server runs.

2.    Stop Essbase from the Windows Services panel using the Oracle Process Manager and Notification (OPMN) service: EPM_epmsystem1.

3.    Backup the OPMN configuration file (opmn.xml).

For example:

C:\Oracle\Middleware\user_projects\epmsystem1\config\OPMN\opmn\opmn.xml

4.    Open the opmn.xml file in a text editor.

5.    To properly load the Teradata drivers, the opmn.xml file must include a statement that points to the location of the Teradata libraries.

a.    Locate the following statement in the opmn.xml file:

<variable id="ESS_CSS_JVM_OPTION7" value="-Djava.util.logging.config.class=oracle.core.ojdl.logging.LoggingConfiguration"/>

b.    After this statement, add a statement similar to the following one:

<variable append="true" id="PATH" value="C:\Program Files\Teradata\Client\14.00\Shared ICU Libraries for Teradata\lib"/>

6.    When using Teradata data sources with Essbase, and using OPMN to monitor and control the Essbase Agent process, you must update the opmn.xml file with variables for the operating system you are using.

Note: The absolute path value cannot contain spaces. The examples of absolute path values are based on a 64-bit machine configuration.

64-bit Windows

Add these variables:

·         TWB_ROOT: Teradata root

·         PATH: Teradata shared libraries

·         PATH: Teradata client DLL libraries

·         PATH: Teradata Call-Level Interface Version 2 routines

·         PATH: Teradata message DLL libraries

64-bit Windows example:

<variable id="TWB_ROOT" value="C:\PROGRA~1\Teradata\Client\14.00"/>

<variable append="true" id="PATH" value="C:\PROGRA~1\Teradata\Client\14.00\SHARED~1\lib"/>

<variable append="true" id="PATH" value="C:\PROGRA~1\Teradata\Client\14.00\TERADA~1\bin64"/>

<variable append="true" id="PATH" value="C:\PROGRA~1\Teradata\Client\14.00\CLIv2"/>

<variable append="true" id="PATH" value="C:\PROGRA~1\Teradata\Client\14.00\TERADA~1\msg64"/>

 

64-bit AIX

Add these variables:

·         LIBPATH: Teradata ODBC libraries

·         LIBPATH: Teradata shared libraries

·         LIBPATH: ODBC components needed to load Teradata ODBC drivers

·         LIBPATH: Teradata client libraries

·         COPERR: Directory where the errmsg.txt file resides

·         NLSPATH: Teradata message libraries

64-bit AIX example:

<variable append="true" id="LIBPATH" value="/opt/teradata/client/ODBC_64/lib"/>

<variable append="true" id="LIBPATH" value="/opt/teradata/client/13.10/tdicu/lib64"/>

<variable append="true" id="LIBPATH" value="/usr/odbc/lib:/usr/odbc/drivers"/>

<variable append="true" id="LIBPATH" value="/usr/lib:/usr/teragss/aix-power/client/lib"/>

<variable id=" COPERR" value="/usr/libperion/essbase"/>

<variable id="NLSPATH" value="/opt/teradata/client/13.10/odbc_32/msg/%N"/>

<variable append="true" id="NLSPATH" value="/usr/lib/nls/msg/%L/%N"/>

<variable append="true" id="NLSPATH" value="/usr/lib/nls/msg/%L/%N.cat"/>

 

64-bit LINUX

Add these variables:

·         TWB_ROOT: Teradata root

·         TD_ICU_DATA: Teradata shared libraries

·         NLSPATH: Teradata ODBC message libraries

·         COPERR: Directory where the errmsg.txt file resides

·         COPLIB: Directory where the libcliv2.so library file resides

·         LD_LIBRARY_PATH: Teradata libraries

·         PATH: Teradata client directories

Note: The errmsg.txt and libcliv2.so files typically reside in the same directory. Therefore, the value for the COPERR and COPLIB variables is typically identical.

64-bit LINUX example:

<variable id="TWB_ROOT" value="/opt/teradata/client/13.10/tbuild"/>

<variable id="TD_ICU_DATA" value="</opt/teradata/client/13.10/tdicu/lib64> "/>

<variable id="NLSPATH" value="</opt/teradata/client/13.10/odbc_64/msg/%N > "/>  

<variable append=”true” id=”NLSPATH” value=”/opt/teradata/client/13.10/tbuild/msg64/%N”/>

<variable id="COPERR" value="/usr/lib64"/>

<variable id="COPLIB" value="/usr/lib64"/>

<variable append=”true” id=”LD_LIBRARY_PATH” value=”/opt/teradata/client/13.10/tbuild/lib64”/>

<variable append=”true” id=”LD_LIBRARY_PATH” value=”/usr/lib64”/>

<variable append=”true” id=”PATH” value=”/opt/teradata/client/13.10/tbuild/bin”/>

<variable append=”true” id=”PATH” value=”/opt/teradata/client/13.10/tbuild/lib64”/>

 

7.    Save the opmn.xml file.

8.    Start Essbase from the Windows Services panel using the Oracle Process Manager and Notification (OPMN) service (EPM_epmsystem1).

9.     Verify the following:

·         Essbase: Use the Data Prep Editor in Essbase Administration Services Console to connect to a Teradata database using a DNS.

·         Essbase Studio: Perform a cube deployment in non-streaming mode, which uses the Teradata ODBC driver.

Top of Document

 

Copyright © 2012, Oracle and/or its affiliates. All rights reserved.
http://www.oracle.com