|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- ILOM LAN configuration utility
ilomconfig list subcommand [options]
ilomconfig modify subcommand [options]
ilomconfig enable subcommand [options]
ilomconfig disable subcommand [options]
ilomconfig is an Oracle Integrated Lights Out Management (ILOM) configuration utility that allows an administrator to configure the LAN interface between the Service Processor (SP) and host. The administrator can view the LAN configuration settings by means of the list command and configure the interface using the enable, disable, and modify commands.
The following subcommands are available under the list command:
List product summary information and ILOM version.
List Host-to-ILOM interconnect settings.
The following subcommands are available under the modify command:
Modifies Host-to-ILOM interconnect settings.
The following subcommand is available under the enable command:
Enables the Host-to-ILOM interconnect.
The following subcommand is available under the disable command:
Disables the Host-to-ILOM interconnect.
The following options are available for the enable and modify commands:
Set the IP address for the SP side of the LAN interconnect.
Set the IP address for the host side of the LAN interconnect.
Set the network mask for the IP addresses used for the LAN.
The following are general options:
Display a brief usage message and then exit.
Suppress informational message output and return only error codes.
Display version information for ilomconfig and then exit.
ilomconfig can return any of the following values.
0 - Command successful 1 - Invalid option 3 - Invalid command 4 - The version of ILOM does not support this functionality 6 - Internal error 7 - Insufficient memory to execute command 9 - Insufficient privilege to execute command 10 - ILOM is not suipported on this system 50 - Cannot connect to ILOM 51 - An option must be specified 53 - Invalid IP Address 54 - An ILOM error occurred 55 - Cannot disable interconnect as it is already disabled
ilomconfig-specific log file.
See attributes(5) for descriptions of the following attributes: