|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- mount pcfs file systems
mount -F pcfs [generic_options] [-o FSType-specific_options] special | mount_point
mount -F pcfs [generic_options] [-o FSType-specific_options] special mount_point
mount attaches an MS-DOS file system (pcfs) to the file system hierarchy at the mount_point, which is the pathname of a directory. If mount_point has any contents prior to the mount operation, these are hidden until the file system is unmounted.
If mount is invoked with special or mount_point as the only arguments, mount will search /etc/vfstab to fill in the missing arguments, including the FSType-specific_options; see mount(1M) for more details.
The special argument is a special device file type, which is:
A DOS logical drive on a hard disk expressed as device-name:logical-drive , where device-name specifies the special block device-file for the whole disk and logical-drive is either a drive letter (c through z) or a drive number (1 through 24). Examples are /dev/dsk/c0t0d0p0:c and /dev/dsk/c0t0d0p0:1.
The special device file type must have a formatted MS-DOS file system with either a 12-bit, 16-bit, or 32-bit File Allocation Table.
See mount(1M) for the list of supported options.
Specify pcfs file system-specific options. The following options are supported:
File timestamps in pcfs cover a range between January 1st 1980 and December 31st 2127. This is not equal to the range of time_t on Unix for either 32-bit or 64-bit applications. In particular, 32-bit applications fail with EOVERFLOW errors on the stat(2) system call when timestamps beyond the range of 32-bit time_t are encountered. In order to prevent such spurious failures, pcfs by default clamps timestamps to the common subset of possible pcfs timestamps and the range available to 32-bit applications in Unix. The clamptime mount option therefore is active by default. If you want access to the full range of possible timestamps on pcfs, mount the file system with the noclamptime mount option. Note that if noclamptime is used, only 64-bit applications will have access to timestamps beyond January 19th 2038, 03:14:06 UTC; 32-bit applications will encounter EOVERFLOW errors.
Force uppercase characters in filenames to lowercase when reading them from the filesystem. This is for compatibility with the previous behavior of pcfs. The default is nofoldcase.
Allow or disallow listing of files with hidden or system bits set. Option hidden is the default. When nohidden is effect, hidden and system files are neither visible nor accessible. Note that PCFS in previous releases of the Solaris operating system used the nohidden option as the default.
Enable or disable write access timestamps on DOS-formatted media. Default for fixed disks is atime, while for removable media noatime is used. The latter default is so that writes to flash-based media (“memory sticks”) can be minimized, to prolong lifetime.
Timestamps on DOS-formatted media are recorded in the local time of the recording system. This can cause confusion when accessing removable media in which the recording and receiving system use different time zones. Use this option to force media timestamps to be interpreted for a specific time zone. The mount_pcfs command converts the given time zone name into a numerical offset that is passed to the pcfs kernel module, using the same rules as described in environ(5) for the TZ environment variable. By default, the timezone value is taken from the TZ environment variable.
Specifies the owner for the contents of the file system. The value can either be a character-string for a user name, or an integer value for the user ID. The default owner is the user ID of current process.
Specifies the group ID for the contents of the file systems. The value can either be a character-string for a group name, or an integer value for the group ID. The default group is the group ID of the mounting process.
Specifies the mask used for setting maximum access permissions on contents of the file system. The user_mask is an octal value, a bitmask, where each bit represents the permissions that should be disabled. The default user_mask is the file mode creation mask of the mounting process.
See Intro(2) for more information on masks.
table of mounted file systems
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than on top of the symbolic link itself.