|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- Availability Suite Remote Mirror update resynchronization daemon
The sndrsyncd daemon automates update resynchronization after a network or machine failure and invokes Point-in-Time Copy copies when needed to protect the data volumes being updated during a resynchronization.
The daemon is notified by the kernel when a network link being used by Remote Mirror goes down and invokes the sndradm(1M) command with the -u option to resynchronize all Remote Mirror sets which have autosync switched on and are using the network link. See sndradm(1M) for details on how to configure autosync for a Remote Mirror set.
The daemon is also notified when any Remote Mirror resynchronization starts or completes. The daemon takes Point-in-Time Copy snapshots, if configured in the Availability Suite configuration file. On a secondary server, the daemon checks if a file system is currently mounted on the secondary volume and informs the kernel not to allow the synchronization to start if the file system is currently mounted.
Daemon started successfully.
Daemon failed to start.
Shell script for starting sndrsyncd.
Shell script for stopping sndrsyncd.
See attributes(5) for descriptions of the following attributes:
Do not manually stop the sndrsyncd daemon. If you need to manually stop sndrsyncd perform these steps. This stops both the sndrd and sndrsyncd daemons.
# svcadm disable svc:/system/nws_rdc
# svcadm disable svc:/system/nws_rdcsyncd
Do not manually start or restart the sndrsyncd daemon. If you need to manually start sndrsyncd perform these steps. This starts both the sndrd and sndrsyncd daemons.
# svcadm enable svc:/system/nws_rdc
# svcadm enable svc:/system/nws_rdcsyncd
See svcadm(1M) for additional information.