|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- set default system time zone and locale
/etc/TIMEZONE is a symbolic link to /etc/default/init (see init(1M)). It sets up to 20 environment variables from /etc/default/init, including the time zone environment variable TZ.
The format of the file is:
where VAR is a timezone environment variable and value is the value assigned to the variable. value can be enclosed in double quotes (”) or single quotes (’). The double or single quotes cannot be part of the value.
With the transition to localtime-based timezones, $TZ values are connected with the svc:/system/timezone service as well as the svc:/system/environment:init service, replacing /etc/default/init. You must have localtime set in order for the timezone service to function properly.
When changing the TZ setting on x86 systems, you must make a corresponding change to the /etc/rtc_config file to account for the new timezone setting. This can be accomplished by executing the following commands, followed by a reboot, to make the changes take effect:
# rtc -z zone-name # rtc -c
where zone-name is the same name as the TZ variable setting.
See rtc(1M) for information on the rtc command.