|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11.1 Information Library|
- service management framework conventions for methods
The class of services managed by svc.startd(1M) in the service management framework, smf(5), consists of applications that fit a simple fork(2)-exec(2) model. The svc.startd(1M) master daemon and other restarters support the fork(2)-exec(2) model, potentially with additional capabilities. The svc.startd(1M) daemon and other restarters require that the methods which activate, manipulate, or examine a service instance follow the conventions described in this manual page.
The form of a method invocation is not dictated by convention. In some cases, a method invocation might consist of the direct invocation of the daemon or other binary executable that provides the service. For cases in which an executable script or other mediating executable is used, the convention recommends the form:
The abbr_method_name used for the recommended form is a supported method such as start or stop. The set of methods supported by a restarter is given on the related restarter page. The svc.startd(1M) daemon supports start, stop, and refresh methods.
A restarter might define other kinds of methods beyond those referenced in this page. The conventions surrounding such extensions are defined by the restarter and might not be identical to those given here.
The restarter provides four environment variables to the method that determine the context in which the method is invoked.
The service fault management resource identifier (FMRI) of the instance for which the method is invoked.
The full name of the method being invoked, such as start or stop.
The service FMRI of the restarter that invokes the method
The name of the zone in which the method is running. This can also be obtained by using the zonename(1) command.
These variables should be removed from the environment prior to the invocation of any persistent process by the method. A convenience shell function, smf_clear_env, is given for service authors who use Bourne-compatible shell scripting to compose service methods in the include file described below.
The method context can cause other environment variables to be set as described below.
A method is defined minimally by three properties in a propertygroup of type method.
These properties are:
Method executable string.
Number of seconds before method times out. See the Timeouts section for more detail.
Method type. Currently always set to method.
A Method Context can be defined to further refine the execution environment of the method. See the Method Context section for more information.
When defined in the exec string of the method by the restarter svc.startd, a set of tokens are parsed and expanded with appropriate value. Other restarters might not support method tokens. The delegated restarter for inet services, inetd(1M), does not support the following method expansions.
Name of the restarter, such as svc.startd
The full name of the method being invoked, such as start or stop.
Name of the service
Name of the instance
FMRI of the instance
Value(s) of a property. The prop might be a property FMRI, a property group name and a property name separated by a /, or a property name in the application property group. These values can be followed by a , (comma) or : (colon). If present, the separators are used to separate multiple values. If absent, a space is used. The following shell metacharacters encountered in string values are quoted with a \ (backslash):
; & ( ) | ^ < > newline space tab \ " '
An invalid expansion constitutes method failure.
Two explicit tokens can be used in the place of method commands.
Sends the specified signal, which is SIGTERM by default, to all processes in the primary instance contract. Always returns SMF_EXIT_OK. This token should be used to replace common pkill invocations.
Always returns SMF_EXIT_OK. This token should be used for methods that are required by the restarter but which are unnecessary for the particular service implementation.
The required behavior of a start method is to delay exiting until the service instance is ready to answer requests or is otherwise functional.
The following exit status codes are defined in <libscf.h> and in the shell support file.
In addition to the exit codes described above, a method may use the following exit codes in conjunction with smf_method_exit(), available via smf_method_exit(3SCF) and smf_include.sh:
Use of a precise exit code allows the responsible restarter to categorize an error response as likely to be intermittent and worth pursuing restart or permanent and request administrative intervention.
Each method can have an independent timeout, specified in seconds. The method timeout is specified by the timeout_seconds property.
A timeout is used as a last resort for the service's restarter to determine that a method has hung or is not making progress. If a timeout elapsed, many restarters place the service into the maintenance state. See svc.startd(1M). A significant margin of error is recommended when specifying a timeout in order to avoid premature failures when the method is making progress, but the system is temporarily responding very slowly due to memory, CPU, or I/O load.
60 seconds is a good starting value for methods expected to take only a second or two. 300 seconds (5 minutes) is appropriate for a method which commonly takes 30 seconds. Scale up as appropriate for methods which routinely take longer.
Shorter timeouts can be used if fast failure is desired in order to prompt administrative intervention. If administrative intervention is likely to only be to clear the service and start the method again, consider a longer timeout.
If timeout_seconds is set to 0, there is no timeout for the service. This setting is not preferred, but is available for services which absolutely require it. -1 is also accepted to specify no timeout, but is deprecated.
A set of environment variables that define the above exit status values is provided with convenience shell functions in the file /lib/svc/share/smf_include.sh. This file is a Bourne shell script suitable for inclusion via the source operator in any Bourne-compatible shell.
To assist in the composition of scripts that can serve as SMF methods as well as /etc/init.d scripts, the smf_present() shell function is provided. If the smf(5) facility is not available, smf_present() returns a non-zero exit status.
One possible structure for such a script follows:
if smf_present; then # Shell code to run application as managed service .... smf_clear_env else # Shell code to run application as /etc/init.d script .... fi
This example shows the use of both convenience functions that are provided.
The desired method context should be provided by the service developer. All service instances should run with the lowest level of privileges possible to limit potential security compromises.
A method context can contain the following properties:
A boolean that specifies whether the profile should be used instead of the user, group, privileges, and limit_privileges properties.
Environment variables to insert into the environment of the method, in the form of a number of NAME=value strings.
The name of an RBAC (role-based access control) profile which, along with the method executable, identifies an entry in exec_attr(4).
The user ID in numeric or text form.
The group ID in numeric or text form.
An optional string that specifies the supplemental group memberships by ID, in numeric or text form.
An optional string specifying the privilege set as defined in privileges(5). An Extended Policy can be specified here.
An optional string specifying the limit privilege set as defined in privileges(5).
The home directory from which to launch the method. :home can be used as a token to indicate the home directory of the user whose uid is used to launch the method. If the property is unset, :home is used.
An optional string that specifies the corefile pattern to use for the service, as per coreadm(1M). Most restarters supply a default. Setting this property overrides local customizations to the global core pattern.
The project ID in numeric or text form. :default can be used as a token to indicate a project identified by getdefaultproj(3PROJECT) for the user whose uid is used to launch the method.
The resource pool name on which to launch the method. :default can be used as a token to indicate the pool specified in the project(4) entry given in the project attribute above.
The method context can be set for the entire service instance by specifying a method_context property group for the service or instance. A method might override the instance method context by providing the method context properties on the method property group.
Invalid method context settings always lead to failure of the method, with the exception of invalid environment variables that issue warnings.
The arguments in argv are set consistently with the result of /bin/sh -c of the exec string.
File descriptor 0 is /dev/null. File descriptors 1 and 2 are recommended to be a per-service log file.
Definitions of exit status values.
Definitions of exit status codes.
Example 1 Report a service-specific configuration error message in the service log.
A start method might want to use smf_method_exit() to report a service-specific configuration error message in the service log.
if [ ! -s "$my_config_file" ]; then smf_method_exit $SMF_EXIT_ERR_CONFIG \ missing_or_empty_config_file \ "$my_config_file is missing or empty" fi
Example 2 Disable a service that should only run in the global zone when started in a non-global zone.
A service that should only run in the global zone might want to disable itself when started in a non-global zone.
if smf_is_nonglobalzone; then smf_method_exit $SMF_EXIT_TEMP_DISABLE global_zone_only \ "$SMF_FMRI is not supported in a local zone" SUNW_OST_OSCMD fi
zonename(1), coreadm(1M), inetd(1M), svccfg(1M), svc.startd(1M), exec(2), fork(2), getdefaultproj(3PROJECT), smf_method_exit(3SCF), exec_attr(4), project(4), service_bundle(4), attributes(5), privileges(5), rbac(5), smf(5), smf_bootstrap(5), zones(5)
The present version of smf(5) does not support multiple repositories.
When a service is configured to be started as root but with privileges different from limit_privileges, the resulting process is privilege aware. This can be surprising to developers who expect seteuid(<non-zero UID>) to reduce privileges to basic or less.