|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Intel Pro. Wireless 802.11b IPW2100B driver
The ipw 802.11b wireless NIC driver is a multi-threaded, loadable, clonable, GLDv3-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Intel Pro Wireless 2100B chipset-based wireless NIC's. Driver functions include controller initialization, wireless 802.11b infrastructure network connection, WEP, frame transmit and receive and promiscuous support.
The ipw driver performs auto-negotiation to determine the data rate and mode. Supported 802.11b data rates are 1, 2, 5.5 and 11 Mbits/sec.
The ipw driver supports only BSS networks (also known as ap or infrastructure networks) and the open (open-system) or shared system authentication. Only WEP encryption is currently supported. You perform configuration and administration tasks using the dladm(1M) utility.
Special character device.
64-bit ELF kernel module (x86).
See attributes(5) for a description of the following attributes:
ANSI/IEEE Std 802.11- Standard for Wireless LAN Technology — 1999
IEEE Std 802.11b - Standard for Wireless LAN Technology-Rev. B - 2003