|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Intel Pro. Wireless 802.11a/b/g IPW2200B/G IPW2915A/B/G Driver
The iwi 802.11b/g wireless NIC driver is a multi-threaded, loadable, clonable, GLDv3-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Intel Pro Wireless 2200BG 2915ABG chipset-based wireless NIC's. Driver functions include controller initialization, wireless 802.11b infrastructure network connection, WEP and frame transmit and receive.
The iwi driver performs auto-negotiation to determine the data rate and mode. Supported 802.11b data rates are 1, 2, 5.5 and 11 Mbits/sec. Supported 802.11g data rates are 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48 and 54 Mbits/sec.
The iwi driver supports only BSS networks (also known as ap or infrastructure networks) and open (or open-system) or shared system authentication. Only WEP encryption is currently supported. You perform configuration and administration tasks using the dladm(1M) utility.
Special character device.
64-bit ELF kernel module (x86).
See attributes(5) for a description of the following attributes:
ANSI/IEEE Std 802.11- Standard for Wireless LAN Technology — 1999
IEEE Std 802.11a- Standard for Wireless LAN Technology-Rev. A— 2003
IEEE Std 802.11b - Standard for Wireless LAN Technology-Rev. B — 2003
IEEE Std 802.11g- Standard for Wireless LAN Technology -Rev. G— 2003