|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Intel 10Gb PCI Express NIC Driver
The ixgbe 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Intel 10–Gigabit PCI Express Ethernet controllers.
The ixgbe driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The ixgbe driver and hardware support auto-negotiation, a protocol specified by the IEEE 802.3ae specification.
The ixgbe driver also supports the SRIOV capability on Intel 82599 and later 10 Gigabit Ethernet controllers. In SR-IOV enabled mode, it supports the Physical Function of the controller.
The cloning character-special device, /dev/ixgbe, is used to access all Intel 10 –Gigabit PCI Express Ethernet devices installed within the system.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.
The values returned by the driver in the DL_INFO_ACK primitive in response to your DL_INFO_REQ are:
Maximum SDU is 16366.
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP (Service Access Point) length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular SAP with the stream.
By default, the ixgbe driver performs auto-negotiation to select the link speed and mode. Link speed and mode can only be 10000 Mbps full-duplex. See the IEEE802.3 standard for more information.
In SR-IOV mode, the following device specific parameters are exported by the ixgbe driver to supprot SR-IOV feature.
This is a read-only parameter describing the maximum number of VFs that can be configured. A value of 63 is exported to override the information that is found in PCI config space of the 82599 device. difference is due to the fact that ixgbe driver utilizes hardware resources to provide a functional PF device along with VFs. parameter enables external management software to limit the number of configured VFs to be 63 or less.
This is a read-only parameter describing the maximum number of VLAN filters supported for PF and VFs. As the 82599 supports 64 VLAN filters for PF and VFs all together, a value of 64 is exported. parameter allows external management software entities to limit the number of VLAN filters configured to be with the supported limit.
This is a read-only parameter describing the maximum MTU allowed for a VF. A value of 1500 is exported to indicate the 82599 VF hardware limit. parameter allows external management software to limit the maximum VF MTU setting to be within the described limit.
This is a tunable parameter that allows the reservation of unicast mac-address slots to a PF or a VF. A total of 128 unicast mac-address slots are present in a 82599 device instance, out which one mac-address slot for the PF and each VFs is always reserved. The rest of the unicast mac-address slots can be reserved for the PF or VFs through this parameter. If not, the rest unicast mac-address slots are shared and allocated on first come first serve basis.
This is a read-only parameter describing the hardware attribute that vlan IDs and port vlan ID are mutual exclusive on a 82599 device. Users cannot set vlan IDs successfully when port vlan ID has been set. Vice versa, users cannot set port vlan ID successfully when vlan IDs have been set.
Special character device
64–bit device driver (x86)
64–bit device driver (SPARC)
See attributes(5) for descriptions of the following attributes:
IEEE 802.3ae Specificiation, IEEE – 2002