|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- DTrace profile interrupt provider
The profile driver is a DTrace dynamic tracing provider that adds time-based interrupt event sources that can be used as DTrace probes.
Each profile event source is a time-based interrupt firing every fixed, specified time interval. You can use these probes to sample some aspect of system state every unit time and the samples can then be used to infer system behavior. If the sampling rate is high, or the sampling time is long, an accurate inference is possible. By using the DTrace facility to bind arbitrary actions to probes, you can use the profile provider to sample practically anything in the system. For example, you could sample the state of the current thread, the CPU state, or the current machine instruction each time a probe fires.
The profile driver is not a public interface and you access the instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the profile provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide