|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Solaris SATA framework
Serial ATA is an interconnect technology designed to replace parallel ATA technology. It is used to connect hard drives, optical drives, removable magnetic media devices and other peripherals to the host system. For complete information on Serial ATA technology, visit the Serial ATA web site at http://www.serialata.org.
Up to 32 SATA devices may be plugged directly to each SATA HBA and up to 15 SATA devices may be plugged directly to each SATA port multiplier supported by the Solaris SATA framework. The actual number of pluggable devices my be lower, and is limited by the number of device ports on the SATA HBA or the SATA port multiplier. The maximum data rate is either 1.5Gb/sec. or 3.0Gb/sec., depending on the capability of a SATA device, port multiplier and SATA HBA controller.
The Solaris SATA framework adheres to the Serial ATA 1.0a specification and supports SATA-2 signaling speed 3.0Gb/sec. SATA devices that are connected to SATA HBAs controlled by a SATA framework-compliant HBA driver are treated by the system as SCSI devices. The Solaris SCSI disk driver (sd(7D)) is attached as a target driver for each device node created by the SATA framework. You can use the cfgadm(1M) utility to manage hot plugged and unplugged SATA devices.
32–bit ELF kernel module (x86).
64–bit ELF kernel module (x86).
See attributes(5) for descriptions of the following attribute:
Serial ATA 1.0a Specification — Serial ATA International Organization.
Serial ATA II (Extension to Serial ATA 1.0.a.) — Serial ATA International Organization.
The messages described below may appear on the system console as well as being logged. All messages are presented in one of the following formats and are followed by the diagnostic message:
sata: WARNING: <controller/devices/.. path>:
sata: NOTICE: <controller/devices/.. path>:
...where <controller/devices/.. path> identifies a specific SATA HBA issuing a diagnostic message shown below.
Communication (via serial link) between the HBA and the device plugged to the specified SATA device port has been lost.
Communication (via serial link) between the HBA and the device plugged to the specified SATA device port has been established.
The device plugged to the specified SATA device port has been reset. The reset may be due to a communication or command error, command timeout, or an explicit request from the host.
The specified SATA device port failed and is in an unusable state. You can change the port state by deactivating the port and activating it again using cfgadm SATA hardware-specific commands (see cfgadm_sata(1M)).
An error was detected in specified SATA device port operations.
Communication (via serial link) between the HBA and the device plugged to the specified SATA device port has been lost and could not be re-established. The SATA framework assumes that the device is unplugged from the specified SATA device port.
Communication( via serial link) between the HBA and the device plugged to the specified empty SATA device port has been established. The SATA framework assumes that the new device is plugged to the specified SATA device port.
This message is followed by a disk description specifying the disk vendor, serial number, firmware revision number and the disk capabilities.
This message is followed by a SATA CD/DVD description specifying the DVD vendor, serial number, firmware revision number and the DVD capabilities.
The port cannot be configured because there is application using the previous attached device, so the application must release it, then the newly inserted device can be configured.
The target node remained and it belongs to a previously attached device. This happens when the file was open or the node was waiting for resources at the time the associated device was removed. Instruct event daemon to retry the cleanup later.
When error recovery is requested, the device is not yet attached.
When property pm-capable on the target device node setting fails, the SATA device won't be power-managed.
The disk device plugged into specified SATA device port does not support LBA addressing and cannot be used.
IDENTIFY (PACKET) DEVICE data cannot be retrieved successfully after the device is attached to the SATA port.
The SATA HBA instance attach operation failed. This HBA instance cannot be configured and is not available.
The length of the command cdb is greater than that the device can support.
The specified SATA HBA driver and the SATA framework are incompatible. The driver cannot attach and SATA HBAs controlled by this driver (and devices plugged to this SATA HBA ports) are not available.
The specified SATA device port cannot be configured in the system and a device plugged to this port could not be not be configured and used.
The device target node for the device plugged to the specified SATA device port could not be created. As a result, the device cannot be configured and used.