|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- System Management BIOS image
The smbios device is a character special file that provides access to a snapshot of the System Management BIOS (SMBIOS) image exported by the current system. SMBIOS is an industry-standard mechanism that enables low-level system software to export hardware configuration information to higher-level system management software. The SMBIOS data format is defined by the Distributed Management Task Force (DMTF). For more information on SMBIOS and to obtain a copy of the SMBIOS specification and implementation guidelines, refer to http://www.dmtf.org.
The SMBIOS image consists of a table of structures, each describing some aspect of the system software or hardware configuration. The content of the image varies widely by platform and BIOS vendor and may not exist on some systems. You can use the smbios(1M) utility to inspect the contents of the SMBIOS image and copy it to a file.
See attributes(5) for a description of the following attributes:
System Management BIOS Reference Specification, Version 2, Release 4 — 2005
The implementation of a System Management BIOS image is entirely at the discretion of the system and BIOS vendors. Not all systems export a SMBIOS. The SMBIOS structure content varies widely between systems and BIOS vendors and frequently does not comply with the guidelines included in the specification. For example, some structure fields may not be filled in by the BIOS, while others may be filled in with non-conforming values.