|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- SCSI RDMA Protocol Target Driver for Infiniband (IB)
The srpt kernel pseudo device driver is an IB Architecture-compliant implementation of the target side of the SCSI RDMA Protocol (SRP). SRP accelerates the SCSI protocol by mapping SCSI data transfer phases to RDMA operations using InfiniBand as the underlying transport.
SRP target services are enabled and disabled through smf(5), using the FMRI svc:/system/ibsrp/target.
When enabled, srpt enumerates each IB Host Channel Adapter (HCA) on the system and registers each one as a SCSI target using the SCSI Target Mode Framework (STMF).
64-bit x86 ELF kernel module
64-bit SPARC ELF kernel module
Driver configuration file
See attributes(5) for a description of the following attributes:
COMSTAR Administration Guide
SCSI RDMA Protocol (SRP) T10 Project 1415-D, Revision