|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library|
- return the number of channels for an audio engine
#include <sys/audio/audio_driver.h> int prefix_channels(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_channels() function is called by the framework to determine the number of channels used by the engine.
The audio framework currently supports between one and 16 channels.
There is no standard convention for the layout of more than eight channels.
An audio engine may not change the number of channels it uses while it is open.
The audio_engine_channels() function returns the number of channels for the engine (such as 1 for mono, 2 for stereo, 6 for 5.1 surround, or 8 for 7.1 surround.)
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes: