|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library|
- start or stop an audio engine
#include <sys/audio/audio_driver.h> int prefix_start(void *state);
void prefix_stop(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_start() function starts an audio engine that has been initialized with audio_engine_open(9E). This initiates actual playback or recording of audio. The data transfer must start at the first frame in the engine's buffer.
The audio_engine_stop() function stops an audio engine that was previously started with audio_engine_start() and resets the frame index back to 0. The master frame counter for the engine is not reset.
Once audio_engine_stop() returns, the engine must not perform any further data transfers to or from the audio buffer. Furthermore, actual play back or capture of audio associated with the engine shall have ceased.
The audio_engine_start() function returns 0 on success or an error number on failure.
These functions may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: