JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Driver Entry Points     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Driver Entry Points

aread(9E)

attach(9E)

audio_engine_channels(9E)

audio_engine_chinfo(9E)

audio_engine_close(9E)

audio_engine_count(9E)

audio_engine_format(9E)

audio_engine_open(9E)

audio_engine_playahead(9E)

audio_engine_qlen(9E)

audio_engine_rate(9E)

audio_engine_start(9E)

audio_engine_stop(9E)

audio_engine_sync(9E)

awrite(9E)

chpoll(9E)

close(9E)

csx_event_handler(9E)

detach(9E)

devmap(9E)

devmap_access(9E)

devmap_contextmgt(9E)

devmap_dup(9E)

devmap_map(9E)

devmap_unmap(9E)

dump(9E)

_fini(9E)

getinfo(9E)

gld(9E)

gldm_get_stats(9E)

gldm_intr(9E)

gldm_ioctl(9E)

gldm_reset(9E)

gldm_send(9E)

gldm_set_mac_addr(9E)

gldm_set_multicast(9E)

gldm_set_promiscuous(9E)

gldm_start(9E)

gldm_stop(9E)

identify(9E)

_info(9E)

_init(9E)

ioctl(9E)

ks_snapshot(9E)

ks_update(9E)

mac(9E)

mac_capab_rings(9E)

mac_group_info(9E)

mac_ring_info(9E)

mc_getcapab(9E)

mc_getprop(9E)

mc_getstat(9E)

mc_ioctl(9E)

mc_multicst(9E)

mc_propinfo(9E)

mc_setpromisc(9E)

mc_setprop(9E)

mc_start(9E)

mc_stop(9E)

mc_tx(9E)

mc_unicst(9E)

mgi_addmac(9E)

mgi_add_vlanfilter(9E)

mgi_getsriov_info(9E)

mgi_remmac(9E)

mgi_rem_vlanfliter(9E)

mgi_setmtu(9E)

mgi_start(9E)

mgi_stop(9E)

mmap(9E)

mr_gaddring(9E)

mr_gget(9E)

mr_gremring(9E)

mri_intr_disable(9E)

mri_intr_enable(9E)

mri_poll(9E)

mri_start(9E)

mri_stat(9E)

mri_stop(9E)

mri_tx(9E)

mr_rget(9E)

open(9E)

power(9E)

print(9E)

probe(9E)

prop_op(9E)

put(9E)

quiesce(9E)

read(9E)

segmap(9E)

sofop_accepted(9E)

sofop_attach_active(9E)

sofop_attach_passive(9E)

sofop_bind(9E)

sofop_connect(9E)

sofop_data_in(9E)

sofop_data_in_proc(9E)

sofop_data_out(9E)

sofop_detach(9E)

sofop_getpeername(9E)

sofop_getsockname(9E)

sofop_getsockopt(9E)

sofop_listen(9E)

sofop_notify(9E)

sofop_setsockopt(9E)

sofop_shutdown(9E)

srv(9E)

strategy(9E)

tran_abort(9E)

tran_bus_reset(9E)

tran_destroy_pkt(9E)

tran_dmafree(9E)

tran_getcap(9E)

tran_init_pkt(9E)

tran_pkt_constructor(9E)

tran_pkt_destructor(9E)

tran_quiesce(9E)

tran_reset(9E)

tran_reset_notify(9E)

tran_setcap(9E)

tran_setup_pkt(9E)

tran_start(9E)

tran_sync_pkt(9E)

tran_teardown_pkt(9E)

tran_tgt_free(9E)

tran_tgt_init(9E)

tran_tgt_probe(9E)

tran_unquiesce(9E)

write(9E)

mac_ring_info

, mri_start

, mri_stop

, mri_tx

, mri_poll

, mri_stat

, mri_intr_enable

, mri_intr_disable

- MAC ring info driver entry points

Synopsis

#include <sys/mac_provider.h>

int mri_start(mac_ring_driver_t ring_handle, uint64_t gen_num);
void mri_stop(mac_ring_driver_t ring_handle);
mblk_t *mri_tx(void *arg, mblk_t *mp);
mblk_t *mri_poll(void *arg, int nbytes, int npackets);
int mri_stat(mac_ring_driver_t ring_handle, uint_t stat,
      uint64_t *val);
int mri_intr_enable(mac_intr_handle_t *ihandle);
int mri_intr_disable(mac_intr_handle_t *ihandle);

Parameters

ring_handle

The opaque handle to the driver's representation of the specified ring.

gen_num

Generation number for this ring.

arg

Opaque handle to the driver's ring.

mblk_t

Chain of mblk packet buffers.

nbytes

The number of total bytes that will be polled for this call to mri_poll().

npackets

The maximum number of packets that will be returned for this call to mri_poll().

statsp

The pointer to the ring statistic being queried.

ihandle

The opaque handle to the driver private data representing this interrupt.

Interface Level

Solaris architecture specific (Solaris DDI).

Description

The mri_start() function is the driver entry point called by the MAC layer to start the ring processing packets. The mri_stop() function is the driver entry point called by the MAC layer to stop the ring processing packets.

The mri_stop() function is the driver entry point called by the MAC layer to stop the ring processing packets

The mri_tx() function is the driver entry point called by the MAC layer to transmit packets. This is a TX ring only entry point.

The mri_poll() function is the driver entry point called by the MAC layer to poll for the reception of incoming packets. This is RX ring only driver entry point. Packets are returned to the MAC layer as a chain of mblks. The parameters of nbytes is used to cap the number of bytes that can be polled while the npackets parameters caps the number of packets that can be polled.

The mri_stat() function is the driver entry point called to get various ring statistics. Statistics included for TX/RX rings:

MAC_STAT_OERRORS
MAC_STAT_OBYTES
MAC_STAT_OPACKETS
MAC_STAT_IERRORS
MAC_STAT_IBYTES
MAC_STAT_IPACKETS

The mri_intr_enable() function is the driver entry point called by the MAC layer to enable interrupts to re-enable interrupts while transitioning the ring from polling mode to interrupt mode. This is an RX ring entry point.

The mri_intr_disable() function is the driver entry point called by the MAC layer to disable interrupts for the specified ring while transitioning the ring to polling mode.

Return Values

The mri_start() function returns 0 on success and EIO when the operation fails.

The mri_tx() function returns NULL if all packets are transmitted. It returns some or all of the mblk chain if some or all of the packets where processed.

The mri_poll() function returns It returns a chain of packets received during this poll call or NULL if no packets where received.

The mri_stat() function returns 0 on success and ENOTUSP if the statistic is not supported.

The mri_intr_enable() function returns 0 on success.

The mri_intr_disable() function returns 0 on success.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), mac_capab_rings(9E), mac_group_info(9E), mac_capab_rings(9S), mac_register(9S)