JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Driver Entry Points     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Driver Entry Points

aread(9E)

attach(9E)

audio_engine_channels(9E)

audio_engine_chinfo(9E)

audio_engine_close(9E)

audio_engine_count(9E)

audio_engine_format(9E)

audio_engine_open(9E)

audio_engine_playahead(9E)

audio_engine_qlen(9E)

audio_engine_rate(9E)

audio_engine_start(9E)

audio_engine_stop(9E)

audio_engine_sync(9E)

awrite(9E)

chpoll(9E)

close(9E)

csx_event_handler(9E)

detach(9E)

devmap(9E)

devmap_access(9E)

devmap_contextmgt(9E)

devmap_dup(9E)

devmap_map(9E)

devmap_unmap(9E)

dump(9E)

_fini(9E)

getinfo(9E)

gld(9E)

gldm_get_stats(9E)

gldm_intr(9E)

gldm_ioctl(9E)

gldm_reset(9E)

gldm_send(9E)

gldm_set_mac_addr(9E)

gldm_set_multicast(9E)

gldm_set_promiscuous(9E)

gldm_start(9E)

gldm_stop(9E)

identify(9E)

_info(9E)

_init(9E)

ioctl(9E)

ks_snapshot(9E)

ks_update(9E)

mac(9E)

mac_capab_rings(9E)

mac_group_info(9E)

mac_ring_info(9E)

mc_getcapab(9E)

mc_getprop(9E)

mc_getstat(9E)

mc_ioctl(9E)

mc_multicst(9E)

mc_propinfo(9E)

mc_setpromisc(9E)

mc_setprop(9E)

mc_start(9E)

mc_stop(9E)

mc_tx(9E)

mc_unicst(9E)

mgi_addmac(9E)

mgi_add_vlanfilter(9E)

mgi_getsriov_info(9E)

mgi_remmac(9E)

mgi_rem_vlanfliter(9E)

mgi_setmtu(9E)

mgi_start(9E)

mgi_stop(9E)

mmap(9E)

mr_gaddring(9E)

mr_gget(9E)

mr_gremring(9E)

mri_intr_disable(9E)

mri_intr_enable(9E)

mri_poll(9E)

mri_start(9E)

mri_stat(9E)

mri_stop(9E)

mri_tx(9E)

mr_rget(9E)

open(9E)

power(9E)

print(9E)

probe(9E)

prop_op(9E)

put(9E)

quiesce(9E)

read(9E)

segmap(9E)

sofop_accepted(9E)

sofop_attach_active(9E)

sofop_attach_passive(9E)

sofop_bind(9E)

sofop_connect(9E)

sofop_data_in(9E)

sofop_data_in_proc(9E)

sofop_data_out(9E)

sofop_detach(9E)

sofop_getpeername(9E)

sofop_getsockname(9E)

sofop_getsockopt(9E)

sofop_listen(9E)

sofop_notify(9E)

sofop_setsockopt(9E)

sofop_shutdown(9E)

srv(9E)

strategy(9E)

tran_abort(9E)

tran_bus_reset(9E)

tran_destroy_pkt(9E)

tran_dmafree(9E)

tran_getcap(9E)

tran_init_pkt(9E)

tran_pkt_constructor(9E)

tran_pkt_destructor(9E)

tran_quiesce(9E)

tran_reset(9E)

tran_reset_notify(9E)

tran_setcap(9E)

tran_setup_pkt(9E)

tran_start(9E)

tran_sync_pkt(9E)

tran_teardown_pkt(9E)

tran_tgt_free(9E)

tran_tgt_init(9E)

tran_tgt_probe(9E)

tran_unquiesce(9E)

write(9E)

sofop_bind

, sofop_listen

, sofop_connect

, sofop_accepted

, sofop_shutdown

, sofop_getsockname

, sofop_getpeername

, sofop_setsockopt

, sofop_getsockopt

- filter socket operations

Synopsis

#include <sys/sockfilter.h>

sof_rval_t prefix_bind(sof_handle_t hdl, void *cookie,
     struct sockaddr *addr, socklen_t addrlen, cred_t *cr);
sof_rval_t prefix_listen(sof_handle_t hdl, void *cookie,
     int *backlogp, cred_t *cr);
sof_rval_t prefix_accepted(sof_handle_t hdl, void *cookie,
     cred_t *cr);
sof_rval_t prefix_connect(sof_handle_t hdl, void *cookie,
     struct sockaddr *addr, socklen_t addrlen, cred_t *cr);
sof_rval_t prefix_shutdown(sof_handle_t hdl, void *cookie,
     int *howp, cred_t *cr);
sof_rval_t prefix_getsockname(sof_handle_t hdl, void *cookie,
     struct sockaddr *addr, socklen_t *addrlenp, cred_t *cr);
sof_rval_t prefix_getpeername(sof_handle_t hdl, void *cookie,
     struct sockaddr *addr, socklen_t *addrlenp, cred_t *cr);
sof_rval_t prefix_setsockopt(sof_handle_t hdl, void *cookie,
     int level, int options, void *opt, socklen_t *optlenp,
     cred_t *cr);
sof_rval_t prefix_getsockopt(sof_handle_t hdl, void *cookie,
     int level, int option, void *opt, socklen_t *optlenp,
     cred_t *cr);

Parameters

hdl

per-socket filter handle

cookie

per-socket filter-private data

cr

pointer to the user credential structure for the operation

addr

pointer to address

addrlen

address length, in bytes

addrlenp

pointer to address length, in bytes

backlogp

pointer to backlog value

level

level of the socket option

option

name of the socket option

opt

pointer to option data

optlenp

pointer to options data length, in bytes

Description

The entry points described below are called in response to socket operations being issued on a socket to which the filter is attached. A filter can interrupt an operation, causing it to return immediately, by either returning an error, or SOF_RVAL_RETURN. Returning an error causes the operation to report a failure.

The sofop_bind() entry point is called when a bind(3SOCKET) operation is issued on the socket. The filter can modify the address.

The sofop_listen() entry point is called when a listen(3SOCKET) operation is issued on the socket. The filter can modify the backlog size.

The sofop_accepted() entry point is called when the socket has been accepted from the listener's accept queue. Returning an error will cause the connection to terminate, and accept(3SOCKET) will report the failure.

The sofop_connect() entry point is called when a connect(3SOCKET) operation is issued on the socket. The filter can modify the address.

The sofop_shutdown() entry point is called when a shutdown() operation is issued on the socket. The filter can modify how the socket is to be shut down, but the value must be one of the valid values listed in shutdown(3SOCKET).

The sofop_getsockname() entry point is called when a getsockname(3SOCKET) operation is issued on the socket. The filter can modify the address and address length. The address length can only be reduced.

The sofop_getpeername() entry point is called when a getpeername(3SOCKET) operation is issued on the socket. The filter can modify the address and address length. The address length can only be reduced.

The sofop_setsockopt() entry point is called when a setsockopt(3SOCKET) operations is issued on the socket. The filter can to modify the option data and option data length. The option data length can only be reduced.

The sofop_getsockopt() entry point is called when a getsockopt(3SOCKET) operation is issued on the socket. The filter can modify the option data and option data length. The option data length can only be reduced.

Return Values

The sofop_bind(), sofop_listen(), sofop_accepted(), sofop_connect(), sofop_shutdown(), sofop_getsockname(), sofop_getpeername(), sofop_setsockopt(), and sofop_getsockopt() entry points return:

SOF_RVAL_CONTINUE

The operation will continue as normal.

SOF_RVAL_EINVAL

An argument was invalid.

SOF_RVAL_ENOMEM

There was insufficient memory for the operation to complete.

SOF_RVAL_EPERM

Permission was denied.

SOF_RVAL_RETURN

The filter satisfied the request, and the operation will return immediately without being processed by the protocol.

The sofop_accepted() entry point may also return:

SOF_RVAL_ECONNABORTED

Software caused the connection to abort.

Context

All entry points can be called from kernel or user context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/kernel
Interface Stability
Uncommitted

See Also

accept(3SOCKET), bind(3SOCKET), connect(3SOCKET), getpeername(3SOCKET), getsockname(3SOCKET), getsockopt(3SOCKET), listen(3SOCKET), setsockopt(3SOCKET), shutdown(3SOCKET), attributes(5), sof_bypass(9F), sof_flowctrl_data_in(9F), sof_inject_data_in(9F), sof_ops(9S)