|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- set or return the client event mask for the client
#include <sys/pccard.h> int32_t csx_SetEventMask(client_handle_t ch, sockevent_t *se);
int32_t csx_GetEventMask(client_handle_t ch, sockevent_t *se);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a sockevent_t structure
The function csx_SetEventMask() sets the client or global event mask for the client.
The function csx_GetEventMask() returns the client or global event mask for the client.
csx_RequestSocketMask(9F) must be called before calling csx_SetEventMask() for the client event mask for this socket.
The structure members of sockevent_t are:
uint32_t uint32_t /* attribute flags for call */ uint32_t EventMask; /* event mask to set or return */ uint32_t Socket; /* socket number if necessary */
The fields are defined as follows:
This is a bit-mapped field that identifies the type of event mask to be returned. The field is defined as follows:
Client's global event mask. If set, the client's global event mask is returned.
Client's local event mask. If set, the client's local event mask is returned.
This field is bit-mapped. Card Services performs event notification based on this field. See csx_event_handler(9E) for valid event definitions and for additional information about handling events.
Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.
Client handle is invalid.
csx_RequestSocketMask(9F) not called for CONF_EVENT_MASK_CLIENT.
No PCMCIA hardware installed.
These functions may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA