JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Kernel Functions     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Kernel Functions for Drivers

adjmsg(9F)

allocb(9F)

allocb_tmpl(9F)

aminphys(9F)

anocancel(9F)

aphysio(9F)

ASSERT(9F)

assert(9F)

atomic_add_16(9F)

atomic_add_16_nv(9F)

atomic_add_32(9F)

atomic_add_32_nv(9F)

atomic_add_64(9F)

atomic_add_64_nv(9F)

atomic_add_8(9F)

atomic_add_8_nv(9F)

atomic_add(9F)

atomic_add_char(9F)

atomic_add_char_nv(9F)

atomic_add_int(9F)

atomic_add_int_nv(9F)

atomic_add_long(9F)

atomic_add_long_nv(9F)

atomic_add_ptr(9F)

atomic_add_ptr_nv(9F)

atomic_add_short(9F)

atomic_add_short_nv(9F)

atomic_and_16(9F)

atomic_and_16_nv(9F)

atomic_and_32(9F)

atomic_and_32_nv(9F)

atomic_and_64(9F)

atomic_and_64_nv(9F)

atomic_and_8(9F)

atomic_and_8_nv(9F)

atomic_and(9F)

atomic_and_uchar(9F)

atomic_and_uchar_nv(9F)

atomic_and_uint(9F)

atomic_and_uint_nv(9F)

atomic_and_ulong(9F)

atomic_and_ulong_nv(9F)

atomic_and_ushort(9F)

atomic_and_ushort_nv(9F)

atomic_bits(9F)

atomic_cas_16(9F)

atomic_cas_32(9F)

atomic_cas_64(9F)

atomic_cas_8(9F)

atomic_cas(9F)

atomic_cas_ptr(9F)

atomic_cas_uchar(9F)

atomic_cas_uint(9F)

atomic_cas_ulong(9F)

atomic_cas_ushort(9F)

atomic_clear_long_excl(9F)

atomic_dec_16(9F)

atomic_dec_16_nv(9F)

atomic_dec_32(9F)

atomic_dec_32_nv(9F)

atomic_dec_64(9F)

atomic_dec_64_nv(9F)

atomic_dec_8(9F)

atomic_dec_8_nv(9F)

atomic_dec(9F)

atomic_dec_ptr(9F)

atomic_dec_ptr_nv(9F)

atomic_dec_uchar(9F)

atomic_dec_uchar_nv(9F)

atomic_dec_uint(9F)

atomic_dec_uint_nv(9F)

atomic_dec_ulong(9F)

atomic_dec_ulong_nv(9F)

atomic_dec_ushort(9F)

atomic_dec_ushort_nv(9F)

atomic_inc_16(9F)

atomic_inc_16_nv(9F)

atomic_inc_32(9F)

atomic_inc_32_nv(9F)

atomic_inc_64(9F)

atomic_inc_64_nv(9F)

atomic_inc_8(9F)

atomic_inc_8_nv(9F)

atomic_inc(9F)

atomic_inc_ptr(9F)

atomic_inc_ptr_nv(9F)

atomic_inc_uchar(9F)

atomic_inc_uchar_nv(9F)

atomic_inc_uint(9F)

atomic_inc_uint_nv(9F)

atomic_inc_ulong(9F)

atomic_inc_ulong_nv(9F)

atomic_inc_ushort(9F)

atomic_inc_ushort_nv(9F)

atomic_ops(9F)

atomic_or_16(9F)

atomic_or_16_nv(9F)

atomic_or_32(9F)

atomic_or_32_nv(9F)

atomic_or_64(9F)

atomic_or_64_nv(9F)

atomic_or_8(9F)

atomic_or_8_nv(9F)

atomic_or(9F)

atomic_or_uchar(9F)

atomic_or_uchar_nv(9F)

atomic_or_uint(9F)

atomic_or_uint_nv(9F)

atomic_or_ulong(9F)

atomic_or_ulong_nv(9F)

atomic_or_ushort(9F)

atomic_or_ushort_nv(9F)

atomic_set_long_excl(9F)

atomic_swap_16(9F)

atomic_swap_32(9F)

atomic_swap_64(9F)

atomic_swap_8(9F)

atomic_swap(9F)

atomic_swap_ptr(9F)

atomic_swap_uchar(9F)

atomic_swap_uint(9F)

atomic_swap_ulong(9F)

atomic_swap_ushort(9F)

audio_control_read(9F)

audio_control_write(9F)

audio_dev_add_control(9F)

audio_dev_add_engine(9F)

audio_dev_add_info(9F)

audio_dev_add_soft_volume(9F)

audio_dev_alloc(9F)

audio_dev_del_control(9F)

audio_dev_free(9F)

audio_dev_register(9F)

audio_dev_remove_engine(9F)

audio_dev_resume(9F)

audio_dev_set_description(9F)

audio_dev_set_version(9F)

audio_dev_suspend(9F)

audio_dev_unregister(9F)

audio_dev_update_controls(9F)

audio_dev_warn(9F)

audio_engine_alloc(9F)

audio_engine_free(9F)

audio_engine_get_private(9F)

audio_engine_set_private(9F)

audio_fini_ops(9F)

audio_init_ops(9F)

backq(9F)

bcanput(9F)

bcanputnext(9F)

bcmp(9F)

bcopy(9F)

bioaligned(9F)

bioclone(9F)

biodone(9F)

bioerror(9F)

biofini(9F)

bioinit(9F)

biomodified(9F)

bioreset(9F)

biosize(9F)

biowait(9F)

bp_copyin(9F)

bp_copyout(9F)

bp_mapin(9F)

bp_mapout(9F)

btop(9F)

btopr(9F)

bufcall(9F)

bzero(9F)

canput(9F)

canputnext(9F)

CIRCLEQ_EMPTY(9F)

CIRCLEQ_ENTRY(9F)

CIRCLEQ_FIRST(9F)

CIRCLEQ_FOREACH(9F)

CIRCLEQ_FOREACH_REVERSE(9F)

CIRCLEQ_HEAD(9F)

CIRCLEQ_HEAD_INITIALIZER(9F)

CIRCLEQ_INIT(9F)

CIRCLEQ_INSERT_AFTER(9F)

CIRCLEQ_INSERT_BEFORE(9F)

CIRCLEQ_INSERT_HEAD(9F)

CIRCLEQ_INSERT_TAIL(9F)

CIRCLEQ_LAST(9F)

CIRCLEQ_LOOP_NEXT(9F)

CIRCLEQ_LOOP_PREV(9F)

CIRCLEQ_NEXT(9F)

CIRCLEQ_PREV(9F)

CIRCLEQ_REMOVE(9F)

clrbuf(9F)

cmn_err(9F)

condvar(9F)

copyb(9F)

copyin(9F)

copymsg(9F)

copyout(9F)

crgetgid(9F)

crgetgroups(9F)

crgetngroups(9F)

crgetrgid(9F)

crgetruid(9F)

crgetsgid(9F)

crgetsuid(9F)

crgetuid(9F)

crgetzoneid(9F)

csx_AccessConfigurationRegister(9F)

csx_ConvertSize(9F)

csx_ConvertSpeed(9F)

csx_CS_DDI_Info(9F)

csx_DeregisterClient(9F)

csx_DupHandle(9F)

csx_Error2Text(9F)

csx_Event2Text(9F)

csx_FreeHandle(9F)

csx_Get16(9F)

csx_Get32(9F)

csx_Get64(9F)

csx_Get8(9F)

csx_GetEventMask(9F)

csx_GetFirstClient(9F)

csx_GetFirstTuple(9F)

csx_GetHandleOffset(9F)

csx_GetMappedAddr(9F)

csx_GetNextClient(9F)

csx_GetNextTuple(9F)

csx_GetStatus(9F)

csx_GetTupleData(9F)

csx_MakeDeviceNode(9F)

csx_MapLogSocket(9F)

csx_MapMemPage(9F)

csx_ModifyConfiguration(9F)

csx_ModifyWindow(9F)

csx_Parse_CISTPL_BATTERY(9F)

csx_Parse_CISTPL_BYTEORDER(9F)

csx_Parse_CISTPL_CFTABLE_ENTRY(9F)

csx_Parse_CISTPL_CONFIG(9F)

csx_Parse_CISTPL_DATE(9F)

csx_Parse_CISTPL_DEVICE(9F)

csx_Parse_CISTPL_DEVICE_A(9F)

csx_Parse_CISTPL_DEVICEGEO(9F)

csx_Parse_CISTPL_DEVICEGEO_A(9F)

csx_Parse_CISTPL_DEVICE_OA(9F)

csx_Parse_CISTPL_DEVICE_OC(9F)

csx_Parse_CISTPL_FORMAT(9F)

csx_Parse_CISTPL_FUNCE(9F)

csx_Parse_CISTPL_FUNCID(9F)

csx_Parse_CISTPL_GEOMETRY(9F)

csx_Parse_CISTPL_JEDEC_A(9F)

csx_Parse_CISTPL_JEDEC_C(9F)

csx_Parse_CISTPL_LINKTARGET(9F)

csx_Parse_CISTPL_LONGLINK_A(9F)

csx_Parse_CISTPL_LONGLINK_C(9F)

csx_Parse_CISTPL_LONGLINK_MFC(9F)

csx_Parse_CISTPL_MANFID(9F)

csx_Parse_CISTPL_ORG(9F)

csx_Parse_CISTPL_SPCL(9F)

csx_Parse_CISTPL_SWIL(9F)

csx_Parse_CISTPL_VERS_1(9F)

csx_Parse_CISTPL_VERS_2(9F)

csx_ParseTuple(9F)

csx_Put16(9F)

csx_Put32(9F)

csx_Put64(9F)

csx_Put8(9F)

csx_RegisterClient(9F)

csx_ReleaseConfiguration(9F)

csx_ReleaseIO(9F)

csx_ReleaseIRQ(9F)

csx_ReleaseSocketMask(9F)

csx_ReleaseWindow(9F)

csx_RemoveDeviceNode(9F)

csx_RepGet16(9F)

csx_RepGet32(9F)

csx_RepGet64(9F)

csx_RepGet8(9F)

csx_RepPut16(9F)

csx_RepPut32(9F)

csx_RepPut64(9F)

csx_RepPut8(9F)

csx_RequestConfiguration(9F)

csx_RequestIO(9F)

csx_RequestIRQ(9F)

csx_RequestSocketMask(9F)

csx_RequestWindow(9F)

csx_ResetFunction(9F)

csx_SetEventMask(9F)

csx_SetHandleOffset(9F)

csx_ValidateCIS(9F)

cv_broadcast(9F)

cv_destroy(9F)

cv_init(9F)

cv_reltimedwait(9F)

cv_reltimedwait_sig(9F)

cv_signal(9F)

cv_timedwait(9F)

cv_timedwait_sig(9F)

cv_wait(9F)

cv_wait_sig(9F)

datamsg(9F)

DB_BASE(9F)

DB_LIM(9F)

DB_REF(9F)

DB_TYPE(9F)

ddi_add_event_handler(9F)

ddi_add_intr(9F)

ddi_add_softintr(9F)

ddi_binding_name(9F)

ddi_btop(9F)

ddi_btopr(9F)

ddi_can_receive_sig(9F)

ddi_cb_register(9F)

ddi_cb_unregister(9F)

ddi_check_acc_handle(9F)

ddi_check_dma_handle(9F)

ddi_copyin(9F)

ddi_copyout(9F)

ddi_create_minor_node(9F)

ddi_cred(9F)

ddi_device_copy(9F)

ddi_device_zero(9F)

ddi_devid_compare(9F)

ddi_devid_free(9F)

ddi_devid_get(9F)

ddi_devid_init(9F)

ddi_devid_register(9F)

ddi_devid_sizeof(9F)

ddi_devid_str_decode(9F)

ddi_devid_str_encode(9F)

ddi_devid_str_free(9F)

ddi_devid_unregister(9F)

ddi_devid_valid(9F)

ddi_dev_is_sid(9F)

ddi_devmap_segmap(9F)

ddi_dev_nintrs(9F)

ddi_dev_nregs(9F)

ddi_dev_regsize(9F)

ddi_dev_report_fault(9F)

ddi_dma_addr_bind_handle(9F)

ddi_dma_addr_setup(9F)

ddi_dma_alloc_handle(9F)

ddi_dma_buf_bind_handle(9F)

ddi_dma_buf_setup(9F)

ddi_dma_burstsizes(9F)

ddi_dma_coff(9F)

ddi_dma_curwin(9F)

ddi_dma_devalign(9F)

ddi_dmae_1stparty(9F)

ddi_dmae(9F)

ddi_dmae_alloc(9F)

ddi_dmae_disable(9F)

ddi_dmae_enable(9F)

ddi_dmae_getattr(9F)

ddi_dmae_getcnt(9F)

ddi_dmae_getlim(9F)

ddi_dmae_prog(9F)

ddi_dmae_release(9F)

ddi_dmae_stop(9F)

ddi_dma_free(9F)

ddi_dma_free_handle(9F)

ddi_dma_get_attr(9F)

ddi_dma_getwin(9F)

ddi_dma_htoc(9F)

ddi_dma_mem_alloc(9F)

ddi_dma_mem_free(9F)

ddi_dma_movwin(9F)

ddi_dma_nextcookie(9F)

ddi_dma_nextseg(9F)

ddi_dma_nextwin(9F)

ddi_dma_numwin(9F)

ddi_dma_segtocookie(9F)

ddi_dma_set_sbus64(9F)

ddi_dma_setup(9F)

ddi_dma_sync(9F)

ddi_dma_unbind_handle(9F)

ddi_driver_major(9F)

ddi_driver_name(9F)

ddi_enter_critical(9F)

ddi_exit_critical(9F)

ddi_ffs(9F)

ddi_fls(9F)

ddi_fm_acc_err_clear(9F)

ddi_fm_acc_err_get(9F)

ddi_fm_capable(9F)

ddi_fm_dma_err_clear(9F)

ddi_fm_dma_err_get(9F)

ddi_fm_ereport_post(9F)

ddi_fm_fini(9F)

ddi_fm_handler_register(9F)

ddi_fm_handler_unregister(9F)

ddi_fm_init(9F)

ddi_fm_service_impact(9F)

ddi_get16(9F)

ddi_get32(9F)

ddi_get64(9F)

ddi_get8(9F)

ddi_getb(9F)

ddi_get_cred(9F)

ddi_get_devstate(9F)

ddi_get_driver_private(9F)

ddi_get_eventcookie(9F)

ddi_get_iblock_cookie(9F)

ddi_getiminor(9F)

ddi_get_instance(9F)

ddi_get_kt_did(9F)

ddi_getl(9F)

ddi_get_lbolt64(9F)

ddi_get_lbolt(9F)

ddi_getll(9F)

ddi_getlongprop(9F)

ddi_getlongprop_buf(9F)

ddi_get_name(9F)

ddi_get_parent(9F)

ddi_get_pid(9F)

ddi_getprop(9F)

ddi_getproplen(9F)

ddi_get_soft_iblock_cookie(9F)

ddi_get_soft_state(9F)

ddi_get_time(9F)

ddi_getw(9F)

ddi_in_panic(9F)

ddi_intr_add_handler(9F)

ddi_intr_add_softint(9F)

ddi_intr_alloc(9F)

ddi_intr_block_disable(9F)

ddi_intr_block_enable(9F)

ddi_intr_clr_mask(9F)

ddi_intr_disable(9F)

ddi_intr_dup_handler(9F)

ddi_intr_enable(9F)

ddi_intr_free(9F)

ddi_intr_get_cap(9F)

ddi_intr_get_hilevel_pri(9F)

ddi_intr_get_navail(9F)

ddi_intr_get_nintrs(9F)

ddi_intr_get_pending(9F)

ddi_intr_get_pri(9F)

ddi_intr_get_softint_pri(9F)

ddi_intr_get_supported_types(9F)

ddi_intr_hilevel(9F)

ddi_intr_remove_handler(9F)

ddi_intr_remove_softint(9F)

ddi_intr_set_cap(9F)

ddi_intr_set_mask(9F)

ddi_intr_set_nreq(9F)

ddi_intr_set_pri(9F)

ddi_intr_set_softint_pri(9F)

ddi_intr_trigger_softint(9F)

ddi_io_get16(9F)

ddi_io_get32(9F)

ddi_io_get8(9F)

ddi_io_getb(9F)

ddi_io_getl(9F)

ddi_io_getw(9F)

ddi_iomin(9F)

ddi_iopb_alloc(9F)

ddi_iopb_free(9F)

ddi_io_put16(9F)

ddi_io_put32(9F)

ddi_io_put8(9F)

ddi_io_putb(9F)

ddi_io_putl(9F)

ddi_io_putw(9F)

ddi_io_rep_get16(9F)

ddi_io_rep_get32(9F)

ddi_io_rep_get8(9F)

ddi_io_rep_getb(9F)

ddi_io_rep_getl(9F)

ddi_io_rep_getw(9F)

ddi_io_rep_put16(9F)

ddi_io_rep_put32(9F)

ddi_io_rep_put8(9F)

ddi_io_rep_putb(9F)

ddi_io_rep_putl(9F)

ddi_io_rep_putw(9F)

ddi_log_sysevent(9F)

ddi_map_regs(9F)

ddi_mem_alloc(9F)

ddi_mem_free(9F)

ddi_mem_get16(9F)

ddi_mem_get32(9F)

ddi_mem_get64(9F)

ddi_mem_get8(9F)

ddi_mem_getb(9F)

ddi_mem_getl(9F)

ddi_mem_getll(9F)

ddi_mem_getw(9F)

ddi_mem_put16(9F)

ddi_mem_put32(9F)

ddi_mem_put64(9F)

ddi_mem_put8(9F)

ddi_mem_putb(9F)

ddi_mem_putl(9F)

ddi_mem_putll(9F)

ddi_mem_putw(9F)

ddi_mem_rep_get16(9F)

ddi_mem_rep_get32(9F)

ddi_mem_rep_get64(9F)

ddi_mem_rep_get8(9F)

ddi_mem_rep_getb(9F)

ddi_mem_rep_getl(9F)

ddi_mem_rep_getll(9F)

ddi_mem_rep_getw(9F)

ddi_mem_rep_put16(9F)

ddi_mem_rep_put32(9F)

ddi_mem_rep_put64(9F)

ddi_mem_rep_put8(9F)

ddi_mem_rep_putb(9F)

ddi_mem_rep_putl(9F)

ddi_mem_rep_putll(9F)

ddi_mem_rep_putw(9F)

ddi_mmap_get_model(9F)

ddi_modclose(9F)

ddi_model_convert_from(9F)

ddi_modopen(9F)

ddi_modsym(9F)

ddi_node_name(9F)

ddi_no_info(9F)

ddi_peek16(9F)

ddi_peek32(9F)

ddi_peek64(9F)

ddi_peek8(9F)

ddi_peek(9F)

ddi_peekc(9F)

ddi_peekd(9F)

ddi_peekl(9F)

ddi_peeks(9F)

ddi_periodic_add(9F)

ddi_periodic_delete(9F)

ddi_poke16(9F)

ddi_poke32(9F)

ddi_poke64(9F)

ddi_poke8(9F)

ddi_poke(9F)

ddi_pokec(9F)

ddi_poked(9F)

ddi_pokel(9F)

ddi_pokes(9F)

ddi_prop_create(9F)

ddi_prop_exists(9F)

ddi_prop_free(9F)

ddi_prop_get_int64(9F)

ddi_prop_get_int(9F)

ddi_prop_lookup(9F)

ddi_prop_lookup_byte_array(9F)

ddi_prop_lookup_int64_array(9F)

ddi_prop_lookup_int_array(9F)

ddi_prop_lookup_string(9F)

ddi_prop_lookup_string_array(9F)

ddi_prop_modify(9F)

ddi_prop_op(9F)

ddi_prop_remove(9F)

ddi_prop_remove_all(9F)

ddi_prop_undefine(9F)

ddi_prop_update(9F)

ddi_prop_update_byte_array(9F)

ddi_prop_update_int64(9F)

ddi_prop_update_int64_array(9F)

ddi_prop_update_int(9F)

ddi_prop_update_int_array(9F)

ddi_prop_update_string(9F)

ddi_prop_update_string_array(9F)

ddi_ptob(9F)

ddi_put16(9F)

ddi_put32(9F)

ddi_put64(9F)

ddi_put8(9F)

ddi_putb(9F)

ddi_putl(9F)

ddi_putll(9F)

ddi_putw(9F)

ddi_regs_map_free(9F)

ddi_regs_map_setup(9F)

ddi_remove_event_handler(9F)

ddi_remove_intr(9F)

ddi_remove_minor_node(9F)

ddi_remove_softintr(9F)

ddi_removing_power(9F)

ddi_rep_get16(9F)

ddi_rep_get32(9F)

ddi_rep_get64(9F)

ddi_rep_get8(9F)

ddi_rep_getb(9F)

ddi_rep_getl(9F)

ddi_rep_getll(9F)

ddi_rep_getw(9F)

ddi_report_dev(9F)

ddi_rep_put16(9F)

ddi_rep_put32(9F)

ddi_rep_put64(9F)

ddi_rep_put8(9F)

ddi_rep_putb(9F)

ddi_rep_putl(9F)

ddi_rep_putll(9F)

ddi_rep_putw(9F)

ddi_root_node(9F)

ddi_segmap(9F)

ddi_segmap_setup(9F)

ddi_set_driver_private(9F)

ddi_slaveonly(9F)

ddi_soft_state(9F)

ddi_soft_state_fini(9F)

ddi_soft_state_free(9F)

ddi_soft_state_init(9F)

ddi_soft_state_zalloc(9F)

ddi_strdup(9F)

ddi_strtol(9F)

ddi_strtoll(9F)

ddi_strtoul(9F)

ddi_strtoull(9F)

ddi_taskq_create(9F)

ddi_taskq_destroy(9F)

ddi_taskq_dispatch(9F)

ddi_taskq_resume(9F)

ddi_taskq_suspend(9F)

ddi_taskq_wait(9F)

ddi_trigger_softintr(9F)

ddi_umem_alloc(9F)

ddi_umem_free(9F)

ddi_umem_iosetup(9F)

ddi_umem_lock(9F)

ddi_umem_unlock(9F)

ddi_unmap_regs(9F)

delay(9F)

desballoc(9F)

devmap_default_access(9F)

devmap_devmem_setup(9F)

devmap_do_ctxmgt(9F)

devmap_load(9F)

devmap_set_ctx_timeout(9F)

devmap_setup(9F)

devmap_umem_setup(9F)

devmap_unload(9F)

disksort(9F)

dlbindack(9F)

dlerrorack(9F)

dlokack(9F)

dlphysaddrack(9F)

dluderrorind(9F)

drv_getparm(9F)

drv_hztousec(9F)

drv_priv(9F)

drv_usectohz(9F)

drv_usecwait(9F)

dupb(9F)

dupmsg(9F)

enableok(9F)

esballoc(9F)

esbbcall(9F)

flushband(9F)

flushq(9F)

freeb(9F)

freemsg(9F)

free_pktiopb(9F)

freerbuf(9F)

freezestr(9F)

geterror(9F)

gethrtime(9F)

getmajor(9F)

getminor(9F)

get_pktiopb(9F)

getq(9F)

getrbuf(9F)

gld(9F)

gld_intr(9F)

gld_mac_alloc(9F)

gld_mac_free(9F)

gld_recv(9F)

gld_register(9F)

gld_sched(9F)

gld_unregister(9F)

hat_getkpfnum(9F)

hook_alloc(9F)

hook_free(9F)

id32_alloc(9F)

id32_free(9F)

id32_lookup(9F)

inb(9F)

inl(9F)

insq(9F)

inw(9F)

IOC_CONVERT_FROM(9F)

kiconv(9F)

kiconv_close(9F)

kiconv_open(9F)

kiconvstr(9F)

kmem_alloc(9F)

kmem_cache_alloc(9F)

kmem_cache_create(9F)

kmem_cache_destroy(9F)

kmem_cache_free(9F)

kmem_cache_set_move(9F)

kmem_free(9F)

kmem_zalloc(9F)

kstat_create(9F)

kstat_delete(9F)

kstat_install(9F)

kstat_named_init(9F)

kstat_named_setstr(9F)

kstat_queue(9F)

kstat_runq_back_to_waitq(9F)

kstat_runq_enter(9F)

kstat_runq_exit(9F)

kstat_waitq_enter(9F)

kstat_waitq_exit(9F)

kstat_waitq_to_runq(9F)

ldi_add_event_handler(9F)

ldi_aread(9F)

ldi_awrite(9F)

ldi_close(9F)

ldi_devmap(9F)

ldi_dump(9F)

ldi_ev_finalize(9F)

ldi_ev_get_cookie(9F)

ldi_ev_get_type(9F)

ldi_ev_notify(9F)

ldi_ev_register_callbacks(9F)

ldi_ev_remove_callbacks(9F)

ldi_get_blksize(9F)

ldi_get_dev(9F)

ldi_get_devid(9F)

ldi_get_eventcookie(9F)

ldi_get_minor_name(9F)

ldi_getmsg(9F)

ldi_get_otyp(9F)

ldi_get_pblksize(9F)

ldi_get_size(9F)

ldi_ident_from_dev(9F)

ldi_ident_from_dip(9F)

ldi_ident_from_stream(9F)

ldi_ident_release(9F)

ldi_ioctl(9F)

ldi_open_by_dev(9F)

ldi_open_by_devid(9F)

ldi_open_by_name(9F)

ldi_poll(9F)

ldi_prop_exists(9F)

ldi_prop_get_int64(9F)

ldi_prop_get_int(9F)

ldi_prop_lookup_byte_array(9F)

ldi_prop_lookup_int64_array(9F)

ldi_prop_lookup_int_array(9F)

ldi_prop_lookup_string(9F)

ldi_prop_lookup_string_array(9F)

ldi_putmsg(9F)

ldi_read(9F)

ldi_remove_event_handler(9F)

ldi_strategy(9F)

ldi_write(9F)

linkb(9F)

list_create(9F)

list_destroy(9F)

LIST_EMPTY(9F)

LIST_ENTRY(9F)

LIST_FIRST(9F)

LIST_FOREACH(9F)

LIST_HEAD(9F)

list_head(9F)

LIST_HEAD_INITIALIZER(9F)

LIST_INIT(9F)

LIST_INSERT_AFTER(9F)

list_insert_after(9F)

LIST_INSERT_BEFORE(9F)

list_insert_before(9F)

LIST_INSERT_HEAD(9F)

list_insert_head(9F)

list_insert_tail(9F)

list_is_empty(9F)

list_link_active(9F)

list_link_init(9F)

list_link_replace(9F)

list_move_tail(9F)

LIST_NEXT(9F)

list_next(9F)

list_prev(9F)

LIST_REMOVE(9F)

list_remove(9F)

list_remove_head(9F)

list_remove_tail(9F)

list_tail(9F)

mac(9F)

mac_alloc(9F)

mac_fini_ops(9F)

mac_free(9F)

mac_hcksum_get(9F)

mac_hcksum_set(9F)

mac_init_ops(9F)

mac_link_update(9F)

mac_lso_get(9F)

mac_prop_info_set_default_link_flowctrl(9F)

mac_prop_info_set_default_str(9F)

mac_prop_info_set_default_uint8(9F)

mac_prop_info_set_perm(9F)

mac_prop_info_set_range_uint32(9F)

mac_register(9F)

mac_rx(9F)

mac_tx_update(9F)

mac_unregister(9F)

makecom(9F)

makecom_g0(9F)

makecom_g0_s(9F)

makecom_g1(9F)

makecom_g5(9F)

makedevice(9F)

max(9F)

MBLKHEAD(9F)

MBLKIN(9F)

MBLKL(9F)

MBLKSIZE(9F)

MBLKTAIL(9F)

mcopyin(9F)

mcopymsg(9F)

mcopyout(9F)

membar_consumer(9F)

membar_enter(9F)

membar_exit(9F)

membar_ops(9F)

membar_producer(9F)

memchr(9F)

memcmp(9F)

memcpy(9F)

memmove(9F)

memset(9F)

merror(9F)

mexchange(9F)

min(9F)

minphys(9F)

mioc2ack(9F)

miocack(9F)

miocnak(9F)

miocpullup(9F)

mkiocb(9F)

mod_info(9F)

mod_install(9F)

mod_modname(9F)

mod_remove(9F)

msgdsize(9F)

msgpullup(9F)

msgsize(9F)

mt-streams(9F)

mutex(9F)

mutex_destroy(9F)

mutex_enter(9F)

mutex_exit(9F)

mutex_init(9F)

mutex_owned(9F)

mutex_tryenter(9F)

net_event_notify_register(9F)

net_event_notify_unregister(9F)

net_getifname(9F)

net_getlifaddr(9F)

net_getmtu(9F)

net_getnetid(9F)

net_getpmtuenabled(9F)

net_hook_register(9F)

net_hook_unregister(9F)

netinfo(9F)

net_inject(9F)

net_inject_alloc(9F)

net_inject_free(9F)

net_instance_alloc(9F)

net_instance_free(9F)

net_instance_notify_register(9F)

net_instance_notify_unregister(9F)

net_instance_protocol_unregister(9F)

net_instance_register(9F)

net_instance_unregister(9F)

net_ispartialchecksum(9F)

net_isvalidchecksum(9F)

net_kstat_create(9F)

net_kstat_delete(9F)

net_lifgetnext(9F)

net_netidtozonid(9F)

net_phygetnext(9F)

net_phylookup(9F)

net_protocol_lookup(9F)

net_protocol_notify_register(9F)

net_protocol_release(9F)

net_protocol_walk(9F)

net_routeto(9F)

net_zoneidtonetid(9F)

nochpoll(9F)

nodev(9F)

noenable(9F)

nulldev(9F)

numtos(9F)

nv_alloc_fini(9F)

nv_alloc_init(9F)

nvlist_add_boolean(9F)

nvlist_add_boolean_array(9F)

nvlist_add_boolean_value(9F)

nvlist_add_byte(9F)

nvlist_add_byte_array(9F)

nvlist_add_int16(9F)

nvlist_add_int16_array(9F)

nvlist_add_int32(9F)

nvlist_add_int32_array(9F)

nvlist_add_int64(9F)

nvlist_add_int64_array(9F)

nvlist_add_int8(9F)

nvlist_add_int8_array(9F)

nvlist_add_nvlist(9F)

nvlist_add_nvlist_array(9F)

nvlist_add_nvpair(9F)

nvlist_add_string(9F)

nvlist_add_string_array(9F)

nvlist_add_uint16(9F)

nvlist_add_uint16_array(9F)

nvlist_add_uint32(9F)

nvlist_add_uint32_array(9F)

nvlist_add_uint64(9F)

nvlist_add_uint64_array(9F)

nvlist_add_uint8(9F)

nvlist_add_uint8_array(9F)

nvlist_alloc(9F)

nvlist_dup(9F)

nvlist_exists(9F)

nvlist_free(9F)

nvlist_lookup_boolean(9F)

nvlist_lookup_boolean_array(9F)

nvlist_lookup_boolean_value(9F)

nvlist_lookup_byte(9F)

nvlist_lookup_byte_array(9F)

nvlist_lookup_int16(9F)

nvlist_lookup_int16_array(9F)

nvlist_lookup_int32(9F)

nvlist_lookup_int32_array(9F)

nvlist_lookup_int64(9F)

nvlist_lookup_int64_array(9F)

nvlist_lookup_int8(9F)

nvlist_lookup_int8_array(9F)

nvlist_lookup_nvlist(9F)

nvlist_lookup_nvlist_array(9F)

nvlist_lookup_nvpair(9F)

nvlist_lookup_pairs(9F)

nvlist_lookup_string(9F)

nvlist_lookup_string_array(9F)

nvlist_lookup_uint16(9F)

nvlist_lookup_uint16_array(9F)

nvlist_lookup_uint32(9F)

nvlist_lookup_uint32_array(9F)

nvlist_lookup_uint64(9F)

nvlist_lookup_uint64_array(9F)

nvlist_lookup_uint8(9F)

nvlist_lookup_uint8_array(9F)

nvlist_merge(9F)

nvlist_next_nvpair(9F)

nvlist_pack(9F)

nvlist_remove(9F)

nvlist_remove_all(9F)

nvlist_size(9F)

nvlist_t(9F)

nvlist_unpack(9F)

nvlist_xalloc(9F)

nvlist_xdup(9F)

nvlist_xpack(9F)

nvlist_xunpack(9F)

nvpair_name(9F)

nvpair_type(9F)

nvpair_value_boolean_array(9F)

nvpair_value_byte(9F)

nvpair_value_byte_array(9F)

nvpair_value_int16(9F)

nvpair_value_int16_array(9F)

nvpair_value_int32(9F)

nvpair_value_int32_array(9F)

nvpair_value_int64(9F)

nvpair_value_int64_array(9F)

nvpair_value_int8(9F)

nvpair_value_int8_array(9F)

nvpair_value_nvlist(9F)

nvpair_value_nvlist_array(9F)

nvpair_value_string(9F)

nvpair_value_string_array(9F)

nvpair_value_uint16(9F)

nvpair_value_uint16_array(9F)

nvpair_value_uint32(9F)

nvpair_value_uint32_array(9F)

nvpair_value_uint64(9F)

nvpair_value_uint64_array(9F)

nvpair_value_uint8(9F)

nvpair_value_uint8_array(9F)

OTHERQ(9F)

otherq(9F)

outb(9F)

outl(9F)

outw(9F)

packet_events(9F)

pci_config_get16(9F)

pci_config_get32(9F)

pci_config_get64(9F)

pci_config_get8(9F)

pci_config_getb(9F)

pci_config_getl(9F)

pci_config_getll(9F)

pci_config_getw(9F)

pci_config_put16(9F)

pci_config_put32(9F)

pci_config_put64(9F)

pci_config_put8(9F)

pci_config_putb(9F)

pci_config_putl(9F)

pci_config_putll(9F)

pci_config_putw(9F)

pci_config_setup(9F)

pci_config_teardown(9F)

pci_ereport_post(9F)

pci_ereport_setup(9F)

pci_ereport_teardown(9F)

pci_param_free(9F)

pci_param_get(9F)

pci_param_get_ioctl(9F)

pci_plist_get(9F)

pci_plist_getvf(9F)

pci_plist_lookup(9F)

pci_plist_lookup_int16(9F)

pci_plist_lookup_int16_array(9F)

pci_plist_lookup_int32(9F)

pci_plist_lookup_int32_array(9F)

pci_plist_lookup_int64(9F)

pci_plist_lookup_int64_array(9F)

pci_plist_lookup_int8(9F)

pci_plist_lookup_int8_array(9F)

pci_plist_lookup_plist(9F)

pci_plist_lookup_string(9F)

pci_plist_lookup_string_array(9F)

pci_plist_lookup_uint16(9F)

pci_plist_lookup_uint16_array(9F)

pci_plist_lookup_uint32(9F)

pci_plist_lookup_uint32_array(9F)

pci_plist_lookup_uint64(9F)

pci_plist_lookup_uint64_array(9F)

pci_plist_lookup_uint8(9F)

pci_plist_lookup_uint8_array(9F)

pci_report_pmcap(9F)

pci_restore_config_regs(9F)

pci_save_config_regs(9F)

pciv_send(9F)

pciv_vf_config(9F)

physio(9F)

pm_busy_component(9F)

pm_idle_component(9F)

pm_lower_power(9F)

pm_power_has_changed(9F)

pm_raise_power(9F)

pm_trans_check(9F)

pollwakeup(9F)

priv_getbyname(9F)

priv_policy(9F)

priv_policy_choice(9F)

priv_policy_only(9F)

proc_ref(9F)

proc_signal(9F)

proc_unref(9F)

ptob(9F)

pullupmsg(9F)

put(9F)

putbq(9F)

putctl1(9F)

putctl(9F)

putnext(9F)

putnextctl1(9F)

putnextctl(9F)

putq(9F)

qassociate(9F)

qbufcall(9F)

qenable(9F)

qprocsoff(9F)

qprocson(9F)

qreply(9F)

qsize(9F)

qtimeout(9F)

queue(9F)

qunbufcall(9F)

quntimeout(9F)

qwait(9F)

qwait_sig(9F)

qwriter(9F)

RB_EMPTY(9F)

RB_ENTRY(9F)

RB_FIND(9F)

RB_FOREACH(9F)

RB_FOREACH_REVERSE(9F)

RB_FOREACH_REVERSE_SAFE(9F)

RB_FOREACH_SAFE(9F)

RB_GENERATE(9F)

RB_GENERATE_STATIC(9F)

RB_HEAD(9F)

RB_INIT(9F)

RB_INITIALIZER(9F)

RB_INSERT(9F)

RB_LEFT(9F)

RB_MAX(9F)

RB_MIN(9F)

RB_NEXT(9F)

RB_NFIND(9F)

RB_PARENT(9F)

RB_PREV(9F)

RB_PROTOTYPE(9F)

RB_PROTOTYPE_STATIC(9F)

RB_REMOVE(9F)

RB_RIGHT(9F)

RB_ROOT(9F)

RD(9F)

rd(9F)

repinsb(9F)

repinsd(9F)

repinsw(9F)

repoutsb(9F)

repoutsd(9F)

repoutsw(9F)

rmalloc(9F)

rmallocmap(9F)

rmallocmap_wait(9F)

rmalloc_wait(9F)

rmfree(9F)

rmfreemap(9F)

rmvb(9F)

rmvq(9F)

rw_destroy(9F)

rw_downgrade(9F)

rw_enter(9F)

rw_exit(9F)

rw_init(9F)

rwlock(9F)

rw_read_locked(9F)

rw_tryenter(9F)

rw_tryupgrade(9F)

SAMESTR(9F)

samestr(9F)

scsi_abort(9F)

scsi_alloc_consistent_buf(9F)

scsi_cname(9F)

scsi_destroy_pkt(9F)

scsi_dmafree(9F)

scsi_dmaget(9F)

scsi_dname(9F)

scsi_errmsg(9F)

scsi_ext_sense_fields(9F)

scsi_find_sense_descr(9F)

scsi_free_consistent_buf(9F)

scsi_get_device_type_scsi_options(9F)

scsi_get_device_type_string(9F)

scsi_hba_attach(9F)

scsi_hba_attach_setup(9F)

scsi_hba_detach(9F)

scsi_hba_fini(9F)

scsi_hba_init(9F)

scsi_hba_lookup_capstr(9F)

scsi_hba_pkt_alloc(9F)

scsi_hba_pkt_comp(9F)

scsi_hba_pkt_free(9F)

scsi_hba_probe(9F)

scsi_hba_tran_alloc(9F)

scsi_hba_tran_free(9F)

scsi_ifgetcap(9F)

scsi_ifsetcap(9F)

scsi_init_pkt(9F)

scsi_log(9F)

scsi_mname(9F)

scsi_pktalloc(9F)

scsi_pktfree(9F)

scsi_poll(9F)

scsi_probe(9F)

scsi_resalloc(9F)

scsi_reset(9F)

scsi_reset_notify(9F)

scsi_resfree(9F)

scsi_rname(9F)

scsi_sense_asc(9F)

scsi_sense_ascq(9F)

scsi_sense_cmdspecific_uint64(9F)

scsi_sense_info_uint64(9F)

scsi_sense_key(9F)

scsi_setup_cdb(9F)

scsi_slave(9F)

scsi_sname(9F)

scsi_sync_pkt(9F)

scsi_transport(9F)

scsi_unprobe(9F)

scsi_unslave(9F)

scsi_validate_sense(9F)

scsi_vu_errmsg(9F)

sema_destroy(9F)

sema_init(9F)

sema_p(9F)

semaphore(9F)

sema_p_sig(9F)

sema_tryp(9F)

sema_v(9F)

SIMPLEQ_EMPTY(9F)

SIMPLEQ_ENTRY(9F)

SIMPLEQ_FIRST(9F)

SIMPLEQ_FOREACH(9F)

SIMPLEQ_HEAD(9F)

SIMPLEQ_HEAD_INITIALIZER(9F)

SIMPLEQ_INIT(9F)

SIMPLEQ_INSERT_AFTER(9F)

SIMPLEQ_INSERT_HEAD(9F)

SIMPLEQ_INSERT_TAIL(9F)

SIMPLEQ_NEXT(9F)

SIMPLEQ_REMOVE(9F)

SIMPLEQ_REMOVE_HEAD(9F)

SIZEOF_PTR(9F)

SIZEOF_STRUCT(9F)

SLIST_EMPTY(9F)

SLIST_ENTRY(9F)

SLIST_FIRST(9F)

SLIST_FOREACH(9F)

SLIST_HEAD(9F)

SLIST_HEAD_INITIALIZER(9F)

SLIST_INIT(9F)

SLIST_INSERT_AFTER(9F)

SLIST_INSERT_HEAD(9F)

SLIST_NEXT(9F)

SLIST_REMOVE(9F)

SLIST_REMOVE_HEAD(9F)

snprintf(9F)

sof_bypass(9F)

sof_flowctrl_data_in(9F)

sof_flowctrl_data_out(9F)

sof_inject_data_in(9F)

sof_inject_data_out(9F)

sof_mblk_create(9F)

sof_mblk_msghdr(9F)

sof_newconn_close(9F)

sof_newconn_ready(9F)

sof_register(9F)

sof_unregister(9F)

SPLAY_EMPTY(9F)

SPLAY_ENTRY(9F)

SPLAY_FIND(9F)

SPLAY_FOREACH(9F)

SPLAY_GENERATE(9F)

SPLAY_HEAD(9F)

SPLAY_INIT(9F)

SPLAY_INITIALIZER(9F)

SPLAY_INSERT(9F)

SPLAY_LEFT(9F)

SPLAY_MAX(9F)

SPLAY_MIN(9F)

SPLAY_NEXT(9F)

SPLAY_PROTOTYPE(9F)

SPLAY_REMOVE(9F)

SPLAY_RIGHT(9F)

SPLAY_ROOT(9F)

sprintf(9F)

STAILQ_CONCAT(9F)

STAILQ_EMPTY(9F)

STAILQ_ENTRY(9F)

STAILQ_FIRST(9F)

STAILQ_FOREACH(9F)

STAILQ_HEAD(9F)

STAILQ_HEAD_INITIALIZER(9F)

STAILQ_INIT(9F)

STAILQ_INSERT_AFTER(9F)

STAILQ_INSERT_HEAD(9F)

STAILQ_INSERT_TAIL(9F)

STAILQ_NEXT(9F)

STAILQ_REMOVE(9F)

STAILQ_REMOVE_HEAD(9F)

stoi(9F)

strcasecmp(9F)

strcasestr(9F)

strchr(9F)

strcmp(9F)

strcpy(9F)

strdup(9F)

strfree(9F)

string(9F)

strlcat(9F)

strlcpy(9F)

strlen(9F)

strlog(9F)

strncasecmp(9F)

strncat(9F)

strncmp(9F)

strncpy(9F)

strnlen(9F)

strqget(9F)

strqset(9F)

strrchr(9F)

strspn(9F)

strstr(9F)

STRUCT_BUF(9F)

STRUCT_DECL(9F)

STRUCT_FADDR(9F)

STRUCT_FGET(9F)

STRUCT_FGETP(9F)

STRUCT_FSET(9F)

STRUCT_FSETP(9F)

STRUCT_HANDLE(9F)

STRUCT_INIT(9F)

STRUCT_SET_HANDLE(9F)

STRUCT_SIZE(9F)

swab(9F)

TAILQ_CONCAT(9F)

TAILQ_EMPTY(9F)

TAILQ_ENTRY(9F)

TAILQ_FIRST(9F)

TAILQ_FOREACH(9F)

TAILQ_FOREACH_REVERSE(9F)

TAILQ_HEAD(9F)

TAILQ_HEAD_INITIALIZER(9F)

TAILQ_INIT(9F)

TAILQ_INSERT_AFTER(9F)

TAILQ_INSERT_BEFORE(9F)

TAILQ_INSERT_HEAD(9F)

TAILQ_INSERT_TAIL(9F)

TAILQ_LAST(9F)

TAILQ_NEXT(9F)

TAILQ_PREV(9F)

TAILQ_REMOVE(9F)

taskq(9F)

taskq_suspended(9F)

testb(9F)

timeout(9F)

tree(9F)

u8_strcmp(9F)

u8_textprep_str(9F)

u8_validate(9F)

uconv_u16tou32(9F)

uconv_u16tou8(9F)

uconv_u32tou16(9F)

uconv_u32tou8(9F)

uconv_u8tou16(9F)

uconv_u8tou32(9F)

uiomove(9F)

unbufcall(9F)

unfreezestr(9F)

unlinkb(9F)

untimeout(9F)

ureadc(9F)

usb_alloc_bulk_req(9F)

usb_alloc_ctrl_req(9F)

usb_alloc_intr_req(9F)

usb_alloc_isoc_req(9F)

usb_alloc_request(9F)

usb_client_attach(9F)

usb_client_detach(9F)

usb_clr_feature(9F)

usb_create_pm_components(9F)

usb_free_bulk_req(9F)

usb_free_ctrl_req(9F)

usb_free_descr_tree(9F)

usb_free_dev_data(9F)

usb_free_intr_req(9F)

usb_free_isoc_req(9F)

usb_get_addr(9F)

usb_get_alt_if(9F)

usb_get_cfg(9F)

usb_get_current_frame_number(9F)

usb_get_dev_data(9F)

usb_get_if_number(9F)

usb_get_max_pkts_per_isoc_request(9F)

usb_get_status(9F)

usb_get_string_descr(9F)

usb_handle_remote_wakeup(9F)

usb_lookup_ep_data(9F)

usb_owns_device(9F)

usb_parse_data(9F)

usb_pipe_bulk_xfer(9F)

usb_pipe_close(9F)

usb_pipe_ctrl_xfer(9F)

usb_pipe_ctrl_xfer_wait(9F)

usb_pipe_drain_reqs(9F)

usb_pipe_get_max_bulk_transfer_size(9F)

usb_pipe_get_private(9F)

usb_pipe_get_state(9F)

usb_pipe_intr_xfer(9F)

usb_pipe_isoc_xfer(9F)

usb_pipe_open(9F)

usb_pipe_reset(9F)

usb_pipe_set_private(9F)

usb_pipe_stop_intr_polling(9F)

usb_pipe_stop_isoc_polling(9F)

usb_print_descr_tree(9F)

usb_register_hotplug_cbs(9F)

usb_reset_device(9F)

usb_set_alt_if(9F)

usb_set_cfg(9F)

usb_unregister_hotplug_cbs(9F)

uwritec(9F)

va_arg(9F)

va_copy(9F)

va_end(9F)

va_start(9F)

vcmn_err(9F)

vsprintf(9F)

WR(9F)

wr(9F)

zcmn_err(9F)

ddi_cb_register

, ddi_cb_unregister

- register and unregister a device driver callback handler

Synopsis

#include <sys/sunddi.h> 

int ddi_cb_register(dev_info_t *dip, ddi_cb_flags_t flags,
      ddi_cb_func_t cbfunc, void *arg1, void *arg2,
      ddi_cb_handle_t * ret_hdlp);
int ddi_cb_unregister(ddi_cb_handle_t hdl);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

ddi_cb_register()

dip

Pointer to the dev_info structure.

flags

Flags to determine which callback events can be handled.

cbfunc

Callback handler function.

arg1

First argument to the callback handler.

arg2

Second (optional) argument to the callback handler.

ret_hdlp

Pointer to return a handle to the registered callback.

ddi_cb_unregister()

hdl

Handle to the registered callback handler that is to be unregistered.

Description

The ddi_cb_register() function installs a callback handler which processes various actions that require the driver's attention while it is attached. The driver specifies which callback actions it can handle through the flags parameter. With each relevant action, the specified callback function passes the arg1 and arg2 arguments along with the description of each callback event to the driver.

The ddi_cb_unregister() function removes a previously installed callback handler and prevents future processing of actions.

The flags parameter consists of the following:

DDI_CB_FLAG_INTR

The device driver participates in interrupt resource management. The device driver may receive additional interrupt resources from the system, but only because it can accept callback notices informing it when it has more or less resources available. Callback notices can occur at anytime after the driver is attached. Interrupt availability varies based on the overall needs of the system.

DDI_CB_FLAG_SRIOV

Indicates to the DDI framework that the device driver is IOV capable. Normally IOV device drivers are expected to call pciv_vf_config(9F)) to configure the VFs during attach and register callbacks with this flag set so that they can be informed through callback notices when VFs are unconfigured by the DDI framework.

If the driver does not explicitly configure the VFs using pciv_vf_config() during attach then the PCIE framework will configure the VFs as part of the post-attach processing if this flag is set.

The callback notices while configuring/unconfiguring is performed with two separate callbacks to the driver PRE and POST. This helps the drivers to prepare for the event during PRE and do the necessary initializations/cleanup during POST notices.

DDI_CB_FLAG_COMM

The device driver uses pciv_send(9F) interfaces to communicate across different domains or within the same domain. The driver may receive callback notices that incoming data has been received.

DDI_CB_FLAG_LSR

The device driver supports Live Suspend and Resume (LSR) operations. When LSR operation (Live Suspend or Live Resume) happens, the device driver will be asked to suspend/resume various I/O activities of the device. The LSR operations may also impose various impacts (such as device reset, losing power, etc.) to the device, the driver needs to handle these impacts too. For more information about the activities and impacts, refer to the data type ddi_cb_lsr_t described below. Callback can occur at anytime after the driver is attached. Currently, LSR is only supported for PCI and PCIe devices.

The cdfunc is a callback handler with the following prototype:

typedef int (*ddi_cb_func_t)(dev_info_t *dip, 
              ddi_cb_action_t action, void *cbarg, 
              void *arg1, void *arg2);

The cbfunc routine with the arguments dip, action, cbarg, arg1 and arg2 is called upon receipt of any callbacks for which the driver is registered. The callback handler returns DDI_SUCCESS if the callback was handled successfully, DDI_ENOTSUP if it received a callback action that it did not know how to process, or DDI_FAILURE if it has an internal failure while processing an action.

For interrupt resource management, the action parameter can be one of the following:

DDI_CB_INTR_ADD

For interrupt resource management, the driver has more available interrupts. The driver can allocate more interrupt vectors and then set up more interrupt handling functions by using ddi_intr_alloc(9F).

DDI_CB_INTR_REMOVE

For interrupt resource management, the driver has fewer available interrupts. The driver must release any previously allocated interrupts in excess of what is now available by using ddi_intr_free(9F).

The cbarg parameter points to an action-specific argument. Each class of registered actions specifies its own data structure that a callback handler should dereference when it receives those actions.

The cbarg parameter is defined as an integer in the case of DDI_CB_INTR_ADD and DDI_CB_INTR_REMOVE actions. The callback handler should cast the cbarg parameter to an integer. The integer represents how many interrupts have been added or removed from the total number available to the device driver.

If a driver participates in interrupt resource management, it must register a callback with the DDI_CB_FLAG_INTR flag. The driver then receives the actions DDI_CB_INTR_ADD and DDI_CB_INTR_REMOVE whenever its interrupt availability has changed. The callback handler should use the interrupt functions ddi_intr_alloc(9F) and ddi_intr_free(9F) functions to respond accordingly. A driver is not required to allocate all interrupts that are available to it, but it is required to manage its allocations so that it never uses more interrupts than are currently available.

DDI_CB_PCIV_CONFIG_VF

The PF driver is being notified of its VF configuration request. The pciv_config_vf_t structure is being passed as cbarg to describe the configuration. The cmd field in pciv_config_vf_t indicates if the VFs are about to or have just been enabled or disabled.

cbarg (when action is set to DDI_CB_PCIV_CONFIG_VF)
   pciv_config_vf_t

typedef enum {
   PCIV_VFCFG_PARAM,       /* Retrieve VF configuration parameters */
   PCIV_VF_ENABLE,         /* Request to enable VFs synchronously */
   PCIV_VF_DISABLE,        /* Request to disable VFs synchronously */
   PCIV_EVT_VFENABLE_PRE,  /* VFs are just about to be enabled */
   PCIV_EVT_VFENABLE_POST, /* VFs have just been enabled */
   PCIV_EVT_VFDISABLE_PRE, /* VFs are just about to be disabled */
   PCIV_EVT_VFDISABLE_POST /* VFs have just been disabled */
} pciv_vf_config_cmd_t;

typedef struct pciv_config_vf {
   int                     version;
   pciv_vf_config_cmd_t    cmd; /* pre/post VF enable/disable */
   uint16_t                num_vf; /* number of VFs to be used */
   uint16_t                first_vf_offset; /* offset between 1st VF & PF */
   uint16_t                vf_stride; /* distance between VFs */
   boolean_t               ari_cap; /* ARI capable hierarchy */
   uint32_t                page_size; /* system page size */
} pciv_config_vf_t;

The cmd field in the pciv_config_vf_t informs the driver the reason for the callback execution. The driver can return one of the following codes back to the caller.

DDI_SUCCESS

The request was accepted and resources are properly configured.

DDI_NOTAPPLICABLE

The requested configuration is not applicable.

DDI_REQRESET

The requested configuration cannot be applied until device is reset (for (example, the PF hardware cannot dynamically adjust its internal resources to satisfy the request.)

DDI_REQREATTACH

The requested configuration cannot be applied unless the driver itself is reattached.

DDI_CB_COMM_RECV

Drivers are notified of incoming data described by pciv_recv_event_t, which is passed as the cbarg argument to the callback handler.

cbarg (when action is set to DDI_CB_COMM_RECV)
   pciv_recv_event_t

typedef enum {
   PCIV_EVT_READY = 0x1,   /* peer side has registered the recv cb */
   PCIV_EVT_NOT_READY,     /* peer side has unregistered the recv cb */
   PCIV_EVT_DRV_DATA,      /* private driver data event */
   PCIV_EVT_FABRIC         /* PCIv framework and fabric admin event */
} pciv_event_type_t;

typedef struct pciv_recv_event {
   pciv_event_type_t event;          /* event type */
   caddr_t           buf;            /* buffer address */
   size_t            nbyte;          /* size of buffer */
   uint32_t          src_func;       /* source function */
   dom_id_t          src_domain;     /* source domain */
} pciv_recv_event_t;
PCIV_EVT_READY

Both local and remote end has registered its event handler. The buf and nbyte fields should be ignored

PCIV_EVT_NOT_READY

Remote end has not registered its event handler. The buf and nbyte fields should be ignored

PCIV_EVT_DRV_DATA

Data in buf with nbyte size has been received or sent. Data can only be interpreted by the transmitter and receiver.

PCIV_EVT_FABRIC

Framework VF administration event, used between framework and PF drivers for VF administration purposes. Administration data is stored in buf with nbyte size.

buf, nbyte

Incoming data is stored in a buffer of address buf with length of nbyte. Not used for certain event types.

src_func

The source function number of the transmission. It is used by the PF driver to identify the transmission source virtual function number. Besides source VF number, it can also be:

PCIV_PF

Transmitter is the PF of the receiver.

PCIV_FRM

Transmitter is the PCI Express framework rather than a driver.

src_domain

The source domain of the transmission. It is used by PF driver to identify the domain the transmission is from.

For Live Suspend & Resume, the action parameter can be one of the following:

DDI_CB_LSR_SUSPEND

Live suspend the device. The detailed I/O activities that will be suspended and impacts that the operation will impose to the device are specified by the argument pointed to by cbarg. It is of type ddi_cb_lsr_t.

DDI_CB_LSR_RESUME

Live resume the device. The detailed activities and impacts are specified in the argument pointed to by cbarg. It will be the same as the previous suspend operation.

DDI_CB_LSR_QUERY_CAPABILITY

Query the device's LSR capabilities. The detailed activities and impacts that the device driver supports are returned in the argument pointed to by cbarg. The type of the argument is ddi_cb_lsr_t.

For all the LSR actions, the cbarg parameter points to the argument of the same type, ddi_cb_lsr_t, which is defined as:

typedef struct ddi_cb_lsr {
    uint64_t    activities;
    uint64_t    impacts;
    char        *reason;
} ddi_cb_lsr_t;

The activities member specifies what I/O activities of the device will be live suspended/resumed (DDI_CB_LSR_SUSPEND and DDI_CB_LSR_RESUME), or the I/O activities that the device driver supports (DDI_CB_LSR_QUERY_CAPABILITY).

For PCI/PCIe devices, the activities member in ddi_cb_lsr_t can be a value bit-ORed from the following:

DDI_CB_LSR_ACT_DMA

DMA activities

DDI_CB_LSR_ACT_PIO

Programmed I/O activities

DDI_CB_LSR_ACT_INTR

Interrupt activities

The impacts member specifies the side effects the LSR operation will impose on the device. For PCI/PCIe devices, it can be bit-ORed value of the following:

DDI_CB_LSR_IMP_DMA_ADDR_CHANGE

During the LSR operation, the device will undergo DMA address changes. The device driver should unbind and rebind the DMA buffers.

DDI_CB_LSR_IMP_DMA_PROP_CHANGE

During the LSR operation, the platform hardware changes may cause the driver's DMA transaction properties to be invalid, such as the lowest and highest DMA address range, DMA address alignment, DMA segment boundary, etc. The driver needs to destroy and reallocate DMA handles.

DDI_CB_LSR_IMP_DEVICE_RESET

During the LSR operation, the device will undergo device reset. The device driver must restore the hardware context during live resume.

DDI_CB_LSR_IMP_DEVICE_REPLACE

During the LSR operation, the device will be replaced. The device driver needs to check the device identity.

DDI_CB_LSR_IMP_LOSE_POWER

During the LSR operation, the device will lose power. The device driver needs to restore device hardware context during live resume. If necessary, the driver should reload firmware.

The reason member is a predefined string to specify the cause of the LSR operation. It is used for printing purposes. There is no predefined string and it may be NULL for DDI_CB_LSR_SUSPEND and DDI_CB_LSR_RESUME. For DDI_CB_LSR_QUERY_CAPABILITY, the driver must set it to NULL.

The driver's implementation should make the LSR operation transparent to user applications, such that when the driver is suspended, it can block user I/O requests (read/write/ioctl) but should not return failure.

The driver may have grouped activities, such as when one is suspended, the other has to be suspended as well. When the driver is asked to suspend one of the grouped activities, it can choose to suspend all the activities in the group.

The driver's callback function will only be asked to suspend after the former suspension has already been resumed.

The callback function should return as soon as possible. In normal cases, returning in milliseconds should be acceptable while returning in seconds is not.

Return Values

The ddi_cb_register() and ddi_cb_unregister() functions return:

DDI_SUCCESS

on success

DDI_EINVAL

An invalid parameter was given when registering a callback handler, or an invalid handle was given when unregistering.

DDI_EALREADY

An attempt was made to register a callback handler while a previous registration still exists.

The cbfunc routine must return:

DDI_SUCCESS

on success

DDI_ENOTSUP

The device does not support the operation

DDI_FAILURE

Implementation specific failure

Context

These functions can be called from kernel, non-interrupt context.

Examples

Example 1 An example using ddi_cb_register().

/*
    * attach(9F) routine.
    *
    * Creates soft state, registers callback handler, initializes
    * hardware, and sets up interrupt handling for the driver.
    */
    xx_attach(dev_info_t *dip, ddi_attach_cmd_t cmd)
    {
        xx_state_t              *statep = NULL;
        xx_intr_t               *intrs = NULL;
        ddi_intr_handle_t       *hdls;
        ddi_cb_handle_t         cb_hdl;
        int                     instance;
        int                     type;
        int                     types;
        int                     nintrs;
        int                     nactual;
        int                     inum;

        /* Get device instance */
        instance = ddi_get_instance(dip);

        switch (cmd) {
        case DDI_ATTACH:

             /* Get soft state */
             if (ddi_soft_state_zalloc(state_list, instance) != 0)
                     return (DDI_FAILURE);
             statep = ddi_get_soft_state(state_list, instance);
             ddi_set_driver_private(dip, (caddr_t)statep);
             statep->dip = dip;

             /* Initialize hardware */
             xx_initialize(statep);

             /* Allocate/bind dma handle, etc. */
             xx_dma_attach(statep);

             /* Initialize Programmed I/O, map register memory, etc. */
             xx_pio_attach(statep);

             /* Initialize LSR state */
             statep->lsr_state = 0;

             /* Register callback handler */
             if (ddi_cb_register(dip, DDI_CB_FLAG_INTR | DDI_CB_FLAG_LSR,
                 xx_cbfunc, statep, NULL, &cb_hdl) != 0) {
                     ddi_soft_state_free(state_list, instance);
                     return (DDI_FAILURE);
             }
             statep->cb_hdl = cb_hdl;

             /* Select interrupt type */
             ddi_intr_get_supported_types(dip, &types);
             if (types & DDI_INTR_TYPE_MSIX) {
                     type = DDI_INTR_TYPE_MSIX;
             } else if (types & DDI_INTR_TYPE_MSI) {
                     type = DDI_INTR_TYPE_MSI;
             } else {
                     type = DDI_INTR_TYPE_FIXED;
             }
             statep->type = type;

             /* Get number of supported interrupts */

             ddi_intr_get_nintrs(dip, type, &nintrs);

             /* Allocate interrupt handle array */
             statep->hdls_size = nintrs * sizeof (ddi_intr_handle_t);
             hdls = kmem_zalloc(statep->hdls_size, KMEM_SLEEP);

             /* Allocate interrupt setup array */
             statep->intrs_size = nintrs * sizeof (xx_intr_t);
             statep->intrs = kmem_zalloc(statep->intrs_size, KMEM_SLEEP);

             /* Allocate interrupt vectors */
             ddi_intr_alloc(dip, hdls, type, 0, nintrs, &nactual, 0);
             statep->nactual = nactual;

             /* Configure interrupt handling */
             xx_setup_interrupts(statep, nactual, statep->intrs);

             /* Install and enable interrupt handlers */
             for (inum = 0; inum < nactual; inum++) {
                     ddi_intr_add_handler(&statep->hdls[inum],
                         statep->intrs[inum].inthandler,
                         statep->intrs[inum].arg1,
                         statep->intrs[inum].arg2);
                     ddi_intr_enable(statep->hdls[inum]);
             }

             break;

        case DDI_RESUME:

                /* Get soft state */
                statep = ddi_get_soft_state(state_list, instance);
                if (statep == NULL)
                        return (DDI_FAILURE);

                /* Resume hardware */
                xx_resume(statep);

                break;
        }

        return (DDI_SUCESS);
    }

    /*
     * detach(9F) routine.
     *
     * Stops the hardware, disables interrupt handling, unregisters
     * a callback handler, and destroys the soft state for the driver.
     */
    xx_detach(dev_info_t *dip, ddi_detach_cmd_t cmd)
    {
        xx_state_t      *statep = NULL;
        int             instance;
        int             inum;


        /* Get device instance */
        instance = ddi_get_instance(dip);

        switch (cmd) {
        case DDI_DETACH:

                /* Get soft state */
                statep = ddi_get_soft_state(state_list, instance);
                if (statep == NULL)
                        return (DDI_FAILURE);

                /* Stop device */
                xx_uninitialize(statep);

                /* Disable and free interrupts */
                for (inum = 0; inum < statep->nactual; inum++) {
                        ddi_intr_disable(statep->hdls[inum]);
                        ddi_intr_remove_handler(statep->hdls[inum]);
                        ddi_intr_free(statep->hdls[inum]);
                }

                /* Clean up DMA, unbind/free dma handle etc. */
                xx_teardown_dma(statep);

                /* Clean up PIO, unmap register memory etc. */
                xx_teardown_pio(statep);

                /* Unregister callback handler */
                ddi_cb_unregister(statep->cb_hdl);

                /* Free interrupt handle array */
                kmem_free(statep->hdls, statep->hdls_size);

                /* Free interrupt setup array */
                kmem_free(statep->intrs, statep->intrs_size);

                /* Free soft state */
                ddi_soft_state_free(state_list, instance);

                break;

        case DDI_SUSPEND:

                /* Get soft state */
                statep = ddi_get_soft_state(state_list, instance);
                if (statep == NULL)
                        return (DDI_FAILURE);

                /* Suspend hardware */
                xx_quiesce(statep);

                break;
        }

        return (DDI_SUCCESS);
    }

    /*
     * (*ddi_cbfunc)() routine.
     *
     * Adapt interrupt usage when availability changes.
     */
    int
    xx_cbfunc(dev_info_t *dip, ddi_cb_action_t cbaction, void *cbarg,
        void *arg1, void *arg2)
    {
        xx_state_t      *statep = (xx_state_t *)arg1;
        int             count;
        int             inum;
        int             nactual;

        switch (cbaction) {
        case DDI_CB_INTR_ADD:
        case DDI_CB_INTR_REMOVE:

             /* Get change in availability */
             count = (int)(uintptr_t)cbarg;

             /* Suspend hardware */
             xx_quiesce(statep);

             /* Tear down previous interrupt handling */
             for (inum = 0; inum < statep->nactual; inum++) {
                     ddi_intr_disable(statep->hdls[inum]);
                     ddi_intr_remove_handler(statep->hdls[inum]);
             }

             /* Adjust interrupt vector allocations */
             if (cbaction == DDI_CB_INTR_ADD) {

                     /* Allocate additional interrupt vectors */
                     ddi_intr_alloc(dip, statep->hdls, statep->type,
                         statep->nactual, count, &nactual, 0);

                     /* Update actual count of available interrupts */
                     statep->nactual += nactual;

             } else {

                     /* Free removed interrupt vectors */
                     for (inum = statep->nactual - count;
                         inum < statep->nactual; inum++) {
                             ddi_intr_free(statep->hdls[inum]);
                     }

                     /* Update actual count of available interrupts */
                     statep->nactual -= count;
             }

             /* Configure interrupt handling */
             xx_setup_interrupts(statep, statep->nactual, statep->intrs);

             /* Install and enable interrupt handlers */
             for (inum = 0; inum < statep->nactual; inum++) {
                     ddi_intr_add_handler(&statep->hdls[inum],
                         statep->intrs[inum].inthandler,
                         statep->intrs[inum].arg1,
                         statep->intrs[inum].arg2);
                     ddi_intr_enable(statep->hdls[inum]);
             }

             /* Resume hardware */
             xx_resume(statep);

             break;

        case DDI_CB_LSR_SUSPEND:

                plsr = (ddi_cb_lsr_t *) cbarg;
                if (plsr->impacts &
                    (DDI_CB_LSR_IMP_LOSE_POWER
                    | DDI_CB_LSR_IMP_DEVICE_REPLACE))
                        return DDI_NOTSUP;

                if (plsr->activities & DDI_CB_LSR_ACT_DMA) {
                        xx_stop_dma_engine(statep);
                        if (plsr->impacts
                            & DDI_CB_LSR_IMP_DMA_ADDR_CHANGE) {
                                xx_unbind_dma_buffer(statep);
                        }
                        if (plsr->impacts
                            & DDI_CB_LSR_IMP_DMA_PROP_CHANGE) {
                                xx_destroy_dma_handle(statep);
                        }
                }

                if (plsr->activities & DDI_CB_LSR_ACT_INTR) {
                        xx_disable_interrupts(statep);
                }

                if (plsr->activities & DDI_CB_LSR_ACT_PIO) {
                        xx_stop_pio(statep);
                }

                if (plsr->impacts & DDI_CB_LSR_IMP_DEVICE_RESET) {
                        /*
                         * may save the context to be restored for re-loaded
                         * firmware on resume
                         */
                        xx_save_hardware_context(statep);
                }

                statep->saved_lsr = *plsr;
                statep->lsr_state = XX_LSR_SUSPENDED;

                break;

        case DDI_CB_LSR_RESUME:

                if (statep->lsr_state != XX_LSR_SUSPENDED)
                        return (DDI_EINVAL);

                plsr = (ddi_cb_lsr_t *) cbarg;

                if (plsr->activities != statep->saved_lsr.activities
                    || plsr->impacts != statep->saved_lsr.impacts)
                        return (DDI_EINVAL);

                if (plsr->impacts & DDI_CB_LSR_IMP_DEVICE_RESET) {
                        xx_restore_hardware_context(statep);
                }

                if (plsr->activities & DDI_CB_LSR_ACT_DMA) {
                        if (plsr->impacts
                            & DDI_CB_LSR_IMP_DMA_PROP_CHANGE) {
                                xx_alloc_dma_handle(statep);
                        }
                        if (plsr->impacts
                            & DDI_CB_LSR_IMP_DMA_ADDR_CHANGE) {
                                xx_bind_dma_buffer(statep);
                        }
                        xx_start_dma_engine(statep);
                }

                if (plsr->activities & DDI_CB_LSR_ACT_INTR) {
                        xx_enable_interrupts(statep);
                }

                if (plsr->activities & DDI_CB_LSR_ACT_PIO) {
                        xx_enable_pio(statep);
                }

                statep->lsr_state = 0;

                break;

        case DDI_CB_LSR_QUERY_CAPABILITY:
                /*
                 * return the supported activities and impacts
                 */
                plsr = (ddi_cb_lsr_t *) cbarg;

                plsr->activities = DDI_CB_LSR_ACT_DMA | DDI_CB_LSR_ACT_PIO
                    | DDI_CB_LSR_ACT_INTR;
                plsr->impacts = DDI_CB_LSR_IMP_DEVICE_RESET
                    | DDI_CB_LSR_IMP_DMA_ADDR_CHANGE
                    | DDI_CB_LSR_IMP_DMA_PROP_CHANGE;

                    break;

     default:
             return (DDI_ENOTSUP);
     }

     return (DDI_SUCCESS);
 }

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Uncommitted
MT-Level
Unsafe

See Also

attributes(5), ddi_intr_alloc(9F), ddi_intr_free(9F), ddi_intr_set_nreq(9F), pciv_send(9F), pciv_vf_config(9F)

Notes

Users of these interfaces that register for DDI_CB_FLAG_INTR become participants in interrupt resource management. With that participation comes a responsibility to properly adjust interrupt usage. In the case of a DDI_CB_INTR_ADD action, the system guarantees that a driver can allocate a total number of interrupt resources up to its new number of available interrupts. The total number of interrupt resources is the sum of all resources allocated by the function ddi_intr_alloc(9F), minus all previously released by the function ddi_intr_free(9F). In the case of a DDI_CB_INTR_REMOVE action, the driver might have more interrupts allocated than are now currently available. It is necessary for the driver to release the excess interrupts, or it will have a negative impact on the interrupt availability for other drivers in the system.

A failure to release interrupts in response to a DDI_CB_INTR_REMOVE callback generates the following warning on the system console:

WARNING: <driver><instance>: failed to release interrupts for
        IRM (nintrs = ##, navail=##).

Participation in interrupt resource management ends when a driver uses the ddi_cb_unregister() function to unregister its callback function. The callback function must still operate properly until after the call to the ddi_cb_unregister() function completes. If addinterrupts were given to the driver because of its participation, then a final use of the callback function occurs to release the additional interrupts. The call to the ddi_cb_unregister() function blocks until the final use of the registered callback function is finished.