|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- retrieve a NDI event service cookie handle
#include <sys/dditypes.h> #include <sys/sunddi.h> int ddi_get_eventcookie(dev_info_t *dip, char *name, ddi_eventcookie_t *event_cookiep);
Solaris DDI specific (Solaris DDI).
Child device node requesting the cookie.
NULL-terminated string containing the name of the event.
Pointer to cookie where event cookie will be returned.
The ddi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by a calling up the device tree hierarchy until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached.
The cookie returned by this function can be used to register a callback handler, unregister a callback handler, or post an event.
Cookie handle is returned.
Request was not serviceable by any nexus driver in the driver's ancestral device tree hierarchy.
The ddi_get_eventcookie() function can be called from user and kernel contexts only.
See attributes(5) for a description of the following attributes: