|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- get identifier of current thread
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> kt_did_t ddi_get_kt_did(void);
Solaris DDI specific (Solaris DDI)
The ddi_get_kt_did() function returns a unique 64-bit identifier for the currently running thread.
This routine can be called from user, kernel, or interrupt context. This routine cannot be called from a high-level interrupt context.
ddi_get_kt_did() always returns the identifier for the current thread. There are no error conditions.
Writing Device Drivers
The value returned by this function can also be seen in adb or mdb as the did field displayed when using the thread macro.
This interface is intended for tracing and debugging purposes.