|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- send a message to the next queue
#include <sys/stream.h> #include <sys/ddi.h> void putnext(queue_t *q, mblk_t *mp);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue from which the message mp will be sent.
Message to be passed.
The putnext() function is used to pass a message to the put(9E) routine of the next queue in the stream.
The putnext() function can be called from user, interrupt, or kernel context.
See allocb(9F) for an example of using putnext().
The put() and putnext() functions should be called only after qprocson() is finished.