|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- stop receiving callbacks
#include <sys/sockfilter.h> void sof_bypass(sof_handle_t hdl);
per-socket filter handle
The sof_bypass() function informs the framework that the filter instance no longer wants to receive callbacks. No guarantee is made that there will not be any active callbacks when sof_bypass() returns, only that no new callbacks will be triggered.
The only callback that will triggered for a filter that has called sof_bypass() is sofop_detach(9E).
A typical use of sof_bypass() is for a filter that only needs to be active during a certain period of a socket's lifetime. Calling sof_bypass() will minimize the performance impact of the inactive filter.
The sof_bypass() function can be called from any context
See attributes(5) for descriptions of the following attributes: