|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library|
- structure for describing how to transmit a packet
Solaris DDI specific (Solaris DDI).
The net_inject_t data structure passes information in to net_inject about how to transmit a packet. Transmit includes sending the packet up into the system as well as out of it.
mblk_t *ni_packet; /* start of the packet */ struct sockaddr_storage ni_addr; /* address of next hop */ phy_if_t ni_physical; /* network interface to use */
Pointer to the first the mblk_t data structure that makes up this packet.
This field is only required to be initialized if NI_DIRECT_OUT is being used to transmit the packet. The sockaddr_storage field must be set to indicate whether the destination address contained in the structure is IPv4 (cast ni_addr to struct sockaddr_in) or IPv6 (cast ni_addr to struct sockaddr_in6).
The physical interface where the packet will be injected.
See attributes(5) for descriptions of the following attributes: