|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- convert a termcap description into a terminfo description
captoinfo [-1] [-v]... [-V] [-w width] filename...
captoinfo looks in filename for termcap descriptions. For each one found, an equivalent terminfo description is written to standard output, along with any comments found. A description which is expressed as relative to another description (as specified in the termcap tc = field) is reduced to the minimum superset before being displayed.
If no filename is given, then the environment variable TERMCAP is used for the filename or entry. If TERMCAP is a full pathname to a file, only the terminal whose name is specified in the environment variable TERM is extracted from that file. If the environment variable TERMCAP is not set, then the file /usr/share/lib/termcap is read.
Display the fields one to a line. Otherwise, the fields are printed several to a line, with a maximum width of 60 characters.
Display tracing information on the standard error as the program runs. Specifying additional -v options displays more detailed information.
Display the version of the program in use on the standard error and then exit.
Change the output to width characters.
compiled terminal description database
See attributes(5) for descriptions of the following attributes:
captoinfo should be used to convert termcap entries to terminfo entries because the termcap database may not be supplied in future releases.